forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/gegl: Fix USE="-jpeg -png" (bug #567582)
Package-Manager: portage-2.2.26
- Loading branch information
Showing
2 changed files
with
59 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,58 @@ | ||
From 86e5d9c3f51153afde57d8adbe22408cee6321d2 Mon Sep 17 00:00:00 2001 | ||
From: Sebastian Pipping <[email protected]> | ||
Date: Wed, 9 Dec 2015 01:48:31 +0100 | ||
Subject: [PATCH] Repair --without-libjpeg and --without-libpng | ||
|
||
--- | ||
configure.ac | 15 ++++++++------- | ||
1 file changed, 8 insertions(+), 7 deletions(-) | ||
|
||
diff --git a/configure.ac b/configure.ac | ||
index 5aa1f3b..95e519b 100644 | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -809,16 +809,16 @@ if test "x$with_libjpeg" != "xno" && test -z "$LIBJPEG"; then | ||
jpeg_ok="no (JPEG header file not found)" | ||
fi | ||
fi | ||
+ | ||
+ if test "$jpeg_ok" != "yes"; then | ||
+ AC_MSG_ERROR([Could not find a usable JPEG library with header files]) | ||
+ fi | ||
fi | ||
|
||
AM_CONDITIONAL(HAVE_JPEG, test "$jpeg_ok" = "yes") | ||
|
||
AC_SUBST(LIBJPEG) | ||
|
||
-if test "$jpeg_ok" != "yes"; then | ||
- AC_MSG_ERROR([Could not find a usable JPEG library with header files]) | ||
-fi | ||
- | ||
|
||
################## | ||
# Check for libpng | ||
@@ -831,6 +831,10 @@ if test "x$with_libpng" != "xno"; then | ||
PKG_CHECK_MODULES(PNG, libpng, | ||
have_libpng="yes", | ||
have_libpng="no (libpng not found)") | ||
+ | ||
+ if test "$have_libpng" != "yes"; then | ||
+ AC_MSG_ERROR([Could not find a usable PNG library with header files]) | ||
+ fi | ||
fi | ||
|
||
AM_CONDITIONAL(HAVE_PNG, test "$have_libpng" = "yes") | ||
@@ -838,9 +842,6 @@ AM_CONDITIONAL(HAVE_PNG, test "$have_libpng" = "yes") | ||
AC_SUBST(PNG_CFLAGS) | ||
AC_SUBST(PNG_LIBS) | ||
|
||
-if test "$have_libpng" != "yes"; then | ||
- AC_MSG_ERROR([Could not find a usable PNG library with header files]) | ||
-fi | ||
|
||
################### | ||
# Check for librsvg | ||
-- | ||
2.6.3 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters