Skip to content

Commit

Permalink
dev-games/freecell-solver: 5.20.1 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Mar 26, 2020
1 parent edf0722 commit fd85398
Show file tree
Hide file tree
Showing 4 changed files with 102 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-games/freecell-solver/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST freecell-solver-5.14.0.tar.xz 407912 BLAKE2B c9da3557d9d073e017215cb0e0c64bfabeeb001c6e8373cc7e35aac40b2722f18966bb7ebf041e869c9e5c1fdbf0fc24e652fef688707c3ee69b300d8fdc246c SHA512 21c8898673e402514c6d40ae0045d6e9077b1606430465bfb146507fbe098be6ca4f88d976e2dafadbc8e84b5aeb9325b58ce8a384ea4ed6de4f5fec485d51ea
DIST freecell-solver-5.20.1.tar.xz 420748 BLAKE2B 5322567ba4246f11deb74d298f069cfa0f093f7d15dda2132c97d04546fac47f979d3e3b69ee2ee0bdef92b3ff10aba27efda5782dc9ffdd9c7eb91ad7c419cd SHA512 439c55713f5fdb98fa90b203fb5a0d135e7f3aa249ee59e659ed371f7d4de03cc16945b3170f3c1fc4e2afe3733866a6db80945868e129589a4fdde00df51335
19 changes: 19 additions & 0 deletions dev-games/freecell-solver/files/freecell-solver-5.20.1-cmake.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
Package wants to install all kinds of doc files. It does not help us.

--- a/CMakeLists.txt 2019-09-12 23:04:19.628187073 +0200
+++ b/CMakeLists.txt 2019-09-12 23:06:38.928231282 +0200
@@ -858,14 +858,6 @@
INSTALL_MAN ("${fc_solve_manpage}" 6)
ENDIF ()

-INSTALL(
- FILES
- ${docs_to_install}
- "README.win32.txt"
- DESTINATION
- "share/doc/freecell-solver-5.20.1"
-)
-
SET (dest "include/freecell-solver")
INSTALL(
FILES
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
From f5801e70d0ade110e23595d00c62221f6dcd8845 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <[email protected]>
Date: Thu, 26 Mar 2020 13:28:29 +0100
Subject: [PATCH] Fix pkgconfig libdir path

Needs to respect LIB_SUFFIX to work.
---
libfreecell-solver.pc.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/libfreecell-solver.pc.in b/libfreecell-solver.pc.in
index 2eb1fe68f..4fc3c7fbb 100644
--- a/libfreecell-solver.pc.in
+++ b/libfreecell-solver.pc.in
@@ -1,6 +1,6 @@
prefix="@CMAKE_INSTALL_PREFIX@"
exec_prefix=${prefix}
-libdir=${exec_prefix}/lib
+libdir=${exec_prefix}/lib@LIB_SUFFIX@
includedir=${prefix}/include

Name: Freecell Solver
--
2.26.0

57 changes: 57 additions & 0 deletions dev-games/freecell-solver/freecell-solver-5.20.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,57 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{6,7,8} )
inherit cmake python-single-r1

DESCRIPTION="C library for automatically solving Freecell and some other solitaire variants"
HOMEPAGE="https://fc-solve.shlomifish.org/"
SRC_URI="https://fc-solve.shlomifish.org/downloads/fc-solve/${P}.tar.xz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="tcmalloc"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/pysol_cards[${PYTHON_MULTI_USEDEP}]
dev-python/random2[${PYTHON_MULTI_USEDEP}]
dev-python/six[${PYTHON_MULTI_USEDEP}]
')
tcmalloc? ( dev-util/google-perftools )
"
DEPEND="${RDEPEND}
dev-perl/Path-Tiny
dev-perl/Template-Toolkit
"

DOCS=( README.html )

PATCHES=(
"${FILESDIR}/${P}-cmake.patch"
"${FILESDIR}/${P}-pkgconfig.patch"
)

src_prepare() {
sed -i -e "s|share/doc/freecell-solver/|share/doc/${P}|" CMakeLists.txt || die

python_fix_shebang board_gen

cmake_src_prepare
}

src_configure() {
local mycmakeargs=(
-DBUILD_STATIC_LIBRARY=OFF
-DFCS_BUILD_DOCS=OFF
-DFCS_WITH_TEST_SUITE=OFF #requires unpackaged dependencies
-DFCS_AVOID_TCMALLOC=$(usex !tcmalloc)
)

cmake_src_configure
}

0 comments on commit fd85398

Please sign in to comment.