Skip to content

Commit

Permalink
dev-libs/libbpf-0.0.9: Version bump
Browse files Browse the repository at this point in the history
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.101, Repoman-2.3.22
Signed-off-by: Patrick McLean <[email protected]>
  • Loading branch information
patrick-mclean authored and chutz committed Jun 19, 2020
1 parent e45fa00 commit fd96caa
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libbpf/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST libbpf-0.0.6.tar.gz 213791 BLAKE2B 9f0a08cc7bae41f7fa93d5ba2f535f76ce47fe691efb6bac6257b88a5607deb62fa53f59984d83b6070ccd573c902899f7528b376d9acbfd77317659de6ab061 SHA512 1678133d9a2bd1cf13d4d1f9b83bb3f0642de91e3e3c8d785e2993257035573aff39b9a1a457e73d9c4c1c66b6a52544a8ad06ac560766d335428bb3fc421e71
DIST libbpf-0.0.7.tar.gz 262068 BLAKE2B e77ff25449274881ddb9d32f25cd6ad8988e4524102bd109049ee6cfce3e2753fd99ebe2a080f809a4c5422dbf6b17633e4b0cea156f289bf95b92f8375a273c SHA512 c2cbc869b7e11339deab3152a6e2d0b3bba25da513d18d77fb0a698cbe61d6bd48175a58e7dd7a3695fbf27faf48b4f517ac5d3a3c66c086df2e5d1b73a2595d
DIST libbpf-0.0.8.tar.gz 262519 BLAKE2B 2a3620c97834cc23e716476b6966c1c65c1c82064b3ba1ae4ab4906ae362a777d9aa7ae40620f9a259fe969a5a897e97c14d97f627f39c47fa28c89abb1efa9a SHA512 1074fb52b7a158e4e2713c4c7083528ccf2d99b899853078f230234ba112071bfa66e174d8800d36516e26d5bf06da44d100a5b2f866d267f62c9308f431220c
DIST libbpf-0.0.9.tar.gz 273706 BLAKE2B 54dc77a8e415c24e6394877fc9ad54daca78a4e4f4779607e977708e8b88b6d7bb5854b618a808b1758529b9fdd574fc85f5969791a88b9a124cc42b63f7a161 SHA512 597ac41ab1727c48f2c53c9626b482ae7abd558b4c7d237e33206e3292295d5e5c2f56d31063d30caedccdc3fd289c040f718ff9aaaf210920f1b9c4c772660d
47 changes: 47 additions & 0 deletions dev-libs/libbpf/libbpf-0.0.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs

HOMEPAGE="https://github.com/libbpf/libbpf"
DESCRIPTION="Stand-alone build of libbpf from the Linux kernel"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2.1 BSD-2"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="+static-libs"

COMMON_DEPEND="virtual/libelf
!<=dev-util/bcc-0.7.0"
DEPEND="${COMMON_DEPEND}
sys-kernel/linux-headers"
RDEPEND="${COMMON_DEPEND}"

S="${WORKDIR}/${P}/src"

PATCHES=(
"${FILESDIR}/libbpf-0.0.7-paths.patch"
)

src_compile() {
emake \
BUILD_SHARED=y \
LIBSUBDIR="$(get_libdir)" \
$(usex static-libs 'BUILD_STATIC=y' '' '' '') \
CC="$(tc-getCC)"
}

src_install() {
emake \
BUILD_SHARED=y \
LIBSUBDIR="$(get_libdir)" \
DESTDIR="${D}" \
$(usex static-libs 'BUILD_STATIC=y' '' '' '') \
install install_uapi_headers

insinto /usr/$(get_libdir)/pkgconfig
doins ${PN}.pc
}

0 comments on commit fd96caa

Please sign in to comment.