forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Gentoo-bug: 572894 Package-Manager: portage-2.2.27
- Loading branch information
Michael Palimaka
committed
Jan 29, 2016
1 parent
c04c058
commit fde5d3c
Showing
2 changed files
with
98 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST trojita-0.4.1.tar.bz2 1219460 SHA256 68a17498e70fd66966917fe4ecb90e6fe6f36f439c714552b8a97c004fe687de SHA512 f24210d4f8e10cfbca25ab4d62ae3c8eea3e8824c13119cd6dc4511d4cf9b5f82be67586b6494aff5290ab06f869ae3bd1c8a19664bcf0f57059ee8d67d6c81a WHIRLPOOL 47652af26fe24c6fb7fb0dbb1ef7c00710d087903787a847b59dc80d61dcd1725b5c7444aa77e36b357c3bbd6bc64f0566a995ac5b3c53842c3744b1a82127c0 | ||
DIST trojita-0.5.tar.bz2 1421368 SHA256 21d8f0bf12b7d6dc39344ab70f4a0cb5b1997a3b60dc502841272ac92959458a SHA512 c3d661b5a49ca083fe7f09f598138f70a6ace5d66760bfe1242b06fcc90cb73abb56a1c27329f8de48eea281a782f8c5b6e1b374e271c33c9907070b5883b904 WHIRLPOOL 59a8bb257226edb4e34445766b5e5e500cae7205cf2ecf64fd80216f77d2e662395c4055744b84e0509311c635c93813849ec83b2ed5ec8212cb4553a118cadd | ||
DIST trojita-0.6.tar.bz2 1409812 SHA256 4c1083f48b51cc37bb318c5a8ada67b64b38ed95d8ad30b4621755fcf45efa10 SHA512 de13437b9c046b3db317c62cbf4fbff5607ad807378a7ef9ba239609aba2e49933a2f0aa9645777536e5c03e2af612164b96d15b731570597b0d4de187d1b350 WHIRLPOOL e81ff5a5759ec2182f1e8e68c478b70c80e2715560dda3c7095e7d897eab1e0d5cb45d2f8e15ba133a0bb31351f59b7a507011bdb637401c28147d456b51145d |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,97 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
QT4_REQUIRED="4.8.0" | ||
EGIT_REPO_URI="git://anongit.kde.org/${PN}.git" | ||
inherit cmake-utils fdo-mime gnome2-utils qmake-utils virtualx | ||
[[ ${PV} == 9999 ]] && inherit git-r3 | ||
|
||
DESCRIPTION="A Qt IMAP e-mail client" | ||
HOMEPAGE="http://trojita.flaska.net/" | ||
if [[ ${PV} != 9999 ]]; then | ||
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2" | ||
KEYWORDS="~amd64 ~x86" | ||
fi | ||
|
||
LICENSE="|| ( GPL-2 GPL-3 )" | ||
SLOT="0" | ||
IUSE="debug +dbus +password +qt5 test +zlib" | ||
|
||
RDEPEND=" | ||
qt5? ( | ||
dev-qt/qtcore:5 | ||
dev-qt/qtgui:5 | ||
dev-qt/qtnetwork:5[ssl] | ||
dev-qt/qtsql:5[sqlite] | ||
dev-qt/qtwebkit:5 | ||
dev-qt/qtwidgets:5 | ||
) | ||
!qt5? ( | ||
>=dev-qt/qtbearer-${QT4_REQUIRED}:4 | ||
>=dev-qt/qtcore-${QT4_REQUIRED}:4 | ||
>=dev-qt/qtgui-${QT4_REQUIRED}:4 | ||
>=dev-qt/qtsql-${QT4_REQUIRED}:4[sqlite] | ||
>=dev-qt/qtwebkit-${QT4_REQUIRED}:4 | ||
) | ||
dbus? ( dev-qt/qtdbus:5 ) | ||
password? ( | ||
qt5? ( dev-libs/qtkeychain[qt5] ) | ||
!qt5? ( dev-libs/qtkeychain[qt4] ) | ||
) | ||
zlib? ( sys-libs/zlib ) | ||
" | ||
DEPEND="${RDEPEND} | ||
qt5? ( dev-qt/linguist-tools:5 ) | ||
test? ( | ||
qt5? ( dev-qt/qttest:5 ) | ||
!qt5? ( >=dev-qt/qttest-${QT4_REQUIRED}:4 ) | ||
) | ||
zlib? ( virtual/pkgconfig ) | ||
" | ||
|
||
DOCS="README LICENSE" | ||
|
||
src_prepare() { | ||
cmake-utils_src_prepare | ||
|
||
# the build system is taking a look at `git describe ... --dirty` and | ||
# gentoo's modifications to CMakeLists.txt break these | ||
sed -i "s/--dirty//" "${S}/cmake/TrojitaVersion.cmake" || die "Cannot fix the version check" | ||
|
||
# ensure correct version of binary is used - bug 544108. | ||
# this file is only used for qt4 builds | ||
sed -i "s|\$ENV{QTDIR}/bin|$(qt4_get_bindir) NO_DEFAULT_PATH|" cmake/FindLinguistForTrojita.cmake || die | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DWITH_DBUS=$(usex dbus) | ||
-DWITH_QT5=$(usex qt5) | ||
-DWITH_QTKEYCHAINPLUGIN=$(usex password) | ||
-DWITH_TESTS=$(usex test) | ||
-DWITH_ZLIB=$(usex zlib) | ||
) | ||
|
||
cmake-utils_src_configure | ||
} | ||
|
||
src_test() { | ||
virtx cmake-utils_src_test | ||
} | ||
|
||
pkg_preinst() { | ||
gnome2_icon_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
fdo-mime_desktop_database_update | ||
gnome2_icon_cache_update | ||
} | ||
|
||
pkg_postrm() { | ||
fdo-mime_desktop_database_update | ||
gnome2_icon_cache_update | ||
} |