forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/testrepository: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <[email protected]>
- Loading branch information
Showing
1 changed file
with
42 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="A repository of test results" | ||
HOMEPAGE="https://launchpad.net/testscenarios" | ||
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux" | ||
IUSE="test" | ||
|
||
RDEPEND=" | ||
>=dev-python/subunit-0.0.10[${PYTHON_USEDEP}] | ||
>=dev-python/testtools-0.9.30[${PYTHON_USEDEP}] | ||
dev-python/fixtures[${PYTHON_USEDEP}]" | ||
#bzr is listed but presumably req'd for a live repo test run | ||
|
||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( ${RDEPEND} | ||
dev-python/testresources[${PYTHON_USEDEP}] | ||
dev-python/testscenarios[${PYTHON_USEDEP}] | ||
dev-python/pytz[${PYTHON_USEDEP}] | ||
)" | ||
|
||
# Required for test phase | ||
DISTUTILS_IN_SOURCE_BUILD=1 | ||
|
||
python_test() { | ||
# some errors appear to have crept in the suite undert py3 since addition. | ||
# Python2.7 now passes all. | ||
|
||
esetup.py testr --coverage | ||
} |