Skip to content

Commit

Permalink
app-vim/splice: add python3.6 support.
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/658840
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
monsieurp committed Dec 13, 2019
1 parent e0fb3fd commit ff1103a
Showing 1 changed file with 35 additions and 0 deletions.
35 changes: 35 additions & 0 deletions app-vim/splice/splice-1.1.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python3_6 )

inherit vim-plugin python-single-r1 vcs-snapshot

DESCRIPTION="vim plugin: resolve conflicts during three-way merges"
HOMEPAGE="https://bitbucket.org/sjl/splice.vim/ https://www.vim.org/scripts/script.php?script_id=4026"
SRC_URI="https://bitbucket.org/sjl/${PN}.vim/get/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
KEYWORDS="~amd64 ~x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="
${PYTHON_DEPS}
|| (
app-editors/vim[python,${PYTHON_USEDEP}]
app-editors/gvim[python,${PYTHON_USEDEP}]
)"

VIM_PLUGIN_HELPFILES="${PN}.txt"

src_prepare() {
default
rm .[a-z]* Makefile LICENSE.markdown package.sh || die
rm -r site || die
}

src_install() {
vim-plugin_src_install
python_optimize "${ED}"/usr/share/vim/vimfiles/autoload/splicelib
}

0 comments on commit ff1103a

Please sign in to comment.