Skip to content

Commit

Permalink
app-misc/figlet: fix building on musl
Browse files Browse the repository at this point in the history
* The patch is from Alpine and the ebuild changes are
  not copyrightable.

Closes: gentoo#20385
Closes: https://bugs.gentoo.org/608172
Package-Manager: Portage-3.0.18, Repoman-3.0.3
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed May 1, 2021
1 parent 04fd34c commit ff505ac
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 0 deletions.
2 changes: 2 additions & 0 deletions app-misc/figlet/figlet-2.2.5-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -13,6 +13,8 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"

PATCHES=( "${FILESDIR}"/${P}-musl.patch )

src_compile() {
emake clean
emake \
Expand Down
36 changes: 36 additions & 0 deletions app-misc/figlet/files/figlet-2.2.5-musl.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
From 88428a728e1f99dcdc63d7c5ff0cd8b6cda37576 Mon Sep 17 00:00:00 2001
From: Natanael Copa <[email protected]>
Date: Tue, 3 Jun 2014 10:59:40 +0000
Subject: [PATCH] Fix build with musl libc

Avoid using the glibc internal macros __BEGIN/__END_DECLS.

Signed-off-by: Natanael Copa <[email protected]>
---
utf8.h | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)

diff --git a/utf8.h b/utf8.h
index 0631b8a..a3e09bd 100644
--- a/utf8.h
+++ b/utf8.h
@@ -27,13 +27,17 @@
#define UTF8_IGNORE_ERROR 0x01
#define UTF8_SKIP_BOM 0x02

-__BEGIN_DECLS
+#ifdef __cplusplus
+extern "C" {
+#endif

size_t utf8_to_wchar(const char *in, size_t insize, wchar_t *out,
size_t outsize, int flags);
size_t wchar_to_utf8(const wchar_t *in, size_t insize, char *out,
size_t outsize, int flags);

-__END_DECLS
+#ifdef __cplusplus
+}
+#endif

#endif /* !_UTF8_H_ */

0 comments on commit ff505ac

Please sign in to comment.