Skip to content

Commit

Permalink
app-i18n/skkfep: add support for annotation
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
hattya committed Jun 25, 2017
1 parent 46427f7 commit ff74335
Show file tree
Hide file tree
Showing 2 changed files with 30 additions and 0 deletions.
29 changes: 29 additions & 0 deletions app-i18n/skkfep/files/skkfep-annotation.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
--- a/kkconv.c
+++ b/kkconv.c
@@ -645,6 +645,7 @@
char c;
{
int l;
+ char *p;
DicList dlist;

kanjiSelectionEffect(0);
@@ -653,7 +654,17 @@
if (OkuriInput)
l += strlen(OkuriBuf);
csrLeft(l);
- writeShells(CurrentCand->candword);
+ p= strrchr(CurrentCand->candword,';');
+ if (p != NULL) {
+ erase(l);
+ csrLeft(l);
+ l -= strlen(p);
+ *p = '\0';
+ writeShells(CurrentCand->candword);
+ *p = ';';
+ } else {
+ writeShells(CurrentCand->candword);
+ }
if (OkuriInput) {
writeShells(OkuriBuf);
}
1 change: 1 addition & 0 deletions app-i18n/skkfep/skkfep-0.87-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,7 @@ RDEPEND="sys-libs/ncurses:=
PATCHES=(
"${FILESDIR}"/${PN}-gentoo.patch
"${FILESDIR}"/${PN}-system-dic.patch
"${FILESDIR}"/${PN}-annotation.patch
)
DOCS=( README HISTORY TODO )

Expand Down

0 comments on commit ff74335

Please sign in to comment.