Skip to content

Commit

Permalink
dev-perl/Cpanel-JSON-XS: Bump to version 4.240.0
Browse files Browse the repository at this point in the history
Upstream:
- Fix decode_json($json, $allow_nonref) failing to reject
  $json that decode to non-references when $allow_nonref
  is false.

Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Kent Fredric <[email protected]>
  • Loading branch information
kentfredric committed Oct 7, 2020
1 parent 7f1e7fa commit ff8678e
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
50 changes: 50 additions & 0 deletions dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.240.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DIST_AUTHOR=RURBAN
DIST_VERSION=4.24
DIST_EXAMPLES=("eg/*")
inherit perl-module

DESCRIPTION="cPanel fork of JSON::XS, fast and correct serializing"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
>=virtual/perl-Math-BigInt-1.160.0
virtual/perl-Carp
>=virtual/perl-Encode-1.980.100
virtual/perl-Exporter
virtual/perl-XSLoader
>=virtual/perl-podlators-2.80.0
"
BDEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
virtual/perl-Data-Dumper
virtual/perl-Test
virtual/perl-Test-Simple
virtual/perl-Time-Piece
)
"
src_compile() {
mymake=(
"OPTIMIZE=${CFLAGS}"
)
perl-module_src_compile
}
src_test() {
ewarn "Comprehensive testing may require manual installation of dependencies"
ewarn " See: https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}#Tests"
perl-module_src_test
}
pkg_postinst() {
ewarn "This package provides 'cpanel_json_xs' in PATH, which includes optional features"
ewarn "otherwise not automatically made available yet. If you desire to use these,"
ewarn "please consult:"
ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}#Optional_Features"
}
1 change: 1 addition & 0 deletions dev-perl/Cpanel-JSON-XS/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST Cpanel-JSON-XS-4.19.tar.gz 251461 BLAKE2B fa22192d017fc41327e71b84f47e3939765b0c48586cc31876f744c2a51a93b36f6d41b8c9f92bba04875123604efe3fed6a486839dbfb39623cb2a4a4064087 SHA512 c67b62e8f95900cb3626357cfa9976f1553f84ffd10a977d47839ca3b317014473c3a6e48f6680478b89bbdc2ac177b22441ad5e49e7e8eb0344ef14a3c52b10
DIST Cpanel-JSON-XS-4.21.tar.gz 253372 BLAKE2B ad090f758d4b7b1f81ee01cb7860a952ca25c028c8043e33898593eb4818e5746d56eed0101656d95b68be54d68589ee7bb174e09e990d4a139448b422e8c542 SHA512 1408fed400e3e792af156695a5437e479a30cafb7d0597afc80c04de9b46882b67f75920f5f32047ed498bf088c9430108cea6863cfd2e6314765688f2c610e0
DIST Cpanel-JSON-XS-4.23.tar.gz 253594 BLAKE2B e9cb66c58015f6b83f00f588e9afc7c360182b67ceffcb90a76c2ebb1ad922250a5f2cec1049a79aea03789248d89669b4c787017bfdb6710f8576ab1e5b2948 SHA512 1c0d70ff85a2217c2b326c8002766e237966e0fcdac447fbb5108a5ba98b2771db17731853f2f7bedf85c337c7f6e18333c2c235830a17e152e7838bd168d0f9
DIST Cpanel-JSON-XS-4.24.tar.gz 254008 BLAKE2B 4449d0d562388c547ab26e87048b49d2e77e7508c8bc2c4db4af562ecfed768452cea1daca60e8ce59ed464b9d4ceca17d73326a16bec3e3a6d42bd6e13df7fe SHA512 311746bd6d686f758db4507c1219675b262205a8d798662b8f5521d3f9c7d76678580a30e26281b461647763d552cb76fdbbcf4aa1737dc7c7416364179741bb

0 comments on commit ff8678e

Please sign in to comment.