Skip to content

Commit

Permalink
app-editors/retext: Version bump to 6.0.1
Browse files Browse the repository at this point in the history
Gentoo-Bugs: 591768

Package-Manager: portage-2.3.0
  • Loading branch information
mrueg committed Sep 4, 2016
1 parent d4bd3d6 commit fff2353
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-editors/retext/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST ReText-4.1.3.tar.gz 129283 SHA256 bb4409982d27ac62cab01b0748fe41d9c6660853668b350f3369e76d155edd6c SHA512 d2b3fa901afa9870f6cecc7ab3126b91f1420ca1b14ddd4f609c2ada7121388840b5be679914694664f3bbf876ee8522aa6b0c82a23f837844f788fa10a46323 WHIRLPOOL 3be71e5d7ec612ae4e4fec17ca544f6d0e7cb7421fcdeb517d3c13156ed07f5e5e7c3e352cf604bfb5f2287964fdc173a1bac0eeab41ee1cda8b265ad0f57686
DIST ReText-5.3.1.tar.gz 159669 SHA256 515b1aaa57615453f8933f997753072a5c4691793da2280e70d1b333b53904c6 SHA512 76c6f78c10129e4845de819fa6db3deff5441a25331fd3dadbdfeb766caa453f21214f82e6625c919cc8be2fcfdfada970cae32837bb8904c3702dda19890628 WHIRLPOOL 5c2db75c2b2f23419bc2803849f6b7a69f3540911c6e53f46a46baffd150a9a0db75d0343361963a53bcc1a6da4534eb72d99068a26c13c1551b6188ab81f67a
DIST ReText-6.0.1.tar.gz 184098 SHA256 7c9785cb022d2f0b123b8a808c2419cf1300249d594a72a5ef5a0030de8bb630 SHA512 aca8db5d82fadee7b8d03279e080b33da696339eb674ba1fc2dd4ced7c92b1608d8ed2d181bdbe913601d63755df38ebdfa06f77398e1b52cc922f54fc0fe867 WHIRLPOOL 0590b347e7ca21d7e6e653c74fd53abe2ccb0852e6ab3f53213f8beb38234b0b757bf60ba77f68e485b68332d3b06def94aa4b9aebae369e472a876ce34d9b77
51 changes: 51 additions & 0 deletions app-editors/retext/retext-6.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python3_{4,5} )

PLOCALES="ca cs cy da de es et eu fr hu it ja pl pt pt_BR ru sk sr sr@latin uk zh_TW"

inherit distutils-r1 l10n

MY_PN="ReText"
MY_P="${MY_PN}-${PV/_/~}"

DESCRIPTION="Simple editor for Markdown and reStructuredText"
HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+spell"

RDEPEND="
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/markdown[${PYTHON_USEDEP}]
>=dev-python/markups-2[${PYTHON_USEDEP}]
>=dev-python/chardet-2.3[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt5[gui,network,printsupport,webkit,widgets,${PYTHON_USEDEP}]
spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )
"

S="${WORKDIR}"/${MY_P}

remove_locale() {
find "${ED}" -name "retext_${1}.qm" -delete || die "Failed to remove locale ${1}."
}

python_test() {
esetup.py test
}

python_install_all() {
distutils-r1_python_install_all

l10n_for_each_disabled_locale_do remove_locale

make_desktop_entry ${PN} "${MY_PN} Editor" ${PN} "Development;Utility;TextEditor"
}

0 comments on commit fff2353

Please sign in to comment.