Skip to content

Commit

Permalink
sys-fs/multipath-tools: fix systemd version detection (bug #590604)
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
dev-zero committed Aug 21, 2016
1 parent dc6cc89 commit fff54f8
Showing 1 changed file with 9 additions and 3 deletions.
12 changes: 9 additions & 3 deletions sys-fs/multipath-tools/multipath-tools-0.6.2-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand Down Expand Up @@ -30,10 +30,16 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.6.2-makefile.patch
)

get_systemd_pv() {
use systemd && \
$(tc-getPKG_CONFIG) --modversion systemd
}

src_compile() {
# LIBDM_API_FLUSH involves grepping files in /usr/include,
# so force the test to go the way we want #411337.
emake LIBDM_API_FLUSH=1 CC="$(tc-getCC)" SYSTEMD=$(usex systemd 1 "")
emake \
LIBDM_API_FLUSH=1 CC="$(tc-getCC)" SYSTEMD="$(get_systemd_pv)"
}

src_install() {
Expand All @@ -42,7 +48,7 @@ src_install() {
dodir /sbin /usr/share/man/man{5,8}
emake \
DESTDIR="${D}" \
SYSTEMD=$(usex systemd 1 "") \
SYSTEMD=$(get_systemd_pv) \
unitdir="$(systemd_get_systemunitdir)" \
libudevdir='${prefix}'/"${udevdir}" \
install
Expand Down

0 comments on commit fff54f8

Please sign in to comment.