Skip to content

Tags: mrgordon/client_ruby

Tags

v0.7.2

Toggle v0.7.2's commit message
Looks like mmap refactor tries to call total on hash which is an error

v0.7.1

Toggle v0.7.1's commit message

Verified

This tag was signed with the committer’s verified signature.
grobie Tobias Schmidt
v0.7.1 / 2017-05-24

- [BUGFIX] Add missing _bucket suffix to histogram metrics

v0.7.0

Toggle v0.7.0's commit message

Verified

This tag was signed with the committer’s verified signature.
grobie Tobias Schmidt
v0.7.0

- [CHANGE] Rewrite Rack middlewares
  - Renamed middlewares to Prometheus::Middleware::*
  - Collector uses histogram instead of summary
  - Adjusted Collector metrics to adhere to our best practices
  - Reduced Collector label cardinality by default
  - See prometheus#32
- [FEATURE] Add support for pushgateway deletes
- [FEATURE] Allow pushing metrics via TLS
- [ENHANCEMENT] Improve example application and docs
- [ENHANCEMENT] Remove extra Proc allocation from metrics sync
- [BUGFIX] Handle setting a gauge value to nil
- [BUGFIX] Validate metric name format

Verified

This tag was signed with the committer’s verified signature.
grobie Tobias Schmidt

v0.6.0

Toggle v0.6.0's commit message

Verified

This tag was signed with the committer’s verified signature.
grobie Tobias Schmidt
v0.6.0

- [CHANGE] Remove redundant `http_request_duration_total_seconds` metric from rack collector
- [FEATURE] Add histogram support
- [ENHANCEMENT] Rename Summary#add to Summary#observe. Summary#add usage is deprecated

v0.5.0

Toggle v0.5.0's commit message
v0.5.0

- [CHANGE] Adjust default HTTP metric names
  `http_request_durations_microseconds` to `http_request_duration_seconds`
- [CHANGE] Remove deprecated JSON exposition format
- [CHANGE] Remove deprecated Counter#decrement
- [ENHANCEMENT] Document recommended usage of gzip middleware
- [ENHANCEMENT] Add host to labels of default HTTP metrics

v0.4.2

Toggle v0.4.2's commit message
Version 0.4.2

v0.4.1

Toggle v0.4.1's commit message
Version 0.4.1

Fixes:

* Reflect latest add/replace semantic changes

v0.4.0

Toggle v0.4.0's commit message
Version 0.4.0

Changes:

* replaced Push#push with Push#add and Push#replace

v0.3.1

Toggle v0.3.1's commit message
Version 0.3.1

Fixes:

* Content-Negotiation fallbacks to JSON format for empty or '*/*' Accept header