Skip to content

Commit

Permalink
ramips: Add support for Phicomm PSG1208
Browse files Browse the repository at this point in the history
This patch adds support for Phicomm PSG1208.This is a router with MT7620A SoC with 8M flash and 64M ram.
The WPS led is uesd as status_led because the power light can't be controlled with GPIO.
It seems that the 5g wifi led is connected to MT7612E and it can't be controlled with GPIO too.

Signed-off-by: Chuanhong Guo <[email protected]>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48721 3c298f89-4303-0410-b956-a3cf2f4a3e73
  • Loading branch information
John Crispin committed Feb 15, 2016
1 parent 6ed3133 commit ffaee94
Show file tree
Hide file tree
Showing 8 changed files with 142 additions and 1 deletion.
3 changes: 3 additions & 0 deletions target/linux/ramips/base-files/etc/board.d/01_leds
Original file line number Diff line number Diff line change
Expand Up @@ -208,6 +208,9 @@ pbr-m1)
ucidef_set_led_default "power" "power" "$board:blue:power" "1"
ucidef_set_led_default "sys" "sys" "$board:blue:sys" "1"
;;
psg1208)
set_wifi_led "$board:white:wlan2g"
;;
px-4885)
set_wifi_led "$board:orange:wifi"
set_usb_led "$board:blue:storage"
Expand Down
1 change: 1 addition & 0 deletions target/linux/ramips/base-files/etc/board.d/02_network
Original file line number Diff line number Diff line change
Expand Up @@ -74,6 +74,7 @@ ramips_setup_interfaces()
mzk-w300nh2|\
oy-0001|\
pbr-m1|\
psg1208|\
sap-g3200u3|\
wf-2881|\
whr-300hp2|\
Expand Down
3 changes: 2 additions & 1 deletion target/linux/ramips/base-files/etc/diag.sh
Original file line number Diff line number Diff line change
Expand Up @@ -75,7 +75,8 @@ get_status_led() {
dir-645)
status_led="$board:green:wps"
;;
cf-wr800n)
cf-wr800n|\
psg1208)
status_led="$board:white:wps"
;;
cy-swr1100|\
Expand Down
3 changes: 3 additions & 0 deletions target/linux/ramips/base-files/lib/ramips.sh
Original file line number Diff line number Diff line change
Expand Up @@ -292,6 +292,9 @@ ramips_board_detect() {
*"PBR-M1")
name="pbr-m1"
;;
*"PSG1208")
name="psg1208"
;;
*"PSR-680W"*)
name="psr-680w"
;;
Expand Down
1 change: 1 addition & 0 deletions target/linux/ramips/base-files/lib/upgrade/platform.sh
Original file line number Diff line number Diff line change
Expand Up @@ -84,6 +84,7 @@ platform_check_image() {
nw718|\
oy-0001|\
pbr-m1|\
psg1208|\
psr-680w|\
px-4885|\
re6500|\
Expand Down
114 changes: 114 additions & 0 deletions target/linux/ramips/dts/PSG1208.dts
Original file line number Diff line number Diff line change
@@ -0,0 +1,114 @@
/dts-v1/;

/include/ "mt7620a.dtsi"

/ {
compatible = "PSG1208", "ralink,mt7620a-soc";
model = "Phicomm PSG1208";

palmbus@10000000 {
gpio1: gpio@638 {
status = "okay";
};

gpio3: gpio@688 {
status = "okay";
};

spi@b00 {
status = "okay";

m25p80@0 {
#address-cells = <1>;
#size-cells = <1>;
compatible = "jedec,spi-nor";
reg = <0 0>;
linux,modalias = "m25p80", "en25q64";
spi-max-frequency = <10000000>;

partition@0 {
label = "u-boot";
reg = <0x0 0x30000>;
read-only;
};

partition@20000 {
label = "u-boot-env";
reg = <0x30000 0x10000>;
read-only;
};

factory: partition@30000 {
label = "factory";
reg = <0x40000 0x10000>;
read-only;
};

partition@40000 {
label = "firmware";
reg = <0x50000 0x7b0000>;
};
};
};
};

pinctrl {
state_default: pinctrl0 {
gpio {
ralink,group = "i2c", "uartf", "rgmii1", "rgmii2", "ephy", "wled", "nd_sd";
ralink,function = "gpio";
};
};
};

ethernet@10100000 {
pinctrl-names = "default";
pinctrl-0 = <&ephy_pins>;
mtd-mac-address = <&factory 0x4>;
mediatek,portmap = "llllw";
};

pcie@10140000 {
status = "okay";

pcie-bridge {
mt76@0,0 {
reg = <0x0000 0 0 0 0>;
device_type = "pci";
mediatek,mtd-eeprom = <&factory 0x8000>;
mediatek,2ghz = <0>;
};
};
};

wmac@10180000 {
ralink,mtd-eeprom = <&factory 0>;
};

gpio-leds {
compatible = "gpio-leds";

wan {
label = "psg1208:white:wps";
gpios = <&gpio1 15 1>;
};

wlan {
label = "psg1208:white:wlan2g";
gpios = <&gpio3 0 1>;
};
};

gpio-keys-polled {
compatible = "gpio-keys-polled";
#address-cells = <1>;
#size-cells = <0>;
poll-interval = <20>;

reset {
label = "reset";
gpios = <&gpio0 1 1>;
linux,code = <0x198>;
};
};
};
2 changes: 2 additions & 0 deletions target/linux/ramips/image/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -937,6 +937,7 @@ Image/Build/Profile/HC5661=$(call BuildFirmware/Default16M/$(1),$(1),hc5661,HC56
Image/Build/Profile/HC5761=$(call BuildFirmware/Default16M/$(1),$(1),hc5761,HC5761)
Image/Build/Profile/HC5861=$(call BuildFirmware/Default16M/$(1),$(1),hc5861,HC5861)
Image/Build/Profile/OY-0001=$(call BuildFirmware/Default16M/$(1),$(1),oy-0001,OY-0001)
Image/Build/Profile/PSG1208=$(call BuildFirmware/Default8M/$(1),$(1),psg1208,PSG1208)
Image/Build/Profile/Y1=$(call BuildFirmware/Default16M/$(1),$(1),y1,Y1)
Image/Build/Profile/Y1S=$(call BuildFirmware/Default16M/$(1),$(1),y1s,Y1S)
Image/Build/Profile/MLW221=$(call BuildFirmware/Default16M/$(1),$(1),mlw221,MLW221)
Expand Down Expand Up @@ -978,6 +979,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/HC5761,$(1))
$(call Image/Build/Profile/HC5861,$(1))
$(call Image/Build/Profile/OY-0001,$(1))
$(call Image/Build/Profile/PSG1208,$(1))
$(call Image/Build/Profile/Y1,$(1))
$(call Image/Build/Profile/Y1S,$(1))
$(call Image/Build/Profile/MLW221,$(1))
Expand Down
16 changes: 16 additions & 0 deletions target/linux/ramips/mt7620/profiles/phicomm.mk
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
#
# Copyright (C) 2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#

define Profile/PSG1208
NAME:=Phicomm PSG1208
PACKAGES:=kmod-mt76
endef

define Profile/PSG1208/Description
Default package set for Phicomm PSG1208.
endef
$(eval $(call Profile,PSG1208))

0 comments on commit ffaee94

Please sign in to comment.