Skip to content

Commit

Permalink
patches: fixed for used kernel
Browse files Browse the repository at this point in the history
  • Loading branch information
pavelpernicka committed Apr 5, 2021
1 parent d8c7050 commit 62b3f4b
Show file tree
Hide file tree
Showing 10 changed files with 7 additions and 325 deletions.
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -39,6 +39,7 @@ dtb-$(CONFIG_SOC_AT91SAM9) += \
at91-ariettag25.dtb \
at91-cosino_mega2560.dtb \
at91-kizboxmini.dtb \
@@ -42,6 +42,7 @@
at91-kizboxmini-mb.dtb \
at91-kizboxmini-rd.dtb \
at91-smartkiz.dtb \
+ at91-q5xr5.dtb \
at91-wb45n.dtb \
at91sam9g15ek.dtb \
Expand Down
24 changes: 0 additions & 24 deletions target/linux/generic/backport-5.4/011-kbuild-export-SUBARCH.patch

This file was deleted.

This file was deleted.

This file was deleted.

Original file line number Diff line number Diff line change
Expand Up @@ -26,14 +26,6 @@ Signed-off-by: Russell King <[email protected]>
/**
* struct sfp_bus - internal representation of a sfp bus
*/
@@ -22,6 +28,7 @@ struct sfp_bus {
const struct sfp_socket_ops *socket_ops;
struct device *sfp_dev;
struct sfp *sfp;
+ const struct sfp_quirk *sfp_quirk;

const struct sfp_upstream_ops *upstream_ops;
void *upstream;
@@ -31,6 +38,46 @@ struct sfp_bus {
bool started;
};
Expand Down Expand Up @@ -99,13 +91,3 @@ Signed-off-by: Russell King <[email protected]>
+
if (ops && ops->module_insert)
ret = ops->module_insert(bus->upstream, id);

@@ -623,6 +675,8 @@ void sfp_module_remove(struct sfp_bus *b

if (ops && ops->module_remove)
ops->module_remove(bus->upstream);
+
+ bus->sfp_quirk = NULL;
}
EXPORT_SYMBOL_GPL(sfp_module_remove);

Original file line number Diff line number Diff line change
Expand Up @@ -187,15 +187,6 @@ Signed-off-by: Russell King <[email protected]>
int err, i;

sfp = sfp_alloc(&pdev->dev);
@@ -2183,7 +2253,7 @@ static int sfp_probe(struct platform_dev

sfp->gpio_irq[i] = gpiod_to_irq(sfp->gpio[i]);
if (!sfp->gpio_irq[i]) {
- poll = true;
+ sfp->need_poll = true;
continue;
}

@@ -2195,11 +2265,11 @@ static int sfp_probe(struct platform_dev
dev_name(sfp->dev), sfp);
if (err) {
Expand Down
39 changes: 1 addition & 38 deletions target/linux/generic/hack-5.4/230-openwrt_lzma_options.patch
Original file line number Diff line number Diff line change
Expand Up @@ -27,45 +27,8 @@ Signed-off-by: Imre Kaloz <[email protected]>
# ---------------------------------------------------------------------------

quiet_cmd_lzma = LZMA $@
- cmd_lzma = { cat $(real-prereqs) | lzma -9; $(size_append); } > $@
- cmd_lzma = { cat $(real-prereqs) | $(LZMA) -9; $(size_append); } > $@
+ cmd_lzma = { cat $(real-prereqs) | lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so; $(size_append); } > $@

quiet_cmd_lzo = LZO $@
cmd_lzo = { cat $(real-prereqs) | lzop -9; $(size_append); } > $@
--- a/usr/gen_initramfs_list.sh
+++ b/usr/gen_initramfs_list.sh
@@ -229,7 +229,7 @@ cpio_list=
output="/dev/stdout"
output_file=""
is_cpio_compressed=
-compr="gzip -n -9 -f"
+compr="gzip -n -9 -f -"

arg="$1"
case "$arg" in
@@ -245,13 +245,13 @@ case "$arg" in
output=${cpio_list}
echo "$output_file" | grep -q "\.gz$" \
&& [ -x "`which gzip 2> /dev/null`" ] \
- && compr="gzip -n -9 -f"
+ && compr="gzip -n -9 -f -"
echo "$output_file" | grep -q "\.bz2$" \
&& [ -x "`which bzip2 2> /dev/null`" ] \
- && compr="bzip2 -9 -f"
+ && compr="bzip2 -9 -f -"
echo "$output_file" | grep -q "\.lzma$" \
&& [ -x "`which lzma 2> /dev/null`" ] \
- && compr="lzma -9 -f"
+ && compr="lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so"
echo "$output_file" | grep -q "\.xz$" \
&& [ -x "`which xz 2> /dev/null`" ] \
&& compr="xz --check=crc32 --lzma2=dict=1MiB"
@@ -320,7 +320,7 @@ if [ ! -z ${output_file} ]; then
if [ "${is_cpio_compressed}" = "compressed" ]; then
cat ${cpio_tfile} > ${output_file}
else
- (cat ${cpio_tfile} | ${compr} - > ${output_file}) \
+ (cat ${cpio_tfile} | ${compr} > ${output_file}) \
|| (rm -f ${output_file} ; false)
fi
[ -z ${cpio_file} ] && rm ${cpio_tfile}
1 change: 1 addition & 0 deletions target/linux/generic/hack-5.4/251-sound_kconfig.patch
Original file line number Diff line number Diff line change
Expand Up @@ -167,6 +167,7 @@ Signed-off-by: John Crispin <[email protected]>
config LIB80211_CRYPT_CCMP
- tristate
+ tristate "LIB80211_CRYPT_CCMP"
select CRYPTO
select CRYPTO_AES
select CRYPTO_CCM

Expand Down

This file was deleted.

1 change: 1 addition & 0 deletions target/linux/generic/pending-5.4/834-ledtrig-libata.patch
Original file line number Diff line number Diff line change
Expand Up @@ -128,6 +128,7 @@ Signed-off-by: Daniel Golle <[email protected]>
#include <linux/acpi.h>
#include <linux/cdrom.h>
#include <linux/sched.h>
#include <linux/async.h>
+#ifdef CONFIG_ATA_LEDS
+#include <linux/leds.h>
+#endif
Expand Down

0 comments on commit 62b3f4b

Please sign in to comment.