forked from coolsnowwolf/packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
ninja: add custom target support for ninja-cmake
- Loading branch information
1 parent
178f01d
commit 0510aad
Showing
3 changed files
with
31 additions
and
3 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,12 +1,12 @@ | ||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=ninja | ||
PKG_VERSION:=1.10.0 | ||
PKG_RELEASE:=1 | ||
PKG_VERSION:=1.10.2 | ||
PKG_RELEASE:=2 | ||
|
||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | ||
PKG_SOURCE_URL:=https://codeload.github.com/ninja-build/ninja/tar.gz/v$(PKG_VERSION)? | ||
PKG_HASH:=3810318b08489435f8efc19c05525e80a993af5a55baa0dfeae0465a9d45f99f | ||
PKG_HASH:=ce35865411f0490368a8fc383f29071de6690cbadc27704734978221f25e2bed | ||
|
||
PKG_MAINTAINER:=Andre Heider <[email protected]> | ||
PKG_LICENSE:=Apache-2.0 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
include $(INCLUDE_DIR)/cmake.mk | ||
include ../../devel/ninja/ninja.mk | ||
|
||
CMAKE_HOST_OPTIONS += -DCMAKE_GENERATOR="Ninja" | ||
CMAKE_OPTIONS += -DCMAKE_GENERATOR="Ninja" | ||
|
||
define Host/Compile/Default | ||
$(call Ninja,-C $(HOST_BUILD_DIR)/$(CMAKE_BINARY_SUBDIR) $(1),) | ||
endef | ||
|
||
define Host/Install/Default | ||
$(call Ninja,-C $(HOST_BUILD_DIR)/$(CMAKE_BINARY_SUBDIR) install,) | ||
endef | ||
|
||
define Host/Uninstall/Default | ||
-$(call Ninja,-C $(HOST_BUILD_DIR)/$(CMAKE_BINARY_SUBDIR) uninstall,) | ||
endef | ||
|
||
define Build/Compile/Default | ||
$(call Ninja,-C $(PKG_BUILD_DIR)/$(CMAKE_BINARY_SUBDIR) $(1),) | ||
endef | ||
|
||
define Build/Install/Default | ||
$(call Ninja,-C $(PKG_BUILD_DIR)/$(CMAKE_BINARY_SUBDIR) install,DESTDIR="$(PKG_INSTALL_DIR)") | ||
endef |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters