forked from coolsnowwolf/packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
1 parent
0ac1de1
commit 080e3d6
Showing
7 changed files
with
93 additions
and
55 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -6,22 +6,21 @@ | |
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=pkgconf | ||
PKG_VERSION:=1.7.4 | ||
PKG_VERSION:=1.8.0 | ||
PKG_RELEASE:=$(AUTORELEASE) | ||
|
||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz | ||
PKG_SOURCE_URL:=https://distfiles.dereferenced.org/pkgconf | ||
PKG_HASH:=d73f32c248a4591139a6b17777c80d4deab6b414ec2b3d21d0a24be348c476ab | ||
PKG_HASH:=ef9c7e61822b7cb8356e6e9e1dca58d9556f3200d78acab35e4347e9d4c2bbaf | ||
|
||
PKG_MAINTAINER:=Rosen Penev <[email protected]> | ||
PKG_LICENSE:=MIT | ||
PKG_LICENSE_FILES:=COPYING | ||
|
||
PKG_INSTALL:=1 | ||
PKG_BUILD_DEPENDS:=meson/host | ||
|
||
include $(INCLUDE_DIR)/package.mk | ||
include ../../devel/meson/meson.mk | ||
include $(INCLUDE_DIR)/meson.mk | ||
|
||
define Package/libpkgconf | ||
SECTION:=libs | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,102 +1,85 @@ | ||
if PACKAGE_fastd | ||
|
||
menu "Configuration" | ||
depends on PACKAGE_fastd | ||
|
||
config FASTD_ENABLE_METHOD_CIPHER_TEST | ||
bool "Enable cipher-test method provider" | ||
depends on PACKAGE_fastd | ||
default n | ||
|
||
config FASTD_ENABLE_METHOD_COMPOSED_GMAC | ||
bool "Enable composed-gmac method provider" | ||
depends on PACKAGE_fastd | ||
default y | ||
select FASTD_ENABLE_MAC_GHASH | ||
|
||
config FASTD_ENABLE_METHOD_COMPOSED_UMAC | ||
bool "Enable composed-umac method provider" | ||
depends on PACKAGE_fastd | ||
select FASTD_ENABLE_MAC_UHASH | ||
default y | ||
|
||
config FASTD_ENABLE_METHOD_GENERIC_GMAC | ||
bool "Enable generic-gmac method provider" | ||
depends on PACKAGE_fastd | ||
default y | ||
select FASTD_ENABLE_MAC_GHASH | ||
|
||
config FASTD_ENABLE_METHOD_GENERIC_POLY1305 | ||
bool "Enable generic-poly1305 method provider" | ||
depends on PACKAGE_fastd | ||
default n | ||
|
||
config FASTD_ENABLE_METHOD_GENERIC_UMAC | ||
bool "Enable generic-umac method provider" | ||
depends on PACKAGE_fastd | ||
select FASTD_ENABLE_MAC_UHASH | ||
default y | ||
|
||
config FASTD_ENABLE_METHOD_NULL | ||
bool "Enable null method" | ||
depends on PACKAGE_fastd | ||
default y | ||
|
||
config FASTD_ENABLE_METHOD_NULL_L2TP | ||
bool "Enable null@l2tp method" | ||
default y | ||
|
||
|
||
config FASTD_ENABLE_CIPHER_NULL | ||
bool "Enable the null cipher" | ||
depends on PACKAGE_fastd | ||
default y | ||
|
||
config FASTD_ENABLE_CIPHER_SALSA20 | ||
bool "Enable the Salsa20 cipher" | ||
depends on PACKAGE_fastd | ||
default n | ||
|
||
config FASTD_ENABLE_CIPHER_SALSA2012 | ||
bool "Enable the Salsa20/12 cipher" | ||
depends on PACKAGE_fastd | ||
default y | ||
|
||
|
||
config FASTD_ENABLE_MAC_GHASH | ||
bool "Enable the GHASH message authentication code" | ||
depends on PACKAGE_fastd | ||
default y | ||
bool | ||
|
||
config FASTD_ENABLE_MAC_UHASH | ||
bool "Enable the UHASH message authentication code" | ||
depends on PACKAGE_fastd | ||
default y | ||
bool | ||
|
||
|
||
config FASTD_WITH_CAPABILITIES | ||
bool "Enable POSIX capability support" | ||
depends on PACKAGE_fastd | ||
default n | ||
|
||
config FASTD_WITH_CMDLINE_USER | ||
bool "Include support for setting user/group related options on the command line" | ||
depends on PACKAGE_fastd | ||
default n | ||
|
||
config FASTD_WITH_CMDLINE_LOGGING | ||
bool "Include support for setting logging related options on the command line" | ||
depends on PACKAGE_fastd | ||
default n | ||
|
||
config FASTD_WITH_CMDLINE_OPERATION | ||
bool "Include support for setting options related to the VPN operation (like mode, interface, encryption method) on the command line" | ||
depends on PACKAGE_fastd | ||
default n | ||
|
||
config FASTD_WITH_CMDLINE_COMMANDS | ||
bool "Include support for setting handler scripts (e.g. --on-up) on the command line" | ||
depends on PACKAGE_fastd | ||
default n | ||
|
||
config FASTD_WITH_DYNAMIC_PEERS | ||
bool "Include support for dynamic peers (using on-verify handlers)" | ||
depends on PACKAGE_fastd | ||
default n | ||
|
||
config FASTD_WITH_STATUS_SOCKET | ||
bool "Include support for status sockets" | ||
depends on PACKAGE_fastd | ||
default y | ||
|
||
config FASTD_WITH_OFFLOAD_L2TP | ||
bool "Enable L2TP offloading" | ||
default y | ||
|
||
endmenu | ||
|
||
endif |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -8,15 +8,16 @@ | |
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=fastd | ||
PKG_VERSION:=21 | ||
PKG_VERSION:=22 | ||
PKG_RELEASE=3 | ||
|
||
PKG_MAINTAINER:=Matthias Schiffer <[email protected]> | ||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz | ||
PKG_SOURCE_URL:=https://github.com/NeoRaider/fastd/releases/download/v$(PKG_VERSION) | ||
PKG_HASH:=942f33bcd794bcb8e19da4c30c875bdfd4d0f1c24ec4dcdf51237791bbfb0d4c | ||
PKG_HASH:=19750b88705d66811b7c21b672537909c19ae6b21350688cbd1a3a54d08a8951 | ||
|
||
PKG_LICENSE:=BSD-2-Clause | ||
PKG_LICENSE_FILES:=COPYRIGHT | ||
PKG_LICENSE:=BSD-2-Clause LGPL-2.1-or-later | ||
PKG_LICENSE_FILES:=COPYRIGHT src/dep/libmnl/COPYING | ||
|
||
PKG_CONFIG_DEPENDS:=\ | ||
CONFIG_FASTD_ENABLE_METHOD_CIPHER_TEST \ | ||
|
@@ -26,6 +27,7 @@ PKG_CONFIG_DEPENDS:=\ | |
CONFIG_FASTD_ENABLE_METHOD_GENERIC_POLY1305 \ | ||
CONFIG_FASTD_ENABLE_METHOD_GENERIC_UMAC \ | ||
CONFIG_FASTD_ENABLE_METHOD_NULL \ | ||
CONFIG_FASTD_ENABLE_METHOD_NULL_L2TP \ | ||
CONFIG_FASTD_ENABLE_CIPHER_NULL \ | ||
CONFIG_FASTD_ENABLE_CIPHER_SALSA20 \ | ||
CONFIG_FASTD_ENABLE_CIPHER_SALSA2012 \ | ||
|
@@ -37,14 +39,14 @@ PKG_CONFIG_DEPENDS:=\ | |
CONFIG_FASTD_WITH_CMDLINE_OPERATION \ | ||
CONFIG_FASTD_WITH_CMDLINE_COMMANDS \ | ||
CONFIG_FASTD_WITH_DYNAMIC_PEERS \ | ||
CONFIG_FASTD_WITH_STATUS_SOCKET | ||
CONFIG_FASTD_WITH_STATUS_SOCKET \ | ||
CONFIG_FASTD_WITH_OFFLOAD_L2TP | ||
|
||
|
||
PKG_BUILD_DEPENDS:=meson/host nacl | ||
PKG_BUILD_PARALLEL:=1 | ||
PKG_BUILD_DEPENDS:=nacl | ||
|
||
include $(INCLUDE_DIR)/package.mk | ||
include ../../devel/meson/meson.mk | ||
include $(INCLUDE_DIR)/meson.mk | ||
|
||
define Package/fastd | ||
SECTION:=net | ||
|
@@ -81,14 +83,17 @@ MESON_ARGS += \ | |
-Dmethod_generic-poly1305=$(call feature,ENABLE_METHOD_GENERIC_POLY1305) \ | ||
-Dmethod_generic-umac=$(call feature,ENABLE_METHOD_GENERIC_UMAC) \ | ||
-Dmethod_null=$(call feature,ENABLE_METHOD_NULL) \ | ||
-Dmethod_null_l2tp=$(call feature,ENABLE_METHOD_NULL_L2TP) \ | ||
-Dstatus_socket=$(call feature,WITH_STATUS_SOCKET) \ | ||
-Doffload_l2tp=$(call feature,WITH_OFFLOAD_L2TP) \ | ||
-Dlibmnl_builtin=true \ | ||
-Dsystemd=disabled \ | ||
-Duse_nacl=true \ | ||
-Db_lto=true \ | ||
-Dprefix=/usr | ||
|
||
define Package/fastd/description | ||
Fast and secure tunneling daemon, which is optimized on small code size and few dependencies | ||
Fast and secure tunneling daemon, which is optimized on small code size and few dependencies | ||
endef | ||
|
||
define Package/fastd/conffiles | ||
|
33 changes: 33 additions & 0 deletions
33
net/fastd/patches/0001-config-allow-disabling-L2TP-offload-when-fastd-doesn.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
From d95ae843845760aecbbc62a734c2b93b401b1834 Mon Sep 17 00:00:00 2001 | ||
Message-Id: <d95ae843845760aecbbc62a734c2b93b401b1834.1624798048.git.mschiffer@universe-factory.net> | ||
From: Matthias Schiffer <[email protected]> | ||
Date: Sun, 27 Jun 2021 14:45:46 +0200 | ||
Subject: [PATCH] config: allow disabling L2TP offload when fastd doesn't | ||
support it | ||
|
||
Only attempting to enable the offloading should raise an error when it | ||
is not supported. | ||
--- | ||
src/config.y | 8 +++++--- | ||
1 file changed, 5 insertions(+), 3 deletions(-) | ||
|
||
--- a/src/config.y | ||
+++ b/src/config.y | ||
@@ -282,12 +282,14 @@ offload: TOK_L2TP boolean { | ||
#ifdef WITH_OFFLOAD_L2TP | ||
conf.offload_l2tp = $2; | ||
#else | ||
+ if ($2) { | ||
# ifdef __linux__ | ||
- fastd_config_error(&@$, state, "L2TP offload is not supported by this build of fastd"); | ||
+ fastd_config_error(&@$, state, "L2TP offload is not supported by this build of fastd"); | ||
# else | ||
- fastd_config_error(&@$, state, "L2TP offload is not supported on this platform"); | ||
+ fastd_config_error(&@$, state, "L2TP offload is not supported on this platform"); | ||
# endif | ||
- YYERROR; | ||
+ YYERROR; | ||
+ } | ||
#endif | ||
} | ||
; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,29 +1,29 @@ | ||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=conmon | ||
PKG_VERSION:=2.0.29 | ||
PKG_VERSION:=2.0.31 | ||
PKG_RELEASE:=$(AUTORELEASE) | ||
|
||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz | ||
PKG_SOURCE_URL:=https://github.com/containers/$(PKG_NAME)/archive/v$(PKG_VERSION) | ||
PKG_HASH:=eb4d5e157671a61b88786e44094775194e30e1d0ad0b9d50035532ece78dbc28 | ||
PKG_HASH:=76286480065d4cf9b24610c159c683710fe9c8b9f753518f804f22bbb59796a8 | ||
|
||
PKG_MAINTAINER:=Oskari Rauta <[email protected]> | ||
PKG_LICENSE:=Apache-2.0 | ||
PKG_LICENSE_FILES:=LICENSE | ||
|
||
PKG_BUILD_DEPENDS:=golang/host meson/host | ||
PKG_BUILD_DEPENDS:=libseccomp | ||
|
||
include $(INCLUDE_DIR)/package.mk | ||
include $(INCLUDE_DIR)/nls.mk | ||
include ../../devel/meson/meson.mk | ||
include $(INCLUDE_DIR)/meson.mk | ||
|
||
define Package/conmon | ||
SECTION:=utils | ||
CATEGORY:=Utilities | ||
TITLE:=Podman conmon | ||
URL:=https://podman.io | ||
DEPENDS:=+glib2 $(INTL_DEPENDS) $(ICONV_DEPENDS) | ||
DEPENDS:=@!arc +glib2 $(INTL_DEPENDS) $(ICONV_DEPENDS) | ||
endef | ||
|
||
define Package/conmon/description | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,19 @@ | ||
--- a/meson.build | ||
+++ b/meson.build | ||
@@ -34,7 +34,6 @@ add_project_arguments('-Os', '-Wall', '- | ||
language : 'c') | ||
|
||
glib = dependency('glib-2.0') | ||
-libdl = cc.find_library('dl') | ||
|
||
executable('conmon', | ||
['src/conmon.c', | ||
@@ -71,7 +70,7 @@ executable('conmon', | ||
'src/utils.h', | ||
'src/seccomp_notify.c', | ||
'src/seccomp_notify.h'], | ||
- dependencies : [glib, libdl], | ||
+ dependencies : [glib], | ||
install : true, | ||
install_dir : join_paths(get_option('libexecdir'), 'podman'), | ||
) |