forked from openwrt/openwrt
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Ran update_kernel.sh in a fresh clone without any existing toolchains. Manually rebased: bcm27xx/950-0993-xhci-quirks-add-link-TRB-quirk-for-VL805.patch layerscape/701-net-0231-enetc-Use-DT-protocol-information-to-set-up-the-port.patch Build system: x86_64 Build-tested: ipq806x/R7800 Run-tested: ipq806x/R7800 No dmesg regressions, everything functional Signed-off-by: John Audia <[email protected]> [remove accidental whitespace edit] Signed-off-by: Adrian Schmutzler <[email protected]>
- Loading branch information
Showing
53 changed files
with
142 additions
and
142 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -48,9 +48,9 @@ Signed-off-by: Vinod Koul <[email protected]> | |
|
||
#include "xhci.h" | ||
#include "xhci-trace.h" | ||
@@ -63,6 +65,44 @@ | ||
#define PCI_DEVICE_ID_ASMEDIA_1142_XHCI 0x1242 | ||
@@ -64,6 +66,44 @@ | ||
#define PCI_DEVICE_ID_ASMEDIA_2142_XHCI 0x2142 | ||
#define PCI_DEVICE_ID_ASMEDIA_3242_XHCI 0x3242 | ||
|
||
+#define RENESAS_FW_VERSION 0x6C | ||
+#define RENESAS_ROM_CONFIG 0xF0 | ||
|
@@ -93,7 +93,7 @@ Signed-off-by: Vinod Koul <[email protected]> | |
static const char hcd_name[] = "xhci_hcd"; | ||
|
||
static struct hc_driver __read_mostly xhci_pci_hc_driver; | ||
@@ -298,6 +338,873 @@ static void xhci_pme_acpi_rtd3_enable(st | ||
@@ -307,6 +347,873 @@ static void xhci_pme_acpi_rtd3_enable(st | ||
static void xhci_pme_acpi_rtd3_enable(struct pci_dev *dev) { } | ||
#endif /* CONFIG_ACPI */ | ||
|
||
|
@@ -967,7 +967,7 @@ Signed-off-by: Vinod Koul <[email protected]> | |
/* called during probe() after chip reset completes */ | ||
static int xhci_pci_setup(struct usb_hcd *hcd) | ||
{ | ||
@@ -339,6 +1246,27 @@ static int xhci_pci_probe(struct pci_dev | ||
@@ -348,6 +1255,27 @@ static int xhci_pci_probe(struct pci_dev | ||
struct hc_driver *driver; | ||
struct usb_hcd *hcd; | ||
|
||
|
@@ -995,7 +995,7 @@ Signed-off-by: Vinod Koul <[email protected]> | |
driver = (struct hc_driver *)id->driver_data; | ||
|
||
/* Prevent runtime suspending between USB-2 and USB-3 initialization */ | ||
@@ -400,6 +1328,16 @@ static void xhci_pci_remove(struct pci_d | ||
@@ -409,6 +1337,16 @@ static void xhci_pci_remove(struct pci_d | ||
{ | ||
struct xhci_hcd *xhci; | ||
|
||
|
@@ -1012,7 +1012,7 @@ Signed-off-by: Vinod Koul <[email protected]> | |
xhci = hcd_to_xhci(pci_get_drvdata(dev)); | ||
xhci->xhc_state |= XHCI_STATE_REMOVING; | ||
|
||
@@ -539,6 +1477,11 @@ static int xhci_pci_resume(struct usb_hc | ||
@@ -548,6 +1486,11 @@ static int xhci_pci_resume(struct usb_hc | ||
if (pdev->vendor == PCI_VENDOR_ID_INTEL) | ||
usb_enable_intel_xhci_ports(pdev); | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -10,7 +10,7 @@ Signed-off-by: Phil Elwell <[email protected]> | |
|
||
--- a/drivers/usb/host/xhci-pci.c | ||
+++ b/drivers/usb/host/xhci-pci.c | ||
@@ -254,6 +254,10 @@ static void xhci_pci_quirks(struct devic | ||
@@ -255,6 +255,10 @@ static void xhci_pci_quirks(struct devic | ||
pdev->device == 0x3432) | ||
xhci->quirks |= XHCI_BROKEN_STREAMS; | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -15,7 +15,7 @@ Signed-off-by: Jonathan Bell <[email protected]> | |
|
||
--- a/drivers/usb/host/xhci.c | ||
+++ b/drivers/usb/host/xhci.c | ||
@@ -1456,6 +1456,103 @@ command_cleanup: | ||
@@ -1464,6 +1464,103 @@ command_cleanup: | ||
} | ||
|
||
/* | ||
|
@@ -119,7 +119,7 @@ Signed-off-by: Jonathan Bell <[email protected]> | |
* non-error returns are a promise to giveback() the urb later | ||
* we drop ownership so next owner (or urb unlink) can get it | ||
*/ | ||
@@ -5337,6 +5434,7 @@ static const struct hc_driver xhci_hc_dr | ||
@@ -5345,6 +5442,7 @@ static const struct hc_driver xhci_hc_dr | ||
.endpoint_reset = xhci_endpoint_reset, | ||
.check_bandwidth = xhci_check_bandwidth, | ||
.reset_bandwidth = xhci_reset_bandwidth, | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -23,7 +23,7 @@ Signed-off-by: Jonathan Bell <[email protected]> | |
|
||
--- a/drivers/usb/host/xhci-pci.c | ||
+++ b/drivers/usb/host/xhci-pci.c | ||
@@ -255,8 +255,10 @@ static void xhci_pci_quirks(struct devic | ||
@@ -256,8 +256,10 @@ static void xhci_pci_quirks(struct devic | ||
xhci->quirks |= XHCI_BROKEN_STREAMS; | ||
|
||
if (pdev->vendor == PCI_VENDOR_ID_VIA && | ||
|
@@ -87,4 +87,4 @@ Signed-off-by: Jonathan Bell <[email protected]> | |
+#define XHCI_EP_CTX_BROKEN_DCS BIT_ULL(36) | ||
#define XHCI_SKIP_PHY_INIT BIT_ULL(37) | ||
#define XHCI_DISABLE_SPARSE BIT_ULL(38) | ||
|
||
#define XHCI_NO_SOFT_RETRY BIT_ULL(40) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -24,7 +24,7 @@ Signed-off-by: Phil Elwell <[email protected]> | |
|
||
--- a/Makefile | ||
+++ b/Makefile | ||
@@ -1261,6 +1261,9 @@ ifneq ($(dtstree),) | ||
@@ -1267,6 +1267,9 @@ ifneq ($(dtstree),) | ||
%.dtb: include/config/kernel.release scripts_dtc | ||
$(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@ | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -85,7 +85,7 @@ Signed-off-by: Catalin Marinas <[email protected]> | |
zhole_size[ZONE_NORMAL] -= normal_end - normal_start; | ||
} | ||
} | ||
@@ -410,9 +410,9 @@ void __init arm64_memblock_init(void) | ||
@@ -422,9 +422,9 @@ void __init arm64_memblock_init(void) | ||
|
||
/* 4GB maximum for 32-bit only capable devices */ | ||
if (IS_ENABLED(CONFIG_ZONE_DMA32)) | ||
|
@@ -97,7 +97,7 @@ Signed-off-by: Catalin Marinas <[email protected]> | |
|
||
reserve_crashkernel(); | ||
|
||
@@ -420,7 +420,7 @@ void __init arm64_memblock_init(void) | ||
@@ -432,7 +432,7 @@ void __init arm64_memblock_init(void) | ||
|
||
high_memory = __va(memblock_end_of_DRAM() - 1) + 1; | ||
|
||
|
@@ -106,7 +106,7 @@ Signed-off-by: Catalin Marinas <[email protected]> | |
} | ||
|
||
void __init bootmem_init(void) | ||
@@ -524,7 +524,7 @@ static void __init free_unused_memmap(vo | ||
@@ -536,7 +536,7 @@ static void __init free_unused_memmap(vo | ||
void __init mem_init(void) | ||
{ | ||
if (swiotlb_force == SWIOTLB_FORCE || | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -140,7 +140,7 @@ Signed-off-by: Catalin Marinas <[email protected]> | |
} | ||
#endif | ||
if (end > max_dma32) { | ||
@@ -408,9 +430,11 @@ void __init arm64_memblock_init(void) | ||
@@ -420,9 +442,11 @@ void __init arm64_memblock_init(void) | ||
|
||
early_init_fdt_scan_reserved_mem(); | ||
|
||
|
@@ -154,7 +154,7 @@ Signed-off-by: Catalin Marinas <[email protected]> | |
else | ||
arm64_dma32_phys_limit = PHYS_MASK + 1; | ||
|
||
@@ -420,7 +444,7 @@ void __init arm64_memblock_init(void) | ||
@@ -432,7 +456,7 @@ void __init arm64_memblock_init(void) | ||
|
||
high_memory = __va(memblock_end_of_DRAM() - 1) + 1; | ||
|
||
|
@@ -163,7 +163,7 @@ Signed-off-by: Catalin Marinas <[email protected]> | |
} | ||
|
||
void __init bootmem_init(void) | ||
@@ -524,7 +548,7 @@ static void __init free_unused_memmap(vo | ||
@@ -536,7 +560,7 @@ static void __init free_unused_memmap(vo | ||
void __init mem_init(void) | ||
{ | ||
if (swiotlb_force == SWIOTLB_FORCE || | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -50,7 +50,7 @@ Signed-off-by: Catalin Marinas <[email protected]> | |
/* | ||
* We need to be able to catch inadvertent references to memstart_addr | ||
* that occur (potentially in generic code) before arm64_memblock_init() | ||
@@ -430,8 +433,10 @@ void __init arm64_memblock_init(void) | ||
@@ -442,8 +445,10 @@ void __init arm64_memblock_init(void) | ||
|
||
early_init_fdt_scan_reserved_mem(); | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -15,7 +15,7 @@ Signed-off-by: Nataliya Korovkina <[email protected]> | |
|
||
--- a/Makefile | ||
+++ b/Makefile | ||
@@ -1261,7 +1261,7 @@ ifneq ($(dtstree),) | ||
@@ -1267,7 +1267,7 @@ ifneq ($(dtstree),) | ||
%.dtb: include/config/kernel.release scripts_dtc | ||
$(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@ | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -33,7 +33,7 @@ Signed-off-by: Catalin Marinas <[email protected]> | |
crash_size, SZ_2M); | ||
if (crash_base == 0) { | ||
pr_warn("cannot allocate crashkernel (size:0x%llx)\n", | ||
@@ -449,7 +449,7 @@ void __init arm64_memblock_init(void) | ||
@@ -461,7 +461,7 @@ void __init arm64_memblock_init(void) | ||
|
||
high_memory = __va(memblock_end_of_DRAM() - 1) + 1; | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -22,7 +22,7 @@ Signed-off-by: Jonathan Bell <[email protected]> | |
|
||
--- a/drivers/usb/host/xhci-pci.c | ||
+++ b/drivers/usb/host/xhci-pci.c | ||
@@ -258,6 +258,7 @@ static void xhci_pci_quirks(struct devic | ||
@@ -259,6 +259,7 @@ static void xhci_pci_quirks(struct devic | ||
pdev->device == 0x3483) { | ||
xhci->quirks |= XHCI_LPM_SUPPORT; | ||
xhci->quirks |= XHCI_EP_CTX_BROKEN_DCS; | ||
|
@@ -56,6 +56,6 @@ Signed-off-by: Jonathan Bell <[email protected]> | |
#define XHCI_SKIP_PHY_INIT BIT_ULL(37) | ||
#define XHCI_DISABLE_SPARSE BIT_ULL(38) | ||
+#define XHCI_AVOID_DQ_ON_LINK BIT_ULL(39) | ||
#define XHCI_NO_SOFT_RETRY BIT_ULL(40) | ||
|
||
unsigned int num_active_eps; | ||
unsigned int limit_active_eps; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -24,7 +24,7 @@ Signed-off-by: Russell King <[email protected]> | |
#include <linux/workqueue.h> | ||
#include <linux/mdio.h> | ||
#include <linux/io.h> | ||
@@ -842,6 +843,9 @@ void phy_stop(struct phy_device *phydev) | ||
@@ -843,6 +844,9 @@ void phy_stop(struct phy_device *phydev) | ||
|
||
mutex_lock(&phydev->lock); | ||
|
||
|
@@ -34,7 +34,7 @@ Signed-off-by: Russell King <[email protected]> | |
phydev->state = PHY_HALTED; | ||
|
||
mutex_unlock(&phydev->lock); | ||
@@ -904,6 +908,9 @@ void phy_state_machine(struct work_struc | ||
@@ -905,6 +909,9 @@ void phy_state_machine(struct work_struc | ||
|
||
old_state = phydev->state; | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -14,7 +14,7 @@ Signed-off-by: Poonam Aggrwal <[email protected]> | |
|
||
--- a/arch/arm64/mm/init.c | ||
+++ b/arch/arm64/mm/init.c | ||
@@ -406,6 +406,8 @@ void __init arm64_memblock_init(void) | ||
@@ -418,6 +418,8 @@ void __init arm64_memblock_init(void) | ||
initrd_end = initrd_start + phys_initrd_size; | ||
} | ||
|
||
|
@@ -23,7 +23,7 @@ Signed-off-by: Poonam Aggrwal <[email protected]> | |
early_init_fdt_scan_reserved_mem(); | ||
|
||
/* 4GB maximum for 32-bit only capable devices */ | ||
@@ -416,8 +418,6 @@ void __init arm64_memblock_init(void) | ||
@@ -428,8 +430,6 @@ void __init arm64_memblock_init(void) | ||
|
||
reserve_crashkernel(); | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -57,7 +57,7 @@ Signed-off-by: David S. Miller <[email protected]> | |
fsl-enetc-mdio-y := enetc_pci_mdio.o enetc_mdio.o | ||
--- a/drivers/net/ethernet/freescale/enetc/enetc.c | ||
+++ b/drivers/net/ethernet/freescale/enetc/enetc.c | ||
@@ -1427,8 +1427,7 @@ int enetc_close(struct net_device *ndev) | ||
@@ -1422,8 +1422,7 @@ int enetc_close(struct net_device *ndev) | ||
return 0; | ||
} | ||
|
||
|
@@ -67,7 +67,7 @@ Signed-off-by: David S. Miller <[email protected]> | |
{ | ||
struct enetc_ndev_priv *priv = netdev_priv(ndev); | ||
struct tc_mqprio_qopt *mqprio = type_data; | ||
@@ -1436,9 +1435,6 @@ int enetc_setup_tc(struct net_device *nd | ||
@@ -1431,9 +1430,6 @@ int enetc_setup_tc(struct net_device *nd | ||
u8 num_tc; | ||
int i; | ||
|
||
|
@@ -77,7 +77,7 @@ Signed-off-by: David S. Miller <[email protected]> | |
mqprio->hw = TC_MQPRIO_HW_OFFLOAD_TCS; | ||
num_tc = mqprio->num_tc; | ||
|
||
@@ -1483,6 +1479,19 @@ int enetc_setup_tc(struct net_device *nd | ||
@@ -1478,6 +1474,19 @@ int enetc_setup_tc(struct net_device *nd | ||
return 0; | ||
} | ||
|
||
|
@@ -99,7 +99,7 @@ Signed-off-by: David S. Miller <[email protected]> | |
struct enetc_ndev_priv *priv = netdev_priv(ndev); | ||
--- a/drivers/net/ethernet/freescale/enetc/enetc.h | ||
+++ b/drivers/net/ethernet/freescale/enetc/enetc.h | ||
@@ -244,3 +244,10 @@ int enetc_set_fs_entry(struct enetc_si * | ||
@@ -249,3 +249,10 @@ int enetc_set_fs_entry(struct enetc_si * | ||
void enetc_set_rss_key(struct enetc_hw *hw, const u8 *bytes); | ||
int enetc_get_rss_table(struct enetc_si *si, u32 *table, int count); | ||
int enetc_set_rss_table(struct enetc_si *si, const u32 *table, int count); | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -42,7 +42,7 @@ Signed-off-by: David S. Miller <[email protected]> | |
} | ||
|
||
static int enetc_dma_alloc_bdr(struct enetc_bdr *r, size_t bd_size) | ||
@@ -1314,8 +1319,12 @@ static void enetc_disable_interrupts(str | ||
@@ -1309,8 +1314,12 @@ static void enetc_disable_interrupts(str | ||
|
||
static void adjust_link(struct net_device *ndev) | ||
{ | ||
|
@@ -91,7 +91,7 @@ Signed-off-by: David S. Miller <[email protected]> | |
struct enetc_bdr *tx_ring[16]; | ||
struct enetc_bdr *rx_ring[16]; | ||
|
||
@@ -248,6 +254,8 @@ int enetc_send_cmd(struct enetc_si *si, | ||
@@ -253,6 +259,8 @@ int enetc_send_cmd(struct enetc_si *si, | ||
|
||
#ifdef CONFIG_FSL_ENETC_QOS | ||
int enetc_setup_tc_taprio(struct net_device *ndev, void *type_data); | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -79,8 +79,8 @@ Signed-off-by: Claudiu Manoil <[email protected]> | |
+} | ||
--- a/drivers/net/ethernet/freescale/enetc/enetc_pf.c | ||
+++ b/drivers/net/ethernet/freescale/enetc/enetc_pf.c | ||
@@ -852,6 +852,61 @@ static int enetc_init_port_rss_memory(st | ||
return err; | ||
@@ -872,6 +872,61 @@ static void enetc_init_unused_port(struc | ||
enetc_free_cbdr(dev, &si->cbd_ring); | ||
} | ||
|
||
+static void enetc_configure_sgmii(struct mii_bus *imdio) | ||
|
@@ -141,7 +141,7 @@ Signed-off-by: Claudiu Manoil <[email protected]> | |
static int enetc_pf_probe(struct pci_dev *pdev, | ||
const struct pci_device_id *ent) | ||
{ | ||
@@ -928,6 +983,10 @@ static int enetc_pf_probe(struct pci_dev | ||
@@ -956,6 +1011,10 @@ static int enetc_pf_probe(struct pci_dev | ||
if (err) | ||
dev_warn(&pdev->dev, "Fallback to PHY-less operation\n"); | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -125,7 +125,7 @@ Signed-off-by: Claudiu Manoil <[email protected]> | |
} | ||
|
||
/* Initialize the entire shared memory for the flow steering entries | ||
@@ -933,6 +936,10 @@ static int enetc_pf_probe(struct pci_dev | ||
@@ -955,6 +958,10 @@ static int enetc_pf_probe(struct pci_dev | ||
pf->si = si; | ||
pf->total_vfs = pci_sriov_get_totalvfs(pdev); | ||
|
||
|
@@ -136,7 +136,7 @@ Signed-off-by: Claudiu Manoil <[email protected]> | |
enetc_configure_port(pf); | ||
|
||
enetc_get_si_caps(si); | ||
@@ -947,6 +954,8 @@ static int enetc_pf_probe(struct pci_dev | ||
@@ -969,6 +976,8 @@ static int enetc_pf_probe(struct pci_dev | ||
enetc_pf_netdev_setup(si, ndev, &enetc_ndev_ops); | ||
|
||
priv = netdev_priv(ndev); | ||
|
@@ -145,7 +145,7 @@ Signed-off-by: Claudiu Manoil <[email protected]> | |
|
||
enetc_init_si_rings_params(priv); | ||
|
||
@@ -974,10 +983,6 @@ static int enetc_pf_probe(struct pci_dev | ||
@@ -1002,10 +1011,6 @@ static int enetc_pf_probe(struct pci_dev | ||
goto err_alloc_msix; | ||
} | ||
|
||
|
@@ -156,23 +156,23 @@ Signed-off-by: Claudiu Manoil <[email protected]> | |
err = enetc_configure_serdes(priv); | ||
if (err) | ||
dev_warn(&pdev->dev, "Attempted serdes config but failed\n"); | ||
@@ -995,7 +1000,6 @@ static int enetc_pf_probe(struct pci_dev | ||
@@ -1023,7 +1028,6 @@ static int enetc_pf_probe(struct pci_dev | ||
|
||
err_reg_netdev: | ||
enetc_mdio_remove(pf); | ||
- enetc_of_put_phy(priv); | ||
enetc_free_msix(priv); | ||
err_config_si: | ||
err_init_port_rss: | ||
err_init_port_rfs: | ||
@@ -1005,6 +1009,7 @@ err_alloc_si_res: | ||
@@ -1034,6 +1038,7 @@ err_alloc_si_res: | ||
si->ndev = NULL; | ||
free_netdev(ndev); | ||
err_alloc_netdev: | ||
+ enetc_of_put_phy(pf); | ||
err_device_disabled: | ||
err_map_pf_space: | ||
enetc_pci_remove(pdev); | ||
|
||
@@ -1027,7 +1032,7 @@ static void enetc_pf_remove(struct pci_d | ||
@@ -1057,7 +1062,7 @@ static void enetc_pf_remove(struct pci_d | ||
unregister_netdev(si->ndev); | ||
|
||
enetc_mdio_remove(pf); | ||
|
Oops, something went wrong.