forked from haiibo/openwrt-packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
0 parents
commit c33f566
Showing
2,888 changed files
with
1,212,886 additions
and
0 deletions.
There are no files selected for viewing
Large diffs are not rendered by default.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,57 @@ | ||
<div align="center"> | ||
<img width="768" src="https://cdn.jsdelivr.net/gh/haiibo/OpenWrt/images/openwrt.png"/> | ||
<h1>OpenWrt — 常用插件合集</h1> | ||
|
||
<img src="https://img.shields.io/github/languages/code-size/haiibo/openwrt-packages?style=for-the-badge&color=32C955"/> | ||
<img src="https://img.shields.io/github/stars/haiibo/openwrt-packages?style=for-the-badge&color=orange"/> | ||
<img src="https://img.shields.io/github/forks/haiibo/openwrt-packages?style=for-the-badge&color=ff69b4"/> | ||
<img src="https://img.shields.io/github/license/haiibo/openwrt-packages?style=for-the-badge&color=blueviolet"/> | ||
</div> | ||
|
||
### 项目说明 | ||
- OpenWrt 常用插件源码合集,适用于 Lean 源码 | ||
- 自动同步上游源码,一键拉取直接编译,不用再一个个找插件 | ||
- 科学上网依赖全部同步在 `helloworld` 目录内,无需再额外拉取 | ||
- 所有插件都为 GITHUB 上收集的开源插件,感谢作者们的付出 | ||
|
||
### 使用方法 | ||
```yaml | ||
sed -i '$a src-git kenzo https://github.com/haiibo/openwrt-packages' feeds.conf.default | ||
git pull | ||
./scripts/feeds update -a | ||
./scripts/feeds install -a | ||
make menuconfig | ||
``` | ||
|
||
### 插件说明 | ||
| 插件 | 说明 | | ||
| ------------- | ------------- | | ||
| helloworld | SSR Plus+ PassWall 等科学上网依赖 | | ||
| luci-app-adguardhome | AdGuard Home 去广告 | | ||
| luci-app-advanced | 系统高级设置 | | ||
| luci-app-aliddns | 阿里云 DDNS 插件 | | ||
| luci-app-aliyundrive-fuse | 阿里云盘 Fuse 服务 | | ||
| luci-app-aliyundrive-webdav | 阿里云盘 WebDAV 服务 | | ||
| luci-app-amlogic | 晶晨宝盒 | | ||
| luci-theme-argon | 老竭力开发的主题 Argon | | ||
| luci-app-argon-config | Argon 主题设置,需搭配 Argon 主题使用 | | ||
| luci-app-bypass | Bypass 科学上网插件 | | ||
| luci-app-ddnsto | DDNSTO 内网穿透 | | ||
| luci-app-dnsfilter | 基于DNS的广告过滤 | | ||
| luci-app-dockerman | Docker 插件 | | ||
| luci-app-eqos | IP 限速插件 | | ||
| luci-app-ikoolproxy | ikoolproxy 去广告 | | ||
| luci-app-mosdns | DNS 国内外分流解析与广告过滤 | | ||
| luci-app-netdata | 中文版 Netdata 监控 | | ||
| luci-app-oaf | 应用过滤 | | ||
| luci-app-openclash | OpenClash 小猫咪科学上网插件 | | ||
| luci-app-passwall | PassWall 科学上网插件 | | ||
| luci-app-passwall2 | PassWall2 科学上网插件 | | ||
| luci-app-poweroff | 关机 | | ||
| luci-app-pushbot | 全能推送 | | ||
| luci-app-serverchan | 微信推送 | | ||
| luci-app-smartdns | SmartDNS DNS防污染 | | ||
| luci-app-ssr-plus | SSR Plus+ 科学上网插件 | | ||
| luci-app-store | iStore 应用商店 | | ||
| luci-app-unblockneteasemusic | 解除网易云音乐播放限制 | | ||
| luci-app-vssr | Hello World 科学上网插件 | |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,52 @@ | ||
# SPDX-Identifier-License: GPL-3.0-only | ||
# | ||
# Copyright (C) 2021 ImmortalWrt.org | ||
|
||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=UnblockNeteaseMusic | ||
PKG_BASE_VERSION:=0.27.0-rc.6 | ||
PKG_RELEASE:=$(AUTORELEASE) | ||
|
||
PKG_SOURCE_PROTO:=git | ||
PKG_SOURCE_URL:=https://github.com/UnblockNeteaseMusic/server.git | ||
PKG_SOURCE_DATE:=2022-05-20 | ||
PKG_SOURCE_VERSION:=83e3467dc6b8e9bf1cc0feaabae834972aad3a64 | ||
PKG_MIRROR_HASH:=4214533b9bd28c67408f901461c10f239fdc3605db6477f043e45a0b7dd843b7 | ||
|
||
PKG_VERSION:=$(PKG_BASE_VERSION)-$(PKG_SOURCE_DATE)-$(call version_abbrev,$(PKG_SOURCE_VERSION)) | ||
|
||
PKG_LICENSE:=LGPL-3.0-only | ||
PKG_LICENSE_FILE:=LICENSE | ||
PKG_MAINTAINER:=Tianling Shen <[email protected]> | ||
|
||
include $(INCLUDE_DIR)/package.mk | ||
|
||
define Package/UnblockNeteaseMusic | ||
SECTION:=multimedia | ||
CATEGORY:=Multimedia | ||
TITLE:=Revive Netease Cloud Music (NodeJS) | ||
URL:=https://github.com/nondanee/UnblockNeteaseMusic | ||
DEPENDS:=+node | ||
PKGARCH:=all | ||
endef | ||
|
||
define Build/Prepare | ||
mkdir -p $(PKG_BUILD_DIR) | ||
xzcat $(DL_DIR)/$(PKG_SOURCE) | $(TAR) -C $(PKG_BUILD_DIR) $(TAR_OPTIONS) | ||
endef | ||
|
||
define Build/Configure | ||
echo -e $(PKG_BASE_VERSION) > $(PKG_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/core_ver | ||
echo -e $(PKG_SOURCE_VERSION) > $(PKG_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/local_ver | ||
endef | ||
|
||
define Build/Compile | ||
endef | ||
|
||
define Package/UnblockNeteaseMusic/install | ||
$(INSTALL_DIR) $(1)/usr/share/UnblockNeteaseMusic | ||
$(CP) $(PKG_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/* $(1)/usr/share/UnblockNeteaseMusic | ||
endef | ||
|
||
$(eval $(call BuildPackage,UnblockNeteaseMusic)) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,88 @@ | ||
# | ||
# This is free software, licensed under the GNU General Public License v2. | ||
# See /LICENSE for more information. | ||
# | ||
|
||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=adguardhome | ||
PKG_VERSION:=0.107.13 | ||
PKG_RELEASE:=65 | ||
|
||
PKG_SOURCE_PROTO:=git | ||
PKG_SOURCE_VERSION:=77d04d44eb080500f79e1329f943decb976d1817 | ||
PKG_SOURCE_URL:=https://github.com/AdguardTeam/AdGuardHome | ||
PKG_MIRROR_HASH:=skip | ||
|
||
PKG_LICENSE:=GPL-3.0-only | ||
PKG_LICENSE_FILES:=LICENSE.txt | ||
PKG_MAINTAINER:=Dobroslaw Kijowski <[email protected]> | ||
|
||
PKG_BUILD_DEPENDS:=golang/host node/host node-yarn/host | ||
PKG_BUILD_PARALLEL:=1 | ||
PKG_USE_MIPS16:=0 | ||
|
||
PKG_CONFIG_DEPENDS:=CONFIG_ADGUARDHOME_COMPRESS_GOPROXY | ||
|
||
GO_PKG:=github.com/AdguardTeam/AdGuardHome | ||
GO_PKG_BUILD_PKG:=github.com/AdguardTeam/AdGuardHome | ||
|
||
AGH_BUILD_TIME:=$(shell date -d @$(SOURCE_DATE_EPOCH) +%FT%TZ%z) | ||
AGH_VERSION_PKG:=github.com/AdguardTeam/AdGuardHome/internal/version | ||
GO_PKG_LDFLAGS_X:=$(AGH_VERSION_PKG).channel=release \ | ||
$(AGH_VERSION_PKG).version=v$(PKG_VERSION) \ | ||
$(AGH_VERSION_PKG).buildtime=$(AGH_BUILD_TIME) \ | ||
$(AGH_VERSION_PKG).goarm=$(GO_ARM) \ | ||
$(AGH_VERSION_PKG).gomips=$(GO_MIPS) | ||
|
||
include $(INCLUDE_DIR)/package.mk | ||
include $(TOPDIR)/feeds/packages/lang/golang/golang-package.mk | ||
|
||
define Package/adguardhome | ||
SECTION:=net | ||
CATEGORY:=Network | ||
TITLE:=Network-wide ads and trackers blocking DNS server | ||
URL:=https://github.com/AdguardTeam/AdGuardHome | ||
DEPENDS:=$(GO_ARCH_DEPENDS) +ca-bundle | ||
endef | ||
|
||
define Package/adguardhome/conffiles | ||
/etc/adguardhome.yaml | ||
/etc/config/adguardhome | ||
endef | ||
|
||
define Package/adguardhome/description | ||
Free and open source, powerful network-wide ads and trackers blocking DNS server. | ||
endef | ||
|
||
define Package/$(PKG_NAME)/config | ||
config ADGUARDHOME_COMPRESS_GOPROXY | ||
bool "Compiling with GOPROXY proxy" | ||
default n | ||
endef | ||
|
||
ifeq ($(CONFIG_ADGUARDHOME_COMPRESS_GOPROXY),y) | ||
export GO111MODULE=on | ||
export GOPROXY=https://goproxy.bj.bcebos.com | ||
endif | ||
|
||
define Build/Compile | ||
( \ | ||
pushd $(PKG_BUILD_DIR) ; \ | ||
make js-deps js-build ; \ | ||
popd ; \ | ||
$(call GoPackage/Build/Compile) ; \ | ||
) | ||
endef | ||
|
||
define Package/adguardhome/install | ||
$(call GoPackage/Package/Install/Bin,$(1)) | ||
$(INSTALL_DIR) $(1)/etc/init.d | ||
$(INSTALL_BIN) ./files/adguardhome.init $(1)/etc/init.d/adguardhome | ||
|
||
$(INSTALL_DIR) $(1)/etc/config | ||
$(INSTALL_DATA) ./files/adguardhome.config $(1)/etc/config/adguardhome | ||
endef | ||
|
||
$(eval $(call GoBinPackage,adguardhome)) | ||
$(eval $(call BuildPackage,adguardhome)) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,4 @@ | ||
config adguardhome config | ||
option enabled '0' | ||
# Where to store persistent data by AdGuard Home | ||
option workdir /var/adguardhome |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
#!/bin/sh /etc/rc.common | ||
|
||
PROG=/usr/bin/AdGuardHome | ||
|
||
USE_PROCD=1 | ||
|
||
# starts after network starts | ||
START=21 | ||
# stops before networking stops | ||
STOP=89 | ||
|
||
start_service() { | ||
config_load adguardhome | ||
config_get_bool enabled config enabled | ||
config_get WORK_DIR config workdir | ||
|
||
[ "$enabled" -eq "1" ] || exit 2 | ||
[ -d "$WORK_DIR" ] || mkdir -m 0755 -p "$WORK_DIR" | ||
|
||
procd_open_instance | ||
procd_set_param command "$PROG" -c /etc/adguardhome.yaml -w "$WORK_DIR" --no-check-update | ||
procd_set_param stdout 1 | ||
procd_set_param stderr 1 | ||
procd_close_instance | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- a/client/src/login/Login/Form.js | ||
+++ b/client/src/login/Login/Form.js | ||
@@ -25,7 +25,7 @@ const Form = (props) => { | ||
type="text" | ||
className="form-control" | ||
component={renderInputField} | ||
- placeholder={t('username_placeholder')} | ||
+ placeholder="默认用户名密码都是root" | ||
autoComplete="username" | ||
autocapitalize="none" | ||
disabled={processing} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,9 @@ | ||
--- a/client/src/helpers/version.js | ||
+++ b/client/src/helpers/version.js | ||
@@ -13,5 +13,5 @@ export const areEqualVersions = (left, right) => { | ||
|
||
const leftVersion = left.replace(/^v/, ''); | ||
const rightVersion = right.replace(/^v/, ''); | ||
- return leftVersion === rightVersion; | ||
+ return leftVersion >= rightVersion; | ||
}; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,77 @@ | ||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_NAME:=aliyundrive-fuse | ||
PKG_VERSION:=0.1.14 | ||
PKG_RELEASE:=$(AUTORELEASE) | ||
|
||
PKG_LICENSE:=MIT | ||
PKG_MAINTAINER:=messense <[email protected]> | ||
|
||
PKG_LIBC:=musl | ||
ifeq ($(ARCH),arm) | ||
PKG_LIBC:=musleabi | ||
|
||
ARM_CPU_FEATURES:=$(word 2,$(subst +,$(space),$(call qstrip,$(CONFIG_CPU_TYPE)))) | ||
ifneq ($(filter $(ARM_CPU_FEATURES),vfp vfpv2),) | ||
PKG_LIBC:=musleabihf | ||
endif | ||
endif | ||
|
||
PKG_ARCH=$(ARCH) | ||
ifeq ($(ARCH),i386) | ||
PKG_ARCH:=i686 | ||
endif | ||
|
||
PKG_SOURCE:=aliyundrive-fuse-v$(PKG_VERSION).$(PKG_ARCH)-unknown-linux-$(PKG_LIBC).tar.gz | ||
PKG_SOURCE_URL:=https://github.com/messense/aliyundrive-fuse/releases/download/v$(PKG_VERSION)/ | ||
PKG_HASH:=skip | ||
|
||
include $(INCLUDE_DIR)/package.mk | ||
|
||
define Package/aliyundrive-fuse | ||
SECTION:=multimedia | ||
CATEGORY:=Multimedia | ||
DEPENDS:=+fuse-utils | ||
TITLE:=FUSE for AliyunDrive | ||
URL:=https://github.com/messense/aliyundrive-fuse | ||
endef | ||
|
||
define Package/aliyundrive-fuse/description | ||
FUSE for AliyunDrive. | ||
endef | ||
|
||
define Package/aliyundrive-fuse/conffiles | ||
/etc/config/aliyundrive-fuse | ||
endef | ||
|
||
define Download/sha256sum | ||
FILE:=$(PKG_SOURCE).sha256 | ||
URL_FILE:=$(FILE) | ||
URL:=$(PKG_SOURCE_URL) | ||
HASH:=skip | ||
endef | ||
$(eval $(call Download,sha256sum)) | ||
|
||
define Build/Prepare | ||
mv $(DL_DIR)/$(PKG_SOURCE).sha256 . | ||
cp $(DL_DIR)/$(PKG_SOURCE) . | ||
shasum -a 256 -c $(PKG_SOURCE).sha256 | ||
rm $(PKG_SOURCE).sha256 $(PKG_SOURCE) | ||
|
||
tar -C $(PKG_BUILD_DIR)/ -zxf $(DL_DIR)/$(PKG_SOURCE) | ||
endef | ||
|
||
define Build/Compile | ||
echo "aliyundrive-fuse using precompiled binary." | ||
endef | ||
|
||
define Package/aliyundrive-fuse/install | ||
$(INSTALL_DIR) $(1)/usr/bin | ||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/aliyundrive-fuse $(1)/usr/bin/aliyundrive-fuse | ||
$(INSTALL_DIR) $(1)/etc/init.d | ||
$(INSTALL_BIN) ./files/aliyundrive-fuse.init $(1)/etc/init.d/aliyundrive-fuse | ||
$(INSTALL_DIR) $(1)/etc/config | ||
$(INSTALL_CONF) ./files/aliyundrive-fuse.config $(1)/etc/config/aliyundrive-fuse | ||
endef | ||
|
||
$(eval $(call BuildPackage,aliyundrive-fuse)) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
config default | ||
option enable '0' | ||
option debug '0' | ||
option refresh_token '' | ||
option domain_id '' | ||
option mount_point '/mnt/aliyundrive' | ||
option read_buffer_size '10485760' | ||
option allow_other '1' |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
#!/bin/sh /etc/rc.common | ||
|
||
USE_PROCD=1 | ||
|
||
START=99 | ||
STOP=15 | ||
|
||
NAME=aliyundrive-fuse | ||
|
||
uci_get_by_type() { | ||
local ret=$(uci get $NAME.@$1[0].$2 2>/dev/null) | ||
echo ${ret:=$3} | ||
} | ||
|
||
start_service() { | ||
local enable=$(uci_get_by_type default enable) | ||
case "$enable" in | ||
1|on|true|yes|enabled) | ||
local refresh_token=$(uci_get_by_type default refresh_token) | ||
local domain_id=$(uci_get_by_type default domain_id) | ||
local mount_point=$(uci_get_by_type default mount_point) | ||
local read_buf_size=$(uci_get_by_type default read_buffer_size 10485760) | ||
local allow_other=$(uci_get_by_type default allow_other 0) | ||
|
||
local extra_options="" | ||
|
||
if [[ ! -z "$domain_id" ]]; then | ||
extra_options="$extra_options --domain-id $domain_id" | ||
fi | ||
|
||
if [ "$allow_other" = "1" ]; then | ||
extra_options="$extra_options --allow-other" | ||
fi | ||
|
||
mkdir -p "$mount_point" | ||
procd_open_instance | ||
procd_set_param command /bin/sh -c "/usr/bin/$NAME $extra_options -S $read_buf_size --workdir /var/run/$NAME $mount_point >>/var/log/$NAME.log 2>&1" | ||
procd_set_param pidfile /var/run/$NAME.pid | ||
procd_set_param env REFRESH_TOKEN="$refresh_token" | ||
case $(uci_get_by_type default debug) in | ||
1|on|true|yes|enabled) | ||
procd_append_param env RUST_LOG="aliyundrive_fuse=debug" ;; | ||
*) ;; | ||
esac | ||
procd_close_instance ;; | ||
*) | ||
stop_service ;; | ||
esac | ||
} | ||
|
||
service_triggers() { | ||
procd_add_reload_trigger "aliyundrive-fuse" | ||
} |
Oops, something went wrong.