This repository has been archived by the owner on Jul 25, 2022. It is now read-only.
v2.0
* refactor: reroute sourcing * gotcha! (spaces for tabs) * fix:search_for_unwatched fn to some extent * chore: optimize decrpyt function * *QA: tidying up comments *QA: made function `search_another_anime()` inline *planning: marked some todo-s * ignore SC2059 There's no posix alternative to line 161 that complies with SC2059 * fix:history reimplementation, not backwords compatible * fix:pass shellcheck 1 * fix:minor bugs * fix:variable id in links * *UX: made "Currently playing..." not contain "-episode-" * *UX: made `anime_selection` only display the anime title * *appease the linter * *appease the linter 2 * *appease the linter 3 * fix:ios compatibility * fix: appease the linter * fix:human error, optimizations * Merge branch 'master' into v2 * *QA: minor changes * * Fix: way to search by english name. (it's slow) * QA: removed input checking from `episode selection` * QA: removed `is_number` QA: removed duplicate functionality from `check_input` QA: renamed `check_input` to `generate_ep_list` * Fix: fixed episode selection * Fix: fixed episode stepping in `LOOP` * Documentation: actualised CONTRIBUTING.md Documentation: updated README.md and disclaimer.md with new provider * feat: new UI * chore: shellcheck * fix:sed and optimizations * Formatting: spaces to tabs Formatting: removed double spaces * Formatting: spaces to tabs * chore: shellcheck * chore: changed mpv displayed_title * chore: shellcheck * refactor: remove git as dependency * docs: new demo * chore: fixed video embed * Formatting: whitespaces * test: reenable 2059 * refactor: remove support for half episodes * refactor: echo -> printf * slimmed down interactive menu * refactor: asynchronous history search * chore: shellcheck * refactor: merge search_for_unwatched into search_history * style: change if to one-liner * feat: add back episode selection in main menu * docs: issue template -U * refactor: removed -h bloat * QA: made the asynchronous part more readable * refactor: debloatification in choice menu * QA: replaced `var=` instances with `unset var` * docs: updated description under discord Co-authored-by: CoolnsX <[email protected]> Co-authored-by: Derisis13 <[email protected]> Co-authored-by: Derisis13 <[email protected]> Co-authored-by: iamchokerman <[email protected]> Co-authored-by: zenith71 <[email protected]> Co-authored-by: ivan <[email protected]>