Skip to content

Commit

Permalink
ar71xx: Support for Ubiquiti UniFi AP AC LITE
Browse files Browse the repository at this point in the history
Add support for the Ubiquiti UniFi AP AC LITE
Signed-off-by: P.Wassi <p.wassi at gmx.at>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48711 3c298f89-4303-0410-b956-a3cf2f4a3e73
  • Loading branch information
John Crispin committed Feb 12, 2016
1 parent a6a72a7 commit de350dc
Show file tree
Hide file tree
Showing 13 changed files with 154 additions and 2 deletions.
1 change: 1 addition & 0 deletions target/linux/ar71xx/base-files/etc/board.d/02_network
Original file line number Diff line number Diff line change
Expand Up @@ -360,6 +360,7 @@ tl-wa901nd-v2 |\
tl-wa901nd-v3 |\
tl-wr703n |\
tube2h |\
unifiac |\
wndap360 |\
mynet-rext |\
wp543)
Expand Down
3 changes: 2 additions & 1 deletion target/linux/ar71xx/base-files/etc/diag.sh
Original file line number Diff line number Diff line change
Expand Up @@ -339,7 +339,8 @@ get_status_led() {
unifi)
status_led="ubnt:green:dome"
;;
uap-pro)
uap-pro | \
unifiac)
status_led="ubnt:white:dome"
;;
unifi-outdoor-plus)
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -75,6 +75,9 @@ case "$FIRMWARE" in
ath10kcal_extract "ART" 20480 2116
ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +16)
;;
unifiac)
ath10kcal_extract "EEPROM" 20480 2116
;;
esac
;;
"ath10k/cal-pci-0000:01:00.0.bin")
Expand Down
3 changes: 3 additions & 0 deletions target/linux/ar71xx/base-files/lib/ar71xx.sh
Original file line number Diff line number Diff line change
Expand Up @@ -908,6 +908,9 @@ ar71xx_board_detect() {
*UniFi)
name="unifi"
;;
*"UniFi-AC")
name="unifiac"
;;
*"UniFi AP Pro")
name="uap-pro"
;;
Expand Down
1 change: 1 addition & 0 deletions target/linux/ar71xx/base-files/lib/upgrade/platform.sh
Original file line number Diff line number Diff line change
Expand Up @@ -263,6 +263,7 @@ platform_check_image() {
wlae-ag300n | \
nbg460n_550n_550nh | \
unifi | \
unifiac | \
unifi-outdoor | \
carambola2 | \
weio )
Expand Down
10 changes: 10 additions & 0 deletions target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
Original file line number Diff line number Diff line change
Expand Up @@ -1356,6 +1356,16 @@ config ATH79_MACH_UBNT
select ATH79_DEV_M25P80
select ATH79_DEV_USB

config ATH79_MACH_UBNT_UNIFIAC
bool "Ubiquiti UniFi AC (LITE) support"
select SOC_QCA956X
select ATH79_DEV_AP9X_PCI if PCI
select ATH79_DEV_ETH
select ATH79_DEV_GPIO_BUTTONS
select ATH79_DEV_LEDS_GPIO
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC

config ATH79_MACH_WEIO
bool "WeIO board"
select SOC_AR933X
Expand Down
1 change: 1 addition & 0 deletions target/linux/ar71xx/files/arch/mips/ath79/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -166,6 +166,7 @@ obj-$(CONFIG_ATH79_MACH_TL_WR720N_V3) += mach-tl-wr720n-v3.o
obj-$(CONFIG_ATH79_MACH_TUBE2H) += mach-tube2h.o
obj-$(CONFIG_ATH79_MACH_UBNT) += mach-ubnt.o
obj-$(CONFIG_ATH79_MACH_UBNT_XM) += mach-ubnt-xm.o
obj-$(CONFIG_ATH79_MACH_UBNT_UNIFIAC) += mach-ubnt-unifiac.o
obj-$(CONFIG_ATH79_MACH_WEIO) += mach-weio.o
obj-$(CONFIG_ATH79_MACH_WHR_HP_G300N) += mach-whr-hp-g300n.o
obj-$(CONFIG_ATH79_MACH_WLAE_AG300N) += mach-wlae-ag300n.o
Expand Down
109 changes: 109 additions & 0 deletions target/linux/ar71xx/files/arch/mips/ath79/mach-ubnt-unifiac.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,109 @@
/*
* Ubiquiti UniFi AC (LITE) board support
*
* Copyright (C) 2015-2016 P. Wassi <p.wassi at gmx.at>
*
* Derived from: mach-ubnt-xm.c
*
* This program is free software; you can redistribute it and/or modify it
* under the terms of the GNU General Public License version 2 as published
* by the Free Software Foundation.
*/

#include <linux/init.h>
#include <linux/pci.h>
#include <linux/platform_device.h>
#include <linux/ath9k_platform.h>
#include <linux/etherdevice.h>

#include <asm/mach-ath79/ath79.h>
#include <asm/mach-ath79/irq.h>
#include <asm/mach-ath79/ar71xx_regs.h>

#include <linux/platform_data/phy-at803x.h>

#include "common.h"
#include "dev-ap9x-pci.h"
#include "dev-eth.h"
#include "dev-gpio-buttons.h"
#include "dev-leds-gpio.h"
#include "dev-m25p80.h"
#include "dev-wmac.h"
#include "machtypes.h"


#define UNIFIAC_KEYS_POLL_INTERVAL 20
#define UNIFIAC_KEYS_DEBOUNCE_INTERVAL (3 * UNIFIAC_KEYS_POLL_INTERVAL)

#define UNIFIAC_GPIO_LED_WHITE 7
#define UNIFIAC_GPIO_LED_BLUE 8

#define UNIFIAC_GPIO_BTN_RESET 2

#define UNIFIAC_MAC0_OFFSET 0x0000
#define UNIFIAC_WMAC_CALDATA_OFFSET 0x1000
#define UNIFIAC_PCI_CALDATA_OFFSET 0x5000


static struct flash_platform_data ubnt_unifiac_flash_data = {
/* mx25l12805d and mx25l12835f have the same JEDEC ID */
.type = "mx25l12805d",
};

static struct gpio_led ubnt_unifiac_leds_gpio[] __initdata = {
{
.name = "ubnt:white:dome",
.gpio = UNIFIAC_GPIO_LED_WHITE,
.active_low = 0,
}, {
.name = "ubnt:blue:dome",
.gpio = UNIFIAC_GPIO_LED_BLUE,
.active_low = 0,
}
};

static struct gpio_keys_button ubnt_unifiac_gpio_keys[] __initdata = {
{
.desc = "reset",
.type = EV_KEY,
.code = KEY_RESTART,
.debounce_interval = UNIFIAC_KEYS_DEBOUNCE_INTERVAL,
.gpio = UNIFIAC_GPIO_BTN_RESET,
.active_low = 1,
}
};

static void __init ubnt_unifiac_setup(void)
{
u8 *eeprom = (u8 *) KSEG1ADDR(0x1fff0000);

ath79_register_m25p80(&ubnt_unifiac_flash_data);


ath79_init_mac(ath79_eth0_data.mac_addr,
eeprom + UNIFIAC_MAC0_OFFSET, 0);

ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_SGMII;
ath79_eth0_data.phy_mask = BIT(4);
ath79_eth0_pll_data.pll_10 = 0x00001313;

ath79_register_mdio(0, ~BIT(4));
ath79_register_eth(0);


ath79_register_wmac(eeprom + UNIFIAC_WMAC_CALDATA_OFFSET, NULL);


ap91_pci_init(eeprom + UNIFIAC_PCI_CALDATA_OFFSET, NULL);


ath79_register_leds_gpio(-1, ARRAY_SIZE(ubnt_unifiac_leds_gpio),
ubnt_unifiac_leds_gpio);

ath79_register_gpio_keys_polled(-1, UNIFIAC_KEYS_POLL_INTERVAL,
ARRAY_SIZE(ubnt_unifiac_gpio_keys),
ubnt_unifiac_gpio_keys);
}

MIPS_MACHINE(ATH79_MACH_UBNT_UNIFIAC, "UBNT-UF-AC", "Ubiquiti UniFi-AC",
ubnt_unifiac_setup);
1 change: 1 addition & 0 deletions target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
Original file line number Diff line number Diff line change
Expand Up @@ -211,6 +211,7 @@ enum ath79_mach_type {
ATH79_MACH_UBNT_RS, /* Ubiquiti RouterStation */
ATH79_MACH_UBNT_UAP_PRO, /* Ubiquiti UniFi AP Pro */
ATH79_MACH_UBNT_UNIFI, /* Ubiquiti Unifi */
ATH79_MACH_UBNT_UNIFIAC, /* Ubiquiti Unifi AC */
ATH79_MACH_UBNT_UNIFI_OUTDOOR, /* Ubiquiti UnifiAP Outdoor */
ATH79_MACH_UBNT_UNIFI_OUTDOOR_PLUS, /* Ubiquiti UnifiAP Outdoor+ */
ATH79_MACH_UBNT_XM, /* Ubiquiti Networks XM board rev 1.0 */
Expand Down
11 changes: 11 additions & 0 deletions target/linux/ar71xx/generic/profiles/ubnt.mk
Original file line number Diff line number Diff line change
Expand Up @@ -38,6 +38,17 @@ endef

$(eval $(call Profile,UBNTUNIFI))

define Profile/UBNTUNIFIAC
NAME:=Ubiquiti UniFi AP AC
PACKAGES:=kmod-ath10k ath10k-firmware-qca988x
endef

define Profile/UBNTUNIFIAC/Description
Package set optimized for the Ubiquiti UniFi AP AC.
endef

$(eval $(call Profile,UBNTUNIFIAC))

define Profile/UBNTUNIFIOUTDOOR
NAME:=Ubiquiti UniFiAP Outdoor
PACKAGES:=
Expand Down
11 changes: 10 additions & 1 deletion target/linux/ar71xx/image/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -1141,12 +1141,21 @@ define Device/ubnt-unifi
DEVICE_PROFILE := UBNT UBNTUNIFI
endef

define Device/ubnt-unifiac
DEVICE_PROFILE := UBNT UBNTUNIFIAC
IMAGE_SIZE := 7744k
MTDPARTS = spi0.0:384k(u-boot)ro,64k(u-boot-env)ro,7744k(firmware),7744k(ubnt-airos)ro,128k(bs)ro,256k(cfg)ro,64k(EEPROM)ro
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin = append-kernel $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
BOARDNAME := UBNT-UF-AC
endef

define Device/ubnt-unifi-outdoor
$(Device/ubnt-bz)
BOARDNAME := UBNT-U20
DEVICE_PROFILE := UBNT UBNTUNIFIOUTDOOR
endef
TARGET_DEVICES += ubnt-unifi ubnt-unifi-outdoor
TARGET_DEVICES += ubnt-unifi ubnt-unifiac ubnt-unifi-outdoor

define Device/ubnt-nano-m-xw
$(Device/ubnt-xw)
Expand Down
1 change: 1 addition & 0 deletions target/linux/ar71xx/mikrotik/config-default
Original file line number Diff line number Diff line change
Expand Up @@ -104,6 +104,7 @@ CONFIG_ATH79_MACH_RBSXTLITE=y
# CONFIG_ATH79_MACH_TUBE2H is not set
# CONFIG_ATH79_MACH_UBNT is not set
# CONFIG_ATH79_MACH_UBNT_XM is not set
# CONFIG_ATH79_MACH_UBNT_UNIFIAC is not set
# CONFIG_ATH79_MACH_WHR_HP_G300N is not set
# CONFIG_ATH79_MACH_WLAE_AG300N is not set
# CONFIG_ATH79_MACH_WLR8100 is not set
Expand Down
1 change: 1 addition & 0 deletions target/linux/ar71xx/nand/config-default
Original file line number Diff line number Diff line change
Expand Up @@ -63,6 +63,7 @@
# CONFIG_ATH79_MACH_TL_WR941ND is not set
# CONFIG_ATH79_MACH_UBNT is not set
# CONFIG_ATH79_MACH_UBNT_XM is not set
# CONFIG_ATH79_MACH_UBNT_UNIFIAC is not set
# CONFIG_ATH79_MACH_WHR_HP_G300N is not set
# CONFIG_ATH79_MACH_WLAE_AG300N is not set
# CONFIG_ATH79_MACH_WNDAP360 is not set
Expand Down

0 comments on commit de350dc

Please sign in to comment.