Skip to content

Commit

Permalink
dev-ruby/rails-html-sanitizer: add ruby23 revision
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
graaff committed Jul 18, 2016
1 parent e20b105 commit 2dcc312
Showing 1 changed file with 33 additions and 0 deletions.
33 changes: 33 additions & 0 deletions dev-ruby/rails-html-sanitizer/rails-html-sanitizer-1.0.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby20 ruby21 ruby22 ruby23"

RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"

inherit ruby-fakegem

DESCRIPTION="Sanitize HTML fragments in Rails applications"
HOMEPAGE="https://github.com/rafaelfranca/rails-html-sanitizer"

LICENSE="MIT"
SLOT="1"
KEYWORDS="~amd64 ~arm ~ppc64 ~amd64-linux"
IUSE=""

ruby_add_rdepend "dev-ruby/loofah:0"

ruby_add_bdepend "test? ( dev-ruby/rails-dom-testing )"

all_ruby_prepare() {
# Avoid tests failing with libxml2-2.9.3
# https://github.com/rails/rails-html-sanitizer/issues/49
sed -i -e '/test_\(strip_links_with_tags_in_tags\|strip_nested_tags\|should_sanitize_script_tag_with_multiple_open_brackets\|strip_tags_with_many_open_quotes\|strip_invalid_html\)/,/^ end/ s:^:#:' test/sanitizer_test.rb || die
}

each_ruby_test() {
${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
}

0 comments on commit 2dcc312

Please sign in to comment.