Skip to content

Commit

Permalink
dev-util/buildbot-www: Version bump to 1.3.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
dol-sen committed Jul 26, 2018
1 parent 39f0abe commit 5963fb4
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/buildbot-www/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST buildbot-www-0.9.12.tar.gz 691551 BLAKE2B 9bef044fe9e48e34d3e314d9c9b7446a1e295898c432da5c8915e36156f2f934fd065c8075dd55f68da7bc29a567c1ef276bc415df38911aff7c33de46fa7942 SHA512 6c525d32407be24aa728a0bd9c9a09c64bb4bef092ef9e5285475527f7fcbd89d516ea376d90b22aa24af384d73125bc886360cf992dfe3d01471838193f351a
DIST buildbot-www-1.1.2.tar.gz 718705 BLAKE2B 009ae0dc07693f9eee4e3982ccbecb32d64e7d27e374f539cd541a5f80d9b9bf798e8836502cd26a5477b0ee842dbfae2308608fa3320e682afd0bcda2f89f1e SHA512 e4a0f7aee5e38d0522d39c819d4b9865966e020fd89b156e79807417fd7f82d497fbceafcc8a89e5beb6def1f42e4bfc595053581cbe2634520ad2c806ce3968
DIST buildbot-www-1.3.0.tar.gz 717517 BLAKE2B 57b0ed7ef46fecb242562a0f93e234985c9cc0ea55d273c1c5de74753f6ea83d25d5017515afb6ad4b7bff4f80cdfb9a6daf937c5cd133c017c9bd6fa9d6d7ee SHA512 e01d1d3528ab1f29ff136321b25f45b01733a4f23cd9d637c9e3290b5301a8ac3dc545decb178c1332e58dc3e11065ef73df49fbb46fca6068acabdd40a8bff1
51 changes: 51 additions & 0 deletions dev-util/buildbot-www/buildbot-www-1.3.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"
PYTHON_REQ_USE="sqlite"
PYTHON_COMPAT=( python2_7 python3_{4,5,6} )

EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"

[[ ${PV} == *9999 ]] && inherit git-r3
inherit distutils-r1

DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-www/"

MY_PV="${PV/_p/.post}"
MY_P="${PN}-${MY_PV}"
[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"

if [[ ${PV} == *9999 ]]; then
KEYWORDS=""
else
KEYWORDS="~amd64"
fi

IUSE="test"

RDEPEND=""

DEPEND="${RDEPEND}
>=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
"

S="${WORKDIR}/${MY_P}"
#[[ ${PV} == *9999 ]] && S=${S}/www/base

python_test() {
distutils_install_for_testing

esetup.py test || die "Tests failed under ${EPYTHON}"
}

python_install_all() {
distutils-r1_python_install_all
}

0 comments on commit 5963fb4

Please sign in to comment.