Skip to content

Commit

Permalink
app-emulation/containerd: Update snapshot
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.8, Repoman-2.3.3
  • Loading branch information
mrueg committed Aug 21, 2017
1 parent 1418eb2 commit 8e4949b
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/containerd/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST containerd-0.2.5_p20170308.tar.gz 1021631 SHA256 d08d3d0758b76f7de0e8f503b74e1562d8c0a1014cb4baf4cd34e246751cec4c SHA512 8b00862a7b54490a8342bcc0eddaa7e8c86d1e05c02f5173b9f4a08321425f8d75d1fb0665e86bc79249294354977693c21d6a4d8405866ff8058da9772e2ecc WHIRLPOOL ed658d10f927fff4d9591930bdf855fc0ed259ca538d4361ce3cffcc5943dcfe39121242f1c9ef950897761016a8450b3a2117c0be0b8b0ebffeab330fe30b5d
DIST containerd-0.2.9.tar.gz 1228977 SHA256 2360fec91d40e4e93757f964f07c74e35b6bfe838252b1cc814a176e1cd1c604 SHA512 6f0de476668e6b86a0cd5e1ea0f6dac24e0e68fe2dd52b8915dbafa5ffab137a5eea866c216f8184ffa6e4750c7b69bce3d46552e8be283a15ce676ea4356fc8 WHIRLPOOL b9fdd57af3cf39e6a5efdd67f0302ad38d6634d20aa3eb45431d2900f5fbb7dc62d624b07a5028bbb09ae763e07103e37703cf52f3e14e7af72fc2198d9c7876
DIST containerd-0.2.9_p20170605.tar.gz 1229549 SHA256 c506121c49e3bfea27018aa77e09e4734067f84ae85b6ef75ec31b488a91ae54 SHA512 900cf9c251c4de0f9848fb5bf26537226c1361d1a64a0fba853bda3805cb141fc2a849442fe885f0ee228b3e3a7018440af18898b484a54a7b75b4a86538aaa9 WHIRLPOOL 880f19a994f623b7cd8c3f771b5c56468681de349ae4196e60ffcb5a34d42ef423d8eefc82c07134c9e50c33bc0ecbfc1a9e47c3df987050d8dcb82da0178d80
42 changes: 42 additions & 0 deletions app-emulation/containerd/containerd-0.2.9_p20170605.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EGO_PN="github.com/${PN}/${PN}"

inherit toolchain-funcs

if [[ ${PV} == *9999 ]]; then
inherit golang-vcs
else
MY_PV="${PV/_/-}"
EGIT_COMMIT="6e23458c129b551d5c9871e5174f6b1b7f6d1170"
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~ppc64"
inherit golang-vcs-snapshot
fi

DESCRIPTION="A daemon to control runC"
HOMEPAGE="https://containerd.tools"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="hardened +seccomp"

DEPEND=""
RDEPEND=">=app-emulation/docker-runc-1.0.0_rc3_p20170706
seccomp? ( sys-libs/libseccomp )"

S=${WORKDIR}/${P}/src/${EGO_PN}

RESTRICT="test"

src_compile() {
local options=( $(usex seccomp "seccomp" '') )
export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
}

src_install() {
dobin bin/containerd* bin/ctr
}

0 comments on commit 8e4949b

Please sign in to comment.