Skip to content

Commit

Permalink
dev-php/reactphp-promise: new package
Browse files Browse the repository at this point in the history
New dependency of dev-php/composer-2.

Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Feb 1, 2021
1 parent b922c43 commit dbd7177
Show file tree
Hide file tree
Showing 3 changed files with 61 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/reactphp-promise/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST reactphp-promise-2.8.0.tar.gz 17178 BLAKE2B 43e5a9eef0f774ec4de7be44fbab300dfd78a23b21de2acbb39e44af49ee95b2532f66b711acc4ee152522d4725e1e29f9abae20d0ac2e18fba3dbb3f615cc5e SHA512 8c882c96b47cc53f791de964303014feb00a73594a510287ea352ff619a8432d88f4c094523d4de98234f985f7351cd244bb094484a257aa36357e85eb0ee62e
12 changes: 12 additions & 0 deletions dev-php/reactphp-promise/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>PHP</name>
</maintainer>
<stabilize-allarches/>
<upstream>
<remote-id type="github">reactphp/promise</remote-id>
</upstream>
</pkgmetadata>
48 changes: 48 additions & 0 deletions dev-php/reactphp-promise/reactphp-promise-2.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

MY_PN="promise"

DESCRIPTION="A lightweight implementation of CommonJS Promises/A for PHP"
HOMEPAGE="https://reactphp.org/promise/"
SRC_URI="https://github.com/reactphp/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

BDEPEND="dev-php/theseer-Autoload"

RDEPEND="dev-php/fedora-autoloader
>=dev-lang/php-7.2:*"

S="${WORKDIR}/${MY_PN}-${PV}"

src_prepare() {
default

phpab \
--output src/autoload.php \
--template fedora2 \
--basedir src \
src \
|| die

cat >> src/autoload.php <<EOF || die "failed to extend autoload.php"
// Dependencies
\Fedora\Autoloader\Dependencies::required([
'/usr/share/php/React/Promise/functions.php'
]);
EOF
}

src_install() {
insinto /usr/share/php/React/Promise
doins -r src/*

einstalldocs
}

0 comments on commit dbd7177

Please sign in to comment.