Skip to content

Commit

Permalink
media-tv/me-tv: Fix building with GCC6 and -Werror=terminate (bug #61…
Browse files Browse the repository at this point in the history
…3426)

Package-Manager: Portage-2.3.5, Repoman-2.3.2
Closes: gentoo#4308
  • Loading branch information
Peter-Levine authored and SoapGentoo committed Apr 16, 2017
1 parent 7ad2c40 commit e9a14be
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 1 deletion.
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
--- a/server/data.cc
+++ b/server/data.cc
@@ -68,7 +68,7 @@
}
}

-Statement::~Statement()
+Statement::~Statement() NOEXCEPT
{
if (sqlite3_finalize(statement) != 0)
{
--- a/server/data.h
+++ b/server/data.h
@@ -26,6 +26,12 @@
#include <linux/dvb/frontend.h>
#include <glibmm.h>

+#if __cplusplus >= 201103L
+#define NOEXCEPT noexcept(false)
+#else
+#define NOEXCEPT
+#endif
+
typedef std::list<Glib::ustring> StringList;

namespace Data
@@ -68,7 +74,7 @@

public:
Statement(Connection& connection, const Glib::ustring& command);
- ~Statement();
+ ~Statement() NOEXCEPT;

void reset();
guint step();
3 changes: 2 additions & 1 deletion media-tv/me-tv/me-tv-1.4.0.10.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5
Expand Down Expand Up @@ -34,6 +34,7 @@ DEPEND="${RDEPEND}
src_prepare() {
append-cxxflags -std=c++11
epatch "${FILESDIR}"/${P}-gcc47.patch
epatch "${FILESDIR}"/${P}-C++11-throw-in-destructors.patch
eautoreconf
}

Expand Down

0 comments on commit e9a14be

Please sign in to comment.