Skip to content

Commit

Permalink
app-office/gnucash: Bump to 3.6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.66, Repoman-2.3.11
Signed-off-by: Aaron W. Swenson <[email protected]>
  • Loading branch information
titanofold committed Jul 3, 2019
1 parent 3155f83 commit eff0d51
Show file tree
Hide file tree
Showing 2 changed files with 177 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-office/gnucash/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,5 @@ DIST gnucash-3.2.tar.bz2 13383942 BLAKE2B ce4beb9eab290bbc85c4b3bf68b205a8ebb274
DIST gnucash-3.3.tar.bz2 13440713 BLAKE2B a308af90d8a8e50eb732d29c7eadac1fb75b63006da5bbaa9044039c43c1c17976c6b6fdb1706a08a527b75b1300df3a8ed469151370097b0308a173a170e41b SHA512 4bf0369ca9b3c91c98a0d916f0befc7e5675a246559a6a72dba6592b64f56f3cbd1885b0711e44e8d9cca290be742812763691ae2f639ea31ec534e52e17b3f9
DIST gnucash-3.4.tar.bz2 13564432 BLAKE2B 478d8e2e4acbd0725ceaf997a1e62ba3875e9d4a003e8a3e69111a9d29118447fb2da8ef3e5dd5274d83a3adef1ee9f4a153cdfd17cabe69864b53bab8c7e813 SHA512 4cebef0ba70e59a82d3b2b7b0b138ddb22e8866dc761e156ff1f15920145d12923719effef21ad4c65ccd62fbd14a1529cf0bfcaab70c5b33d103761d08062e0
DIST gnucash-3.5.tar.bz2 13766397 BLAKE2B b840fa6af719e1d21daabd8e26f7026a12ca9cefe8c0f644a8382b42c34a6dec2dfc67350645437c2f12792518f289f446824a8c99ea83453e69d976c3cd5c9c SHA512 76230d2fe1ba4cc605d0d58976ed3214b10a2549fc7eaa1e327bbf85c861baa082523c70ed088a59bb56deb6af9a7808752fc719eda0df3e9209cec05c9c8d13
DIST gnucash-3.6.tar.bz2 13811045 BLAKE2B aa722755e168b6096a8ad0bb05d3c67be9525d5e9e6fcf076c0b6bdc3188815017c2b1bcb308a6f8a7581315f7d9ab67f85b24486214ebbe7ea5a0428e552ea7 SHA512 3d99235a6171e7189dbb15fed11e7f3acb4f49ef8dc6124b26807e74ce4326ac5ae6e23e693a34947604ecb0253ecbcd80f669803a629eb7d236fd3444dbfe82
DIST gtest-1.8.0.tar.gz 1281617 BLAKE2B ac052b4d0eb0d8ded03a8c7dff05177818627b8a51f2dbc2c162b2ee2a5d1323539e7d0d02236d9ebb799995e018f0171c2fdaeb4de3bb339548265e50de79e6 SHA512 1dbece324473e53a83a60601b02c92c089f5d314761351974e097b2cf4d24af4296f9eb8653b6b03b1e363d9c5f793897acae1f0c7ac40149216035c4d395d9d
176 changes: 176 additions & 0 deletions app-office/gnucash/gnucash-3.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,176 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

# google{test,mock} version
GV="1.8.0"
PYTHON_COMPAT=( python3_{4,5,6} )

inherit cmake-utils gnome2-utils python-single-r1 xdg-utils

DESCRIPTION="A personal finance manager"
HOMEPAGE="http://www.gnucash.org/"
SRC_URI="https://github.com/Gnucash/${PN}/releases/download/${PV}/${P}.tar.bz2
https://github.com/google/googletest/archive/release-${GV}.tar.gz -> gtest-${GV}.tar.gz"

SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"

IUSE="aqbanking chipcard debug doc examples gnome-keyring +gui mysql nls ofx
postgres python quotes -register2 sqlite"

REQUIRED_USE="
chipcard? ( aqbanking )
python? ( ${PYTHON_REQUIRED_USE} )"

# libdbi version requirement for sqlite taken from bug #455134
#
# dev-libs/boost must always be built with nls enabled.
# guile[deprecated] because of SCM_LIST*() use
RDEPEND="
>=dev-libs/glib-2.46.0:2
>=dev-libs/libxml2-2.7.0:2
>=sys-libs/zlib-1.1.4
>=dev-scheme/guile-2.2.0:12=[deprecated,regex]
dev-libs/boost:=[icu,nls]
dev-libs/icu:=
dev-libs/libxslt
aqbanking? (
>=net-libs/aqbanking-5[gtk,ofx?]
sys-libs/gwenhywfar[gtk]
chipcard? ( sys-libs/libchipcard )
)
gnome-keyring? ( >=app-crypt/libsecret-0.18 )
gui? (
gnome-base/dconf
net-libs/webkit-gtk:4=
>=x11-libs/gtk+-3.14.0:3
)
mysql? (
dev-db/libdbi
dev-db/libdbi-drivers[mysql]
)
ofx? ( >=dev-libs/libofx-0.9.1 )
postgres? (
dev-db/libdbi
dev-db/libdbi-drivers[postgres]
)
python? ( ${PYTHON_DEPS} )
quotes? (
>=dev-perl/Finance-Quote-1.11
dev-perl/Date-Manip
dev-perl/HTML-TableExtract
)
sqlite? (
>=dev-db/libdbi-0.9.0
>=dev-db/libdbi-drivers-0.9.0[sqlite]
)
"

DEPEND="${RDEPEND}
~dev-cpp/gtest-${GV}
>=sys-devel/gettext-0.19.6
dev-lang/perl
dev-perl/XML-Parser
sys-devel/libtool
virtual/pkgconfig
"

PDEPEND="doc? (
~app-doc/gnucash-docs-${PV}
gnome-extra/yelp
)"

PATCHES=( "${FILESDIR}"/${PN}-3.2-no-gui.patch )

pkg_setup() {
use python && python-single-r1_pkg_setup
xdg_environment_reset
}

src_unpack() {
default
cp "${FILESDIR}"/gnucash-3.4-test-stress-options.scm \
${PN}-${PV}/${PN}/report/standard-reports/test/test-stress-options.scm \
|| die "Failed copying scm"
}

src_configure() {
local sql_on_off="OFF"
if use mysql || use postgres || use sqlite ; then
sql_on_off="ON"
fi

local mycmakeargs=(
-DGMOCK_ROOT="${WORKDIR}"/googletest-release-${GV}/googlemock
-DGTEST_ROOT="${WORKDIR}"/googletest-release-${GV}/googletest
# Disable fallback to guile-2.0
-DCMAKE_DISABLE_FIND_PACKAGE_GUILE2=ON
-DCOMPILE_GSCHEMAS=OFF
-DDISABLE_NLS=$(usex !nls)
-DENABLE_REGISTER2=$(usex register2)
-DWITH_AQBANKING=$(usex aqbanking)
-DWITH_OFX=$(usex ofx)
-DWITH_PYTHON=$(usex python)
-DWITH_SQL=${sql_on_off}
-DWITH_GNUCASH=$(usex gui)
)

cmake-utils_src_configure
}

src_test() {
if use python ; then
cp common/test-core/unittest_support.py \
"${BUILD_DIR}"/common/test-core/ || die
fi

cd "${BUILD_DIR}" || die
XDG_DATA_HOME="${T}/$(whoami)" emake check
}

src_install() {
cmake-utils_src_install

rm "${ED%/}"/usr/share/doc/${PF}/README.dependencies || die

if use examples ; then
mv "${ED%/}"/usr/share/doc/gnucash \
"${ED%/}"/usr/share/doc/${PF}/examples || die
pushd "${ED%/}"/usr/share/doc/${PF}/examples/ > /dev/null || die
rm AUTHORS DOCUMENTERS LICENSE NEWS projects.html ChangeLog* \
*win32-bin.txt || die
popd > /dev/null || die
docompress -x /usr/share/doc/${PF}/examples/
else
rm -r "${ED%/}"/usr/share/doc/gnucash || die
fi

use aqbanking && dodoc doc/README.HBCI
use ofx && dodoc doc/README.OFX
}

pkg_postinst() {
if use gui ; then
gnome2_icon_cache_update
gnome2_schemas_update
fi
xdg_desktop_database_update
xdg_mimeinfo_database_update

ewarn "Backup all financial files or databases before using GnuCash >=2.7.0!"
ewarn
ewarn "GnuCash 2.7.0 introduced large changes in its file format and database"
ewarn "schema that WILL prevent you from reverting back to GnuCash 2.6."
}

pkg_postrm() {
if use gui ; then
gnome2_icon_cache_update
gnome2_schemas_update
fi
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

0 comments on commit eff0d51

Please sign in to comment.