Skip to content

Commit

Permalink
app-text/pep: EAPI7, improve ebuild
Browse files Browse the repository at this point in the history
  • Loading branch information
mm1ke authored and a17r committed Aug 15, 2018
1 parent e955172 commit f957dd2
Showing 1 changed file with 50 additions and 0 deletions.
50 changes: 50 additions & 0 deletions app-text/pep/pep-2.8-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs flag-o-matic

DESCRIPTION="General purpose filter and file cleaning program"
HOMEPAGE="http://hannemyr.com/enjoy/pep.html"
SRC_URI="http://hannemyr.com/enjoy/${PN}${PV//./}.zip"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~mips ~ppc ~x86 ~x86-linux ~ppc-macos"

DEPEND="app-arch/unzip"

S=${WORKDIR}

# pep does not come with autconf so here's a patch to configure
# Makefile with the correct path
PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
"${FILESDIR}"/${P}-include.patch
)

src_prepare() {
default
# Darwin lacks stricmp and DIRCHAR
if [[ ${CHOST} == *-darwin* ]] ; then
sed -i -e '/^OBJS/s/^\(.*\)$/\1 bdmg.o/' Makefile || die
append-flags "-Dunix" -DSTRICMP
fi
}

src_compile() {
# make man page too
make Doc/pep.1 || die "make man page failed"
emake CC="$(tc-getCC)"
}

src_install() {
dobin pep
doman Doc/pep.1

insinto /usr/share/pep
doins Filters/*

dodoc aareadme.txt file_id.diz
}

0 comments on commit f957dd2

Please sign in to comment.