Skip to content

Commit

Permalink
lxqt-base/liblxqt: Version bump to 0.11.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.1
  • Loading branch information
mrueg committed Sep 26, 2016
1 parent cabcc5d commit 01bbeb4
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions lxqt-base/liblxqt/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST liblxqt-0.10.0.tar.xz 77732 SHA256 77a42a9ae79d0887bf09cba0c6aaf59ba71edb0bc807736384d1072254aace7c SHA512 75686ea2c6f90f8898ee34024a93d8d091ff5cde02204ca860fddb968b5237576165102d6ea801bc0da32951b3effe565400f9edc3bac97ba2ba6de53eccf04f WHIRLPOOL f41eacfb0aff1c228ca95c1be2a65fb412ea3f93de8f91e9ee56c63994b257f8b61beba61e3f985dca7097efa12af7b97a53f3bd4bd5d084de2324bcc8863f4b
DIST liblxqt-0.11.0.tar.xz 58912 SHA256 bc553bf53f3083886b5456a3f22e227f68ea945d8ee0dd31dd24f765bf879fe2 SHA512 df2aaba0c0b723975c65a063ef3c6564a60d1ac8662da443e1ff9030b1dd61bc264916e5efac272895048f7219a5cb5413e98aa12c5340b547413ad686f2c9ed WHIRLPOOL 7f3b0674900825c16a1c89ecaf7bafa5130583f885323fcfb288c6591bd7e4655b79729691eb94f2f1ca19e5785729ac35d67aa3349299fcf8e8c2cd20726df0
45 changes: 45 additions & 0 deletions lxqt-base/liblxqt/liblxqt-0.11.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit cmake-utils

DESCRIPTION="Common base library for the LXQt desktop environment"
HOMEPAGE="http://lxqt.org/"

if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="git://git.lxde.org/git/lxde/${PN}.git"
else
SRC_URI="https://downloads.lxqt.org/lxqt/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi

LICENSE="GPL-2 LGPL-2.1+"
SLOT="0"

RDEPEND=">=dev-libs/libqtxdg-1.3.0
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
dev-qt/qtxml:5
kde-frameworks/kwindowsystem:5[X]
"
DEPEND="${RDEPEND}
dev-qt/linguist-tools:5
"

pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
tc-is-gcc && [[ $(gcc-version) < 4.8 ]] && \
die 'The active compiler needs to be gcc 4.8 (or newer)'
fi
}

src_configure() {
local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
cmake-utils_src_configure
}

0 comments on commit 01bbeb4

Please sign in to comment.