Skip to content

Commit

Permalink
dev-python/sunpy: version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
sfabbro committed Jul 19, 2017
1 parent 072da0c commit 0df0623
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/sunpy/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST sunpy-0.7.8.tar.gz 5666138 SHA256 abb3238b4cfcc67bcb0e81733463e4abb672fc6e8c85684320d4ce552e587916 SHA512 46b493a823018b8500994cdfed8f8ae736ed471251a3b62d615821f8a9ea4228d2c78d7a9f66274fc49d0a386ad4d3d446547b8c06888157e5633fac844e8638 WHIRLPOOL 3939b14eb8452284cb435ace15d666962c801929c36c58748fed612b32cc9f2a7d172dfef588775bda3d21362c0a75be144490dbf89b90b6fe9e714de23d4c42
DIST sunpy-0.7.9.tar.gz 5690849 SHA256 359961f62a32df69b2df2cd5390040fa27b7522066fb546469fc9f485d2d0a57 SHA512 e8322ecf7c797a377fd8ff6962d6d66e147ba893a58e8abbbfa1dad6a391eecc161846a51fba3c92e90a3709125d759da76d444ca3f4ff0878768d23da1f41a3 WHIRLPOOL 512e1f5fbc0c4e127c4fc26fcd3f7f2c7ce0944ca5691fcdb938254615e131d14407f4bb160a32b597ad62a520c59201afee2ae6a133021a7c0d7d4cf9298ab9
51 changes: 51 additions & 0 deletions dev-python/sunpy/sunpy-0.7.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5,6} )

inherit distutils-r1 xdg-utils

DESCRIPTION="Software library for solar physics based on Python"
HOMEPAGE="http://sunpy.org/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="jpeg2k test"

RDEPEND="
<dev-python/astropy-2[${PYTHON_USEDEP}]
dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/sqlalchemy[${PYTHON_USEDEP}]
dev-python/suds[${PYTHON_USEDEP}]
sci-libs/scipy[${PYTHON_USEDEP}]
sci-libs/scikits_image[${PYTHON_USEDEP}]
jpeg2k? ( dev-python/glymur[${PYTHON_USEDEP}] )
"
DEPEND="${RDEPEND}
dev-python/astropy-helpers[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-mpl[${PYTHON_USEDEP}]
)
"

python_prepare_all() {
# use system astropy-helpers instead of bundled one
sed -i -e '/auto_use/s/True/False/' setup.cfg || die
distutils-r1_python_prepare_all
}

python_test() {
"${PYTHON}" -m pytest sunpy -k "not figure and not online" || die
}

0 comments on commit 0df0623

Please sign in to comment.