Skip to content

Commit

Permalink
mate-base/mate-session-manager: Version bump to 1.18.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
mudler committed Jun 4, 2017
1 parent 06d5b19 commit 0fb2e69
Show file tree
Hide file tree
Showing 2 changed files with 86 additions and 0 deletions.
1 change: 1 addition & 0 deletions mate-base/mate-session-manager/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST mate-session-manager-1.12.2.tar.xz 538832 SHA256 bd4221e654a425f7cf05a8b5073dfa10b2f4f99b6e9c2f0b331e0f82142edf93 SHA512 4b4a3ecb0f7cbb25e17db8c5833f789858c94fb236ed60b9e98f59cffa320ec32c2b1960fdcbb9c2c9f476ed76cb1f37c3e07746c7c90e08a0dbcc62aac9793e WHIRLPOOL c7ed6044f99b639716e84135674d4c7e4b001d1284c07f2f0fda6c70e6e2aa420574020fc6f1a53d96b420d7e5ba98c82ca6aeab2168e9494c78729ab1fcbf98
DIST mate-session-manager-1.14.1.tar.xz 574804 SHA256 26bb04472e19d637db6e9653235d5343dd7b6f2a128a4d2b19366a8bd01d4502 SHA512 993f314c887bca8d8e0b9450f0e62686e133ea16ee2b6675ff69766564d47a4e7d48581867e8d5e8395ee2e3b1735b121f16cb1be22c7da29015a58f98edd638 WHIRLPOOL 309f42c3d7b40f6074e5704783eaa83880fe2578d24b1784be992d5418149d1dfaa5f56c347557450e8281f48f990d21d624afe5493d14cba4493cb0b4c951a4
DIST mate-session-manager-1.16.0.tar.xz 574464 SHA256 15a5b986c6ba32bab381ed68d21d50ca14fdbe1e2c28ca990a833f21539b41c6 SHA512 55eeef35c388a1f2ed1ad21002863b09d462f5549fb14edcde530715d52e012ee4ecb09c7757775011159b261db7e02be13dccad710fdcd66455383b84a26b86 WHIRLPOOL 6cef60b4d9816361f51a73dd7048c493d440322df8c4c82f33fcb10c4b73e439aabb0178876cb25dcdc69c0c012dc7d1120e4409843ab45314e61dc0b012ef3b
DIST mate-session-manager-1.18.0.tar.xz 578256 SHA256 1c50f7866d8c75c1a918754960c6629798d6cb0f8d06aa3e48516ea672c7d419 SHA512 0b1299eed5a745112a9976a85965847fc7a579e161236f4d661cf08a1292037aa8246bd3e3efcf3d0c6ea8b005e9dfc33cec797c8dc48615f7bc88ce5d351ba8 WHIRLPOOL d94e9a2d46aefe017ba38987a61721b71b6465b002feb713694146f75dea75798ada81ffc7c1b79e8d76c7badf12b9180292eefcaa0bc97ef7d6a8ba39c71f3e
85 changes: 85 additions & 0 deletions mate-base/mate-session-manager/mate-session-manager-1.18.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,85 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit mate

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~x86"
fi

DESCRIPTION="MATE session manager"
HOMEPAGE="http://mate-desktop.org/"

LICENSE="GPL-2 LGPL-2 FDL-1.1"
SLOT="0"

IUSE="debug elibc_FreeBSD gnome-keyring ipv6 systemd xtrans"

# x11-misc/xdg-user-dirs{,-gtk} are needed to create the various XDG_*_DIRs, and
# create .config/user-dirs.dirs which is read by glib to get G_USER_DIRECTORY_*
# xdg-user-dirs-update is run during login (see 10-user-dirs-update-gnome below).

COMMON_DEPEND=">=dev-libs/dbus-glib-0.76
>=dev-libs/glib-2.36:2
dev-libs/libxslt
sys-apps/dbus
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-3.14:3
x11-libs/libICE
x11-libs/libSM
x11-libs/libX11
x11-libs/libXau
x11-libs/libXext
x11-libs/libXrender
x11-libs/libXtst
x11-libs/pango
virtual/libintl
elibc_FreeBSD? ( dev-libs/libexecinfo )
systemd? ( sys-apps/systemd )
!systemd? ( >=sys-auth/consolekit-0.9.2 )
xtrans? ( x11-libs/xtrans )"

RDEPEND="${COMMON_DEPEND}
x11-apps/xdpyinfo
x11-misc/xdg-user-dirs
x11-misc/xdg-user-dirs-gtk
gnome-keyring? ( gnome-base/gnome-keyring )"

DEPEND="${COMMON_DEPEND}
>=dev-util/intltool-0.40:*
>=dev-lang/perl-5
>=sys-devel/gettext-0.10.40:*
virtual/pkgconfig:*
!<gnome-base/gdm-2.20.4"

MATE_FORCE_AUTORECONF=true

src_configure() {
mate_src_configure \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
$(use_with systemd) \
$(use_with xtrans) \
$(use_enable debug) \
$(use_enable ipv6)
}

src_install() {
mate_src_install

dodir /etc/X11/Sessions/
exeinto /etc/X11/Sessions/
doexe "${FILESDIR}"/MATE

dodir /usr/share/mate/applications/
insinto /usr/share/mate/applications/
doins "${FILESDIR}"/defaults.list

dodir /etc/X11/xinit/xinitrc.d/
exeinto /etc/X11/xinit/xinitrc.d/
doexe "${FILESDIR}"/15-xdg-data-mate

# This should be done in MATE too, see Gentoo bug #270852
doexe "${FILESDIR}"/10-user-dirs-update-mate
}

0 comments on commit 0fb2e69

Please sign in to comment.