forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Showing
2 changed files
with
38 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST oauthlib-0.7.2.tar.gz 106079 SHA256 a051f04ee8ec3305055ab34d87b36c9a449375e07c7d6a05bcafa48329cac7c3 SHA512 11bcd1b0930342017c63c305029efa3cc44afb4ce786c0d0afdecc22928a9ada1356899a58e6e7332e08d1a62c3ce83889f6396234534143781635983185b974 WHIRLPOOL 55cd2df10e40e4b05518b2b830418ea8718b584348eda031a8b0281dcddf93ab5afde88a7a583bb3a0f9fd4a59272e61ff68418bb9aee469e203f0f79a01836c | ||
DIST oauthlib-1.0.1.tar.gz 108125 SHA256 2f1999a7c11f8714a1545de033b0950da77f651ff64f271d7dd9df15dc72049b SHA512 4592ba6a146df55451f65ceab9dd049ddaba20bb0364c4cff882450b701052afc88541e6bf2a112ee18499a9c80e3b1b5e1292899ff7c861e0042c5f96b75653 WHIRLPOOL da8dad0ece0c1f9fbe486c0c23943068612b603e708fdc3c601f19203e2301c308972a50db335804bc1797f645e6355996b7cf484490a4d187d89d337b5f45ed | ||
DIST oauthlib-1.0.3.tar.gz 109095 SHA256 ef4bfe4663ca3b97a995860c0173b967ebd98033d02f38c9e1b2cbb6c191d9ad SHA512 b5df82729edc025f262a18c012f6036f52e97a8a846eeb75e4e205928acfd6e971a58194c4a06853d6743329d397e69b94fb431047b2a17a2cb2472c889c4d4c WHIRLPOOL f63142b667eaed207504494e67de8b58d8c966c19870a2e38714fa6d264a7f57873bb30f3548f9cd0906d9f3abb5c36c9de7255d869f47ebad7662b1dba6ec16 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,37 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
PYTHON_COMPAT=( python{2_7,3_{3,4,5}} ) | ||
|
||
inherit distutils-r1 | ||
|
||
DESCRIPTION="Spec-compliant and thorough implementation of the OAuth request-signing logic" | ||
HOMEPAGE="https://github.com/idan/oauthlib https://pypi.python.org/pypi/oauthlib" | ||
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz" | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86" | ||
IUSE="test" | ||
|
||
# optional extras hard set as RDEPs. See setup.py | ||
RDEPEND=" | ||
dev-python/pycrypto[${PYTHON_USEDEP}] | ||
>=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}] | ||
dev-python/blinker[${PYTHON_USEDEP}] | ||
dev-python/cryptography[${PYTHON_USEDEP}] | ||
" | ||
DEPEND=" | ||
dev-python/setuptools[${PYTHON_USEDEP}] | ||
test? ( ${RDEPEND} | ||
dev-python/nose[${PYTHON_USEDEP}] | ||
$(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7) | ||
$(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' python2_7) ) | ||
" | ||
|
||
python_test() { | ||
nosetests || die "tests failed under ${EPYTHON}" | ||
} |