Skip to content

Commit

Permalink
dev-python/testresources: Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
patricklauer committed Mar 2, 2016
1 parent f5abf5f commit 524a5df
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/testresources/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST testresources-0.2.7.tar.gz 32050 SHA256 ad0a117383dd463827b199eaa92829b4d6a3147fbd97459820df53bae81d7231 SHA512 29518f7326272c56a5f2f3f1f7741959dde9265ba5ce7e0c7d7afabd91bd44a519d1cad82a11a41944ff12d65e541536476f87afcac9a7cbb4869743a38547b7 WHIRLPOOL c414223960fbd6a1c612d2c79c8b8956ab858aaaa76331ddefb1315dbdd6c6bc1d3a7641c098d7d558b332ee8f4262d8921240adb63f581a3127da6a617dc200
DIST testresources-1.0.0.tar.gz 44501 SHA256 e9b2c70ecade3135629e66945a7ac19c6df18c59b3d8f02e95d24bc8e066c7cf SHA512 7c9f9cbcc62066ab4a75d68780d88925484eeee23e2e0ef0395b63ec2a92968a6969d1bd6f483945e32ff5566e686b426f2f37daf4f803d2ef779032ea97cc6b WHIRLPOOL f4a390df289f4e452e197b58cc6df2a162a5843d64ba03fc3a6918c1f0b6124ee9c98e3e08bbb4c8780344749a7e961a4482a005e7b2e23359ecc56f6cef8192
38 changes: 38 additions & 0 deletions dev-python/testresources/testresources-1.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )

inherit distutils-r1

DESCRIPTION="A pyunit extension for managing expensive test resources"
HOMEPAGE="https://launchpad.net/testresources"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="test"

DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/testtools[${PYTHON_USEDEP}]
dev-python/fixtures[${PYTHON_USEDEP}]
)"
RDEPEND=""

python_prepare_all() {
sed \
-e 's:testBasicSortTests:_&:g' \
-i testresources/tests/test_optimising_test_suite.py || die
distutils-r1_python_prepare_all
}

python_test() {
nosetests --verbose || die "Tests failed under ${EPYTHON}"
}

0 comments on commit 524a5df

Please sign in to comment.