forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-perl/Module-Implementation: Bump to version 0.90.0
- use EAPI6 - cleanup deps and tests Package-Manager: portage-2.2.27
- Loading branch information
1 parent
c91014d
commit 1a8c03b
Showing
2 changed files
with
37 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST Module-Implementation-0.06.tar.gz 10514 SHA256 da3b78025ab82b04c042e7cc1fdefc3af225ca90865c215d4d8bcf3bbf54186d SHA512 329854912a6a2deba00f3dd3773f164b588892f90904cabc3426230c1377cce730792e4673c0f292fa3969747b5a21f9a295ea88caa502487f352747941feb6b WHIRLPOOL d5b74761f32e240e54ccbbd0cad00f176c4e22372959ac0fe2263cf2a95d661d8c4996281d3b85261e9f25f17f7e18ba01f62b9b983ca80cfe238ce9a6ccfa29 | ||
DIST Module-Implementation-0.09.tar.gz 18553 SHA256 c15f1a12f0c2130c9efff3c2e1afe5887b08ccd033bd132186d1e7d5087fd66d SHA512 049f967ba1bd8a3914968b34006030ae318d99ac629a0f34736f1c2b5392490c30aa0914e777eaefda7f0f58755d2d3363a266b90db59b53fe145ef68e1d953c WHIRLPOOL 3004b14e8016c56f999fd8ec7c092e111fc21ac2ccd8d6bf72d16255e7e84a758bad4a4aedebeb98e9ebe813441da550764a19913a7d7be2edbc46db8fee1a52 |
36 changes: 36 additions & 0 deletions
36
dev-perl/Module-Implementation/Module-Implementation-0.90.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,36 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
DIST_AUTHOR=DROLSKY | ||
DIST_VERSION=0.09 | ||
inherit perl-module | ||
|
||
DESCRIPTION="Loads one of several alternate underlying implementations for a module" | ||
|
||
LICENSE="Artistic-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris" | ||
IUSE="test" | ||
|
||
RDEPEND=" | ||
virtual/perl-Carp | ||
>=dev-perl/Module-Runtime-0.12.0 | ||
dev-perl/Try-Tiny | ||
" | ||
DEPEND="${RDEPEND} | ||
virtual/perl-ExtUtils-MakeMaker | ||
test? ( | ||
virtual/perl-File-Spec | ||
virtual/perl-IO | ||
dev-perl/Test-Requires | ||
>=dev-perl/Test-Fatal-0.6.0 | ||
>=virtual/perl-Test-Simple-0.880.0 | ||
) | ||
" | ||
src_test() { | ||
perl_rm_files "t/release-"* "t/author-"* | ||
perl-module_src_test | ||
} |