Skip to content

Commit

Permalink
mate-extra/mate-system-monitor: add 1.26.0
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/809062
Signed-off-by: Oz N Tiram <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
oz123 authored and thesamesam committed Oct 4, 2022
1 parent 85b86dc commit 1e6f94b
Show file tree
Hide file tree
Showing 3 changed files with 72 additions and 1 deletion.
1 change: 1 addition & 0 deletions mate-extra/mate-system-monitor/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mate-system-monitor-1.24.2.tar.xz 2429196 BLAKE2B 03d0555d74ba4ba9a80727fa383ad02515a46f61fd1df3487b7acabef4b0561e03d86082c9c161a533716416bab73fad5bd826329c69d1826eeb7dd73a1b4e41 SHA512 4fd0f1a3dc5611d66b2e1ca35171f2056994332f87d895321c384a696afa359a2b78d2b0c2d698923039549f886976f04b1a8c92c928dfe9e2a1a159540a1895
DIST mate-system-monitor-1.26.0.tar.xz 2472116 BLAKE2B e9613206444ab59d3612168e72dedee70f7d39f531075609fd2d8a0d9c94a7150e0862fd635393739f78e3fb3384e5febeda5a64f4d7dc13ba3e2e2909169dbf SHA512 90919af4808348f6d6a66a4dddb02f2b9d2dc2ee42100b28baa104a504b0b0a6d488814381a657d682b3f53e0a5cdf99fc0a6142eab86d77ca1d5147da526c58
66 changes: 66 additions & 0 deletions mate-extra/mate-system-monitor/mate-system-monitor-1.26.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit mate toolchain-funcs

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
fi

DESCRIPTION="The MATE System Monitor"

LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
SLOT="0"
IUSE="elogind systemd wnck"

REQUIRED_USE="?? ( elogind systemd )"

COMMON_DEPEND="
>=dev-cpp/glibmm-2.26:2
>=dev-cpp/gtkmm-3.8:3.0
>=dev-libs/glib-2.56:2
dev-libs/libsigc++:2
>=dev-libs/libxml2-2:2
>=gnome-base/libgtop-2.37.2:2=
>=gnome-base/librsvg-2.35:2
x11-libs/cairo
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-3.22:3
>=x11-libs/libwnck-3.0:3
elogind? ( sys-auth/elogind )
systemd? ( sys-apps/systemd )
"

RDEPEND="${COMMON_DEPEND}
>=sys-auth/polkit-0.97:0
virtual/libintl
"

DEPEND="${COMMON_DEPEND}
app-text/yelp-tools
>=sys-devel/gettext-0.19.8
>=sys-devel/autoconf-2.63:*
virtual/pkgconfig
"

src_configure() {
local myconf=()

if use elogind || use systemd; then
myconf+=( --enable-systemd )
if use elogind; then
local pkgconfig="$(tc-getPKG_CONFIG)"
myconf+=(
SYSTEMD_CFLAGS="$(${pkgconfig} --cflags 'libelogind')"
SYSTEMD_LIBS="$(${pkgconfig} --libs 'libelogind')"
)
fi
else
myconf+=( --disable-systemd )
fi

mate_src_configure "${myconf[@]}" \
$(use_enable wnck)
}
6 changes: 5 additions & 1 deletion mate-extra/mate-system-monitor/metadata.xml
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
Expand All @@ -8,4 +8,8 @@
<upstream>
<remote-id type="github">mate-desktop/mate-system-monitor</remote-id>
</upstream>
<use>
<flag name="wnck">Enable experimental support
using <pkg>x11-libs/libwnck</pkg>.</flag>
</use>
</pkgmetadata>

0 comments on commit 1e6f94b

Please sign in to comment.