Skip to content

Commit

Permalink
sys-fs/aufs4: Bump to latest aufs release
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Nov 2, 2015
1 parent 27f2b8d commit 2b8e174
Show file tree
Hide file tree
Showing 2 changed files with 165 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-fs/aufs4/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -8,3 +8,4 @@ DIST aufs4-standalone-0_pre20150622.tar.xz 543932 SHA256 28de7f6968c62a48b78f4b6
DIST aufs4-standalone-0_pre20150629.tar.xz 547808 SHA256 7c1d9a815c73e8cb1c9f909eee8f6945486c8e8feeea9cae4b3865b6032f17e5 SHA512 b7c734fb83515790b58a81b904acb286ef52124e0799dad1c7900dc8af3e0dc6f2875ba86805f1f39b8d04ce6660bf0c0307e4bbc1b58f2ca6171ead5e668a94 WHIRLPOOL b39f2cdeffd20b636c4a3aa5ec8e87cd6b1c8bdfdab071d1cabf53e10629beebffc919abf5fc90915ec0c14f4b4c45a510bbd303765564348a0e2d1688ddf79b
DIST aufs4-standalone-0_pre20150928.tar.xz 649700 SHA256 614a7d36577d9c432deba647ae925a05f05468fcf9af54c84c553ee9f4b4ccb8 SHA512 69182e8ef0cd8bb251bd579e18aea1fdc5b38d16f9bd8a7dd23eaf84ae86bb24dd011871f90a0d0c1434a6136b9dcc70ed07b6f8301344d13083cd6a755c75ba WHIRLPOOL b43eb05904917f74ea38bd148543552dc1d40eb590cf5059a884dcba909e76943cb9e2d1b873300701ffbc6061beeb3efb76f8014e08a8742c48c38cd6c5fe53
DIST aufs4-standalone-0_pre20151012.tar.xz 651492 SHA256 3cb564a71a4d4fe4f16c9412b5c714645739beea9471db421d76f1af2af86d83 SHA512 abf1833a4902dc95cce203607cd715b6794b13e064c073139bc06facfd86ceb817d00d7bed0f5420d8f8f7c9205524a8ffc9431dc1c0d2da1e73393b7d89d33d WHIRLPOOL a8cb9e8fc4449dbc54e1bfab1c9acb61e7dc31c33c62d8a2e2feb407bc6d4a2ceb502fd85ac7519af1e9b028603525ee26763438e04736fee138420796c13e90
DIST aufs4-standalone-0_pre20151102.tar.xz 677588 SHA256 5e0aa085e42dacc45991e49e485bf4f20cb911c71c8d5363ef2986733cb3d9ef SHA512 b4973078f31c50bb58afeb4fc5216a34d31b1dd4de60a5dd172962935becad60820146e22e39e88fc16a4c7a74e21923f02a77d6b0d8cd8aeef946806ed97932 WHIRLPOOL e04651079f1f04a74c330786ff3bbe72c367657ad8d0351ce251a4287ddee65231df410436f86474e6418b3e848eaa370f930376a2a1ad9fe57280b4d75be4cb
164 changes: 164 additions & 0 deletions sys-fs/aufs4/aufs4-0_pre20151102.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,164 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils flag-o-matic linux-info linux-mod multilib readme.gentoo toolchain-funcs

AUFS_VERSION="${PV%%_p*}"
# highest branch version
PATCH_MAX_VER=2
# highest supported version
KERN_MAX_VER=3
# lowest supported version
KERN_MIN_VER=0

DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
HOMEPAGE="http://aufs.sourceforge.net/"
SRC_URI="https://dev.gentoo.org/~jlec/distfiles/aufs4-standalone-${PV}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug doc fuse hfs inotify kernel-patch nfs pax_kernel ramfs"

DEPEND="
dev-util/patchutils
dev-vcs/git"
RDEPEND="
sys-fs/aufs-util
!sys-fs/aufs
!sys-fs/aufs2
!sys-fs/aufs3"

S="${WORKDIR}"/${PN}-standalone

MODULE_NAMES="aufs(misc:${S})"

pkg_setup() {
CONFIG_CHECK+=" !AUFS_FS"
use inotify && CONFIG_CHECK+=" ~FSNOTIFY"
use nfs && CONFIG_CHECK+=" EXPORTFS"
use fuse && CONFIG_CHECK+=" ~FUSE_FS"
use hfs && CONFIG_CHECK+=" ~HFSPLUS_FS"
use pax_kernel && CONFIG_CHECK+=" PAX" && ERROR_PAX="Please use hardened sources"

# this is needed so merging a binpkg ${PN} is possible w/out a kernel unpacked on the system
[ -n "$PKG_SETUP_HAS_BEEN_RAN" ] && return

get_version
kernel_is lt 4 ${KERN_MIN_VER} 0 && die "the kernel version isn't supported by upstream anymore. Please upgrade."
kernel_is gt 4 ${KERN_MAX_VER} 99 && die "kernel too new"

linux-mod_pkg_setup

if [[ "${KV_MINOR}" -gt "${PATCH_MAX_VER}" ]]; then
PATCH_BRANCH="x-rcN"
else
PATCH_BRANCH="${KV_MINOR}"
fi

case ${KV_EXTRA} in
"")
elog "It seems you are using vanilla-sources with aufs4"
elog "Please use sys-kernel/aufs-sources with USE=vanilla"
elog "This will save you the nasty reemerge of sys-fs/aufs4 on every kernel upgrade"
;;
"-gentoo")
elog "It seems you are using gentoo-sources with aufs4"
elog "Please use sys-kernel/aufs-sources"
elog "This will save you the nasty reemerge of sys-fs/aufs4 on every kernel upgrade"
;;
esac

pushd "${T}" &> /dev/null
unpack ${A}
cd ${PN}-standalone || die
local module_branch=origin/${PN}.${PATCH_BRANCH}
einfo "Using ${module_branch} as patch source"
git checkout -q -b local-${PN}.${PATCH_BRANCH} ${module_branch} || die
combinediff ${PN}-base.patch ${PN}-standalone.patch > "${T}"/combined-1.patch
combinediff "${T}"/combined-1.patch ${PN}-mmap.patch > ${PN}-standalone-base-mmap-combined.patch
if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < ${PN}-standalone-base-mmap-combined.patch > /dev/null ); then
if use kernel-patch; then
cd ${KV_DIR}
ewarn "Patching your kernel..."
patch --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} < "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch >/dev/null
epatch "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
ewarn "You need to compile your kernel with the applied patch"
ewarn "to be able to load and use the aufs kernel module"
else
eerror "You need to apply a patch to your kernel to compile and run the ${PN} module"
eerror "Either enable the kernel-patch useflag to do it with this ebuild"
eerror "or apply "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch by hand"
die "missing kernel patch, please apply it first"
fi
fi
popd &> /dev/null
export PKG_SETUP_HAS_BEEN_RAN=1
}

set_config() {
for option in $*; do
grep -q "^CONFIG_AUFS_${option} =" config.mk || die "${option} is not a valid config option"
sed "/^CONFIG_AUFS_${option}/s:=:= y:g" -i config.mk || die
done
}

src_prepare() {
local module_branch=origin/${PN}.${PATCH_BRANCH}

einfo "Using for module creation branch ${module_branch}"
git checkout -q -b local-gentoo ${module_branch} || die

# All config options to off
sed "s:= y:=:g" -i config.mk || die

set_config RDU BRANCH_MAX_127 SBILIST

use debug && set_config DEBUG
use fuse && set_config BR_FUSE POLL
use hfs && set_config BR_HFSPLUS
use inotify && set_config HNOTIFY HFSNOTIFY
use nfs && set_config EXPORT
use nfs && ( use amd64 || use ppc64 ) && set_config INO_T_64
use ramfs && set_config BR_RAMFS

if use pax_kernel; then
epatch "${FILESDIR}"/pax-4.patch
fi

sed -i "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" Makefile || die
}

src_compile() {
local ARCH=x86

emake \
CC=$(tc-getCC) \
LD=$(tc-getLD) \
LDFLAGS="$(raw-ldflags)" \
ARCH=$(tc-arch-kernel) \
CONFIG_AUFS_FS=m \
KDIR="${KV_OUT_DIR}"
}

src_install() {
linux-mod_src_install

insinto /usr/share/doc/${PF}

use doc && doins -r Documentation

use kernel-patch || doins "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch

dodoc Documentation/filesystems/aufs/README "${T}"/${PN}-standalone/{aufs4-loopback,vfs-ino,tmpfs-idr}.patch

readme.gentoo_create_doc
}

pkg_postinst() {
readme.gentoo_pkg_postinst
linux-mod_pkg_postinst
}

0 comments on commit 2b8e174

Please sign in to comment.