Skip to content

Commit

Permalink
dev-cpp/edencommon: add 2022.08.15.00 (switch to tags)
Browse files Browse the repository at this point in the history
Upstream have enabled tagging (yay!) so let's flip
to that.

Bug: facebookexperimental/edencommon#2
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Aug 15, 2022
1 parent 900accb commit 3014ee3
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/edencommon/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST edencommon-0_pre20220808.tar.gz 142458 BLAKE2B 0dd501069bc511973e89b21b9dbdce7eeb0e87e31ecd05e585fe83c515894691a02e5725de8c912c4bd0fb70f4172445070ef8fec205243e1df9c35a3ccaffe4 SHA512 63f60e1c406d834cf618e2747c21f928e43fe2a475a97152070aecb61b11b5e515bdfd1c9571a93a159d91fa185c9f89caebe8d41421a94e636e8ff43fd11a3a
DIST edencommon-0_pre20220815.tar.gz 142456 BLAKE2B 64e2b8e155e56ff50ca348ae53f3e55e123b32816ec199cebf760dcd4b08da920b15b56aab1254a782d202b89e1d119a8180f7d5382da8a94f67752ecb6924db SHA512 7263fb3f85c6142862eac9472c2de2ac94a2b3c5205e0d87ca2f6694d4ed3c5b9f2643c35266141e6bbbb1d45079a59cf5803de3065ef46a9a8d7f321b15bc99
DIST edencommon-2022.08.15.00.gh.tar.gz 142467 BLAKE2B e3d72f1ae5845db2c18003202ca6360cc9496c3544eff2cad8eee486098dae3649bc54a0b7b9ea57fb72a1669a1f4307a017a85693499ca353f553f0de79dc6b SHA512 211a6f0e22b662e743cc944b7bc3d9ad63c1e4dd55b515db958fdfc04463357caef39ad43a9089417ac61929a8f32375f2fd673a113c04a162e94f6419737e81
41 changes: 41 additions & 0 deletions dev-cpp/edencommon/edencommon-2022.08.15.00.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

# These must be bumped together:
# dev-cpp/edencommon
# dev-cpp/folly
# dev-util/watchman

inherit cmake

DESCRIPTION="Shared library for Watchman and Eden projects"
HOMEPAGE="https://github.com/facebookexperimental/edencommon"
SRC_URI="https://github.com/facebookexperimental/edencommon/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"

LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE="llvm-libunwind"

RDEPEND="
dev-cpp/gflags:=
dev-cpp/glog:=[gflags]
dev-cpp/folly:=
llvm-libunwind? ( sys-libs/llvm-libunwind:= )
!llvm-libunwind? ( sys-libs/libunwind:= )
"
DEPEND="
${RDEPEND}
dev-cpp/gtest
"

src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_DIR="$(get_libdir)/cmake/${PN}"
-DLIB_INSTALL_DIR="$(get_libdir)"
)

cmake_src_configure
}

0 comments on commit 3014ee3

Please sign in to comment.