forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
57 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,56 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
PYTHON_COMPAT=( python3_{6..9} ) | ||
DISTUTILS_USE_SETUPTOOLS=bdepend | ||
inherit distutils-r1 | ||
|
||
DESCRIPTION="The AWS SDK for Python" | ||
HOMEPAGE="https://github.com/boto/boto3" | ||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
|
||
if [[ "${PV}" == "9999" ]]; then | ||
EGIT_REPO_URI="https://github.com/boto/boto3" | ||
inherit git-r3 | ||
BOTOCORE_PV=${PV} | ||
else | ||
SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux" | ||
|
||
# botocore is x.(y+3).z | ||
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)" | ||
fi | ||
|
||
RDEPEND=" | ||
>=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}] | ||
>=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}] | ||
>=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}] | ||
" | ||
BDEPEND=" | ||
test? ( | ||
dev-python/mock[${PYTHON_USEDEP}] | ||
) | ||
" | ||
|
||
distutils_enable_sphinx docs/source \ | ||
'dev-python/guzzle_sphinx_theme' | ||
distutils_enable_tests nose | ||
|
||
python_prepare_all() { | ||
# don't lock versions to narrow ranges | ||
sed -e '/botocore/ d' \ | ||
-e '/jmespath/ d' \ | ||
-e '/s3transfer/ d' \ | ||
-i setup.py || die | ||
|
||
# prevent an infinite loop | ||
rm tests/functional/docs/test_smoke.py || die | ||
|
||
distutils-r1_python_prepare_all | ||
} | ||
|
||
python_test() { | ||
nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}" | ||
} |