Skip to content

Commit

Permalink
dev-python/async_timeout: Bump to 4.0.2
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Dec 20, 2021
1 parent c6d2f99 commit 4df1b49
Show file tree
Hide file tree
Showing 2 changed files with 37 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/async_timeout/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST async-timeout-3.0.1.tar.gz 9724 BLAKE2B f18ae75969b7048469fe22949f25ea25da3fdbf08b98a16b5d5ffe823060a75e6de9ed764727e08d4344c79426e9c89013d49522f20ed62e6fbe912b5c7a8787 SHA512 fd30842671a79edfd52c7350e7fb2120533a6d97b44975f7b071ce2cbde43443bd5bbe1f2ad0ad3ab2156e1987b9e58e0c149b0ecfea8674eb0cb78eee79c986
DIST async-timeout-4.0.1.tar.gz 8030 BLAKE2B 73bb3f38d33608d120a0d633231bc781b9b5530d80a08c98370ab9100486bda5fd9d7a68ae6b16315bf306a75690897d724fa5db318847803bc445074908e650 SHA512 24a72daf9e0737d0be351a35ff28242dea735bed33f06d9865a71983b1341693c80856c0668d6a485bccc8cf7b9adde33fa904e94bf4730e4a678216e572d119
DIST async-timeout-4.0.2.tar.gz 8221 BLAKE2B ebcb2ef956590e265bbdecc223a877e7260750aecf5b631c6af1f335ce57b51579467901e2344bfa8495010eb1e6e7a39adfd4b6311483d63e0674221888d1f7 SHA512 e9884a525b99bc1a3a15c958a1dbb25a92cb286bb7360b03b0be3198e61685970628c8fef6dc478beba3f031e0ff6f03b1fcc3c2c34032d7fea6f8b65850ac38
36 changes: 36 additions & 0 deletions dev-python/async_timeout/async_timeout-4.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1

MY_P=${PN/_/-}-${PV}
DESCRIPTION="Timeout context manager for asyncio programs"
HOMEPAGE="https://github.com/aio-libs/async-timeout"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
S=${WORKDIR}/${MY_P}

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"

BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
)"

distutils_enable_tests pytest

python_prepare_all() {
# remove pointless dep on pytest-cov
sed -i -e '/addopts/d' setup.cfg || die
distutils-r1_python_prepare_all
}

python_test() {
epytest -p no:aiohttp
}

0 comments on commit 4df1b49

Please sign in to comment.