Skip to content

Commit

Permalink
mate-extra/mate-screensaver: bump to 1.22.1, fix deps and configure
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Göktürk Yüksek <[email protected]>
  • Loading branch information
NP-Hardass authored and gktrk committed May 12, 2019
1 parent 03e87b6 commit 5493535
Show file tree
Hide file tree
Showing 2 changed files with 120 additions and 0 deletions.
1 change: 1 addition & 0 deletions mate-extra/mate-screensaver/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mate-screensaver-1.22.0.tar.xz 4959732 BLAKE2B 23d7622ea992c8a29966a12a4e8db36fb489d0d07124907cb3fc2325dedb7fb99394bc551b0d889247989bbea27ba540fb17f55dbd12644e10a9abc242b07d8a SHA512 e253495ad700264ee7833d7b5a732cabff53058384801ff5e874d45f812cea1e4bd3877a1688ecec6197c37f32761f69a4924a47a6556332f1fec736e540e333
DIST mate-screensaver-1.22.1.tar.xz 4942928 BLAKE2B e82b6482ed9ec655bb8bea2795b0e2559cbdfcb2be5f27a2264486a2013b8234cb02292b6ca547f8812e6dc0c74646f51af8a2f8d7baf2f28bf1b688508350d5 SHA512 7ffb94d88095ff5580862fe9c958a2e4af7a424d40dc5e0f3c1da49a258035179573721fc7052710624916678e953a6347a898b53ff872a49e022987b8c02904
119 changes: 119 additions & 0 deletions mate-extra/mate-screensaver/mate-screensaver-1.22.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,119 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit mate readme.gentoo-r1

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi

DESCRIPTION="Replaces xscreensaver, integrating with the MATE desktop"

LICENSE="GPL-2"
SLOT="0"
IUSE="X debug consolekit elogind kernel_linux libnotify opengl pam systemd"
REQUIRED_USE="?? ( elogind systemd )"

DOC_CONTENTS="
Information for converting screensavers is located in
/usr/share/doc/${PF}/xss-conversion.txt*
"

COMMON_DEPEND="
>=dev-libs/dbus-glib-0.71:0
>=dev-libs/glib-2.50:2
gnome-base/dconf
>=mate-base/libmatekbd-1.17.0
>=mate-base/mate-desktop-1.17.0
>=mate-base/mate-menus-1.21.0
>=sys-apps/dbus-0.30
>=x11-libs/gdk-pixbuf-2.14:2
>=x11-libs/libX11-1
x11-libs/cairo
>=x11-libs/gtk+-3.22:3
x11-libs/libXext
x11-libs/libXrandr
x11-libs/libXScrnSaver
x11-libs/libXxf86misc
x11-libs/libXxf86vm
x11-libs/libxklavier
x11-libs/pango
virtual/libintl
consolekit? ( sys-auth/consolekit )
libnotify? ( >=x11-libs/libnotify-0.7:0 )
opengl? ( virtual/opengl )
pam? ( gnome-base/gnome-keyring virtual/pam )
!pam? ( kernel_linux? ( sys-apps/shadow ) )
elogind? ( sys-auth/elogind )
systemd? ( sys-apps/systemd:= )
!!<gnome-extra/gnome-screensaver-3"

RDEPEND="${COMMON_DEPEND}
>=mate-base/mate-session-manager-1.6"

DEPEND="${COMMON_DEPEND}
>=dev-util/intltool-0.50.1
sys-devel/gettext:*
x11-base/xorg-proto
virtual/pkgconfig:*"

src_configure() {
local myconf=(
--enable-locking
--with-kbd-layout-indicator
--with-xf86gamma-ext
--with-xscreensaverdir=/usr/share/xscreensaver/config
--with-xscreensaverhackdir=/usr/$(get_libdir)/misc/xscreensaver
$(use_with X x)
$(use_with consolekit console-kit)
$(use_with elogind)
$(use_with libnotify)
$(use_with opengl libgl)
$(use_with systemd)
$(use_enable debug)
$(use_enable pam)
)

mate_src_configure "${myconf[@]}"
}

src_install() {
mate_src_install

# Install the conversion script in the documentation.
dodoc "${S}"/data/migrate-xscreensaver-config.sh
dodoc "${S}"/data/xscreensaver-config.xsl
dodoc "${FILESDIR}"/xss-conversion.txt

# Non PAM users will need this suid to read the password hashes.
# OpenPAM users will probably need this too when
# https://bugzilla.gnome.org/show_bug.cgi?id=370847
# is fixed.
if ! use pam ; then
fperms u+s /usr/libexec/mate-screensaver-dialog
fi

readme.gentoo_create_doc
}

pkg_postinst() {
mate_pkg_postinst

if has_version "<x11-base/xorg-server-1.5.3-r4" ; then
ewarn "You have a too old xorg-server installation. This will cause"
ewarn "mate-screensaver to eat up your CPU. Please consider upgrading."
echo
fi

if has_version "<x11-misc/xscreensaver-4.22-r2" ; then
ewarn "You have xscreensaver installed, you probably want to disable it."
ewarn "To prevent a duplicate screensaver entry in the menu, you need to"
ewarn "build xscreensaver with -gnome in the USE flags."
ewarn "echo \"x11-misc/xscreensaver -gnome\" >> /etc/portage/package.use"
echo
fi

readme.gentoo_print_elog
}

0 comments on commit 5493535

Please sign in to comment.