Skip to content

Commit

Permalink
www-client/opera-developer: Version 69.0.3673.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Apr 28, 2020
1 parent dbfb0ab commit 5b05f8c
Show file tree
Hide file tree
Showing 2 changed files with 116 additions and 0 deletions.
1 change: 1 addition & 0 deletions www-client/opera-developer/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST opera-developer_69.0.3660.0_amd64.deb 66332904 BLAKE2B 9a92545c226de0c0a40e9d04590efeb494d0885bec9c7324a2a7531daad4b7c643b1200f9efee21d8cc6358b1416feda2d7e109bf1f367a59b2a55e81d75c6d2 SHA512 60be272c5bf31940ef9fe928f1530a6fa922b95c510a6f540a99a1c11c6ffaf6ef385c0488cda3821a814517182bbda382e9a8584910c9bcc6360c8613b8333b
DIST opera-developer_69.0.3665.0_amd64.deb 66148548 BLAKE2B 8f8ad5c9b034b573c297fb86beb959a9fe5c2bc8f71383f27796c21a95463c9839c7e32973b9003c8ac210be51072fa2ec227e7262db121759af3fd6c1d49bd1 SHA512 ab7953c09c6e1d13ec12ffe65a4b5b0810b16e08eb00012e8ffdb2b512b6c02baefdb5b8d70f0251ee9cf6680e6dd21e5ea73490b3f7f1e1a8b89738fd5dccf6
DIST opera-developer_69.0.3673.0_amd64.deb 66207648 BLAKE2B fe503663dea992541d6cde133fe65fb8f61cd32fcc48547853a1f6e75df8f3faf5f5891cb042edb979d44f83a3ae149fb725ea30e567f512960ce687cacc40c3 SHA512 1036d76f45aaa0c537bd1bba5a321d5615a52893a0dd166b2614251dd8aac76b6affaa25a4893ea8918b5f5bc413d7ea509135009f9cff752962921955a97972
115 changes: 115 additions & 0 deletions www-client/opera-developer/opera-developer-69.0.3673.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,115 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
CHROMIUM_LANGS="
be bg bn ca cs da de el en-GB es es-419 fi fil fr fr-CA hi hr hu id it
ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
zh-CN zh-TW
"
inherit chromium-2 multilib unpacker xdg-utils

DESCRIPTION="A fast and secure web browser"
HOMEPAGE="https://www.opera.com/"
LICENSE="OPERA-2014"
SLOT="0"
SRC_URI_BASE="
https://download1.operacdn.com/pub/
https://download2.operacdn.com/pub/
https://download3.operacdn.com/pub/
https://download4.operacdn.com/pub/
"
SRC_URI="amd64? ("
for uri in ${SRC_URI_BASE}; do
SRC_URI+="
"${uri}${PN}/${PV}/linux/${PN}_${PV}_amd64.deb"
"
done
SRC_URI+=")"
KEYWORDS="~amd64"

RDEPEND="
dev-libs/expat
dev-libs/glib:2
dev-libs/nspr
dev-libs/nss
gnome-base/gconf:2
media-libs/alsa-lib
media-libs/fontconfig
media-libs/freetype
net-misc/curl
net-print/cups
sys-apps/dbus
x11-libs/cairo
x11-libs/gdk-pixbuf
x11-libs/gtk+:3
x11-libs/libX11
x11-libs/libXScrnSaver
x11-libs/libXcomposite
x11-libs/libXcursor
x11-libs/libXdamage
x11-libs/libXext
x11-libs/libXfixes
x11-libs/libXi
x11-libs/libXrandr
x11-libs/libXrender
x11-libs/libXtst
x11-libs/libnotify
x11-libs/pango[X]
"

QA_PREBUILT="*"
S=${WORKDIR}

src_unpack() {
unpack_deb ${A}
}

pkg_setup() {
OPERA_HOME="usr/$(get_libdir)/${PN}"
}

src_prepare() {
default

case ${ARCH} in
amd64)
mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
rm -r usr/lib || die
;;
x86)
mv usr/lib/i386-linux-gnu/${PN} usr/$(get_libdir)/ || die
;;
esac

mv usr/share/doc/${PN} usr/share/doc/${PF} || die
gunzip usr/share/doc/${PF}/changelog.gz || die

rm usr/bin/${PN} || die

pushd "${OPERA_HOME}/localization" > /dev/null || die
chromium_remove_language_paks
popd > /dev/null || die

sed -i \
-e 's|^TargetEnvironment|X-&|g' \
usr/share/applications/${PN}.desktop || die
}

src_install() {
mv * "${D}" || die
dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
fperms 4711 /usr/$(get_libdir)/${PN}/opera_sandbox
}

pkg_postrm() {
xdg_desktop_database_update
xdg_icon_cache_update
xdg_mimeinfo_database_update
}

pkg_postinst() {
xdg_desktop_database_update
xdg_icon_cache_update
xdg_mimeinfo_database_update
}

0 comments on commit 5b05f8c

Please sign in to comment.