Skip to content

Commit

Permalink
dev-lua/luasystem: add 0.4.0
Browse files Browse the repository at this point in the history
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
ConiKost committed Jun 22, 2024
1 parent 174e334 commit 67601d6
Show file tree
Hide file tree
Showing 2 changed files with 92 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lua/luasystem/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST luasystem-0.2.1_p0.tar.gz 8162 BLAKE2B ad8a6009823ad8202ff3884a3167d0779405c2a6be460b7ef2939622eb4d0fc8edbc6b04aba5dec9dd5e4e38f11ae0dcd582b9c348d5b516aa411858d55c6d71 SHA512 9dc323d4d1914cfa4f278a49ef22e58569d5cd7e369fa17fa6006cd47f9d90c6dfd4404067ea2436aa46a27cfbdf91e4aa26e20b89aeeefdf2aa7252c51fb32b
DIST luasystem-0.3.0.tar.gz 19607 BLAKE2B 82dd54dab61045d25d9d1dc074526c2443b9732adf27da052f65702f0941a04dce65582091b5ecb802e5aed9baa2f4dbd53e4cd1b624426341a83fbcb0109378 SHA512 1adf1167767d7d8233ed2c90c106b050dc2370e891465eeb13f16ebc96e8f467d67a89a40173064112117ac9db2451aa73fde0d11fab01f6d2c56bdef50cb6ac
DIST luasystem-0.4.0.tar.gz 74560 BLAKE2B 3ca3ef54572c3aca7ac465b4e93c0ae14ce33d9e278b504c7d6be209d9d26c3f21d6bb342da8c0ab7b008d366313fec436c6c7a8bd9e3246a3f2bfd6f2213214 SHA512 2b117e20955dac74b850363d88a08ca75e085e8078824b0f0a43deb29aad92e1f6a3687e6b504caf241a5353a59a96555964b3b0d6ff623c5680c005e65b294a
91 changes: 91 additions & 0 deletions dev-lua/luasystem/luasystem-0.4.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,91 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

LUA_COMPAT=( lua5-{1..4} luajit )
MY_PV="${PV/_p/-}"

inherit lua toolchain-funcs

DESCRIPTION="Platform independent system calls for Lua"
HOMEPAGE="https://github.com/lunarmodules/luasystem"
SRC_URI="https://github.com/lunarmodules/${PN}/archive/refs/tags/v${MY_PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${MY_PV}"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
IUSE="test"
REQUIRED_USE="${LUA_REQUIRED_USE}"
RESTRICT="!test? ( test )"

RDEPEND="${LUA_DEPS}"
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
test? (
dev-lua/busted[${LUA_USEDEP}]
dev-lua/lua_cliargs[${LUA_USEDEP}]
${RDEPEND}
)
"

PATCHES=( "${FILESDIR}"/${PN}-0.2.1_p0-fix-makefile.patch )

src_prepare() {
default

lua_copy_sources
}

lua_src_test() {
busted --lua=${ELUA} || die
}

src_test() {
lua_foreach_impl lua_src_test
}

lua_src_compile() {
pushd "${BUILD_DIR}" || die

local myemakeargs=(
"CC=$(tc-getCC)"
"LD=$(tc-getCC)"
"LUAINC_linux=$(lua_get_include_dir)"
"MYCFLAGS=${CFLAGS}"
"MYLDFLAGS=${LDFLAGS}"
)

emake "${myemakeargs[@]}" linux

popd
}

src_compile() {
lua_foreach_impl lua_src_compile
}

lua_src_install () {
pushd "${BUILD_DIR}" || die

local emakeargs=(
"INSTALL_TOP_CDIR=${ED}/$(lua_get_cmod_dir)"
"INSTALL_TOP_LDIR=${ED}/$(lua_get_lmod_dir)"
"LUA_INC=${ED}/$(lua_get_include_dir)"
)

emake "${emakeargs[@]}" install

insinto $(lua_get_lmod_dir)/system
doins system/init.lua

popd
}

src_install() {
lua_foreach_impl lua_src_install

einstalldocs
}

0 comments on commit 67601d6

Please sign in to comment.