Skip to content

Commit

Permalink
Merge github#929: dev-util/idea-ultimate: Version bump to 15.0.4.
Browse files Browse the repository at this point in the history
Pull-Request: gentoo#929
Reporter: Matthew Brewer <[email protected]>
Acked-by: Gert Pellin <[email protected]>
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
monsieurp committed Feb 28, 2016
2 parents db7d253 + f54c798 commit 68d3cb1
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/idea-ultimate/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST idea-ultimate-14.1.5.141.2735.5.tar.gz 318054935 SHA256 6912902ec97a57f5553247367d6dd5b8e3041e99faf32c48b672cd31413dab73 SHA512 7ab3a45593c2324957455b254ae0257a36e8ecbc63014e18feba813413432dccb25d18971840f43cf22174c3338738eec44304091eb30c6ba2d0119b73cc6fa0 WHIRLPOOL 44a4bef99fdb638cf3cb0f24559b7765b7a4c7cb94aed5c3b8e503cbdf9fa1354f6d6026a9650fc58faec037b95482190891681f41219c61fc7d67a40e71f168
DIST ideaIU-143.1821.5.tar.gz 392844742 SHA256 90c2a880c03bc1213c41be05e56d50a5104175e2589e492ba140987b94d8680b SHA512 0841c3ea509500949358f826405d5c62d84f51657ce4ad621d3b33100a1966d8d85b793286cd4b85c6d2d6d0ca99c4b6a2f84cf5d596538cf530abf73fe8be21 WHIRLPOOL d59367e7671121619d0f787f585a4be436027e4ff39f10849566e441b407295166131cda8af506a7ecf5c34c21231bedd1419c4ee1e2657a38fa3b70a6b424dc
DIST ideaIU-143.2287.1.tar.gz 395915812 SHA256 c4365098055f492483204742626b77d6005f559bba2bb46ec161aa9ce7f12610 SHA512 ccf1191b1b94c8374f7abd3014970f6c85c0284e6bec43b0aafaa06bdb2c0e384c6681436d5b67714429fe9af9e2724123a39e674703055bd715608a91900327 WHIRLPOOL 7b9a7af5a380f5e6166e811f27750ea00b88e475f9e3a89421688e7cf0cf9c50dd63a66a70bf70d935aeadb66abca6308eb4da3fc287ed7aabfd9b325b6b4bad
DIST ideaIU-144.3143.6-custom-jdk-linux.tar.gz 444026233 SHA256 7d43fef31ec373fa700c1bcf6408429abf5549314f134e458335f52feb44772b SHA512 86ef4f9d89184acfcbaee8fbce67be8e226ab363df9892f803bb61fe61c50972bcf1ec260c9a9652998fc3f73cc72311950df3ae23bf01ae4a45336b7830ca01 WHIRLPOOL 9dee3db866fa55f2ddd3fa28120def4455ff4e7bc0a3a86289c6cb46f7a8a48c5fa0c6e9f35753b52cf66848831c3de2540d41673239130529c8848dba914aa6
DIST ideaIU-144.3143.6-no-jdk.tar.gz 399209252 SHA256 c11de6c199c90873976958c4e319176647fb4458370a041b8611007277a057d3 SHA512 6c4b8224901be58b0d41ca59dc6d8215510617470ed15b25c9d84074d4f660e335d6bb450062e353df3bb217a4892eb8783fc9086d2f4e4addada5aa7c5c7e85 WHIRLPOOL 2ea6bfc95c47fb20008c6503a2158a5a6d677e072cb9db41fba198d4dfda0df57db784b3289ecccd64849d1dc59fdb0f3b35aa3490323a7f40df383547cf940f
73 changes: 73 additions & 0 deletions dev-util/idea-ultimate/idea-ultimate-15.0.4.143.2287.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit eutils versionator

SLOT="0"
PV_STRING="$(get_version_component_range 4-6)"
MY_PV="$(get_version_component_range 1-3)"
MY_PN="idea"

# distinguish settings for official stable releases and EAP-version releases
if [[ "$(get_version_component_range 7)x" = "prex" ]]
then
# upstream EAP
KEYWORDS="~amd64 ~x86"
SRC_URI="custom-jdk? ( http://download.jetbrains.com/idea/${MY_PN}IU-${PV_STRING}-custom-jdk-linux.tar.gz )
!custom-jdk? ( http://download.jetbrains.com/idea/${MY_PN}IU-${PV_STRING}-no-jdk.tar.gz )"
else
# upstream stable
KEYWORDS="amd64 x86"
SRC_URI="http://download.jetbrains.com/idea/${MY_PN}IU-${MY_PV}.tar.gz -> ${MY_PN}IU-${PV_STRING}.tar.gz"
fi

DESCRIPTION="A complete toolset for web, mobile and enterprise development"
HOMEPAGE="http://www.jetbrains.com/idea"

LICENSE="IDEA
|| ( IDEA_Academic IDEA_Classroom IDEA_OpenSource IDEA_Personal )"
IUSE="-custom-jdk"

DEPEND="!dev-util/${PN}:14
!dev-util/${PN}:15"
RDEPEND="${DEPEND}
>=virtual/jdk-1.7:*"
S="${WORKDIR}/${MY_PN}-IU-${PV_STRING}"

QA_PREBUILT="opt/${PN}-${MY_PV}/*"

src_prepare() {
if ! use amd64; then
rm -r plugins/tfsIntegration/lib/native/linux/x86_64 || die
fi
if ! use arm; then
rm bin/fsnotifier-arm || die
rm -r plugins/tfsIntegration/lib/native/linux/arm || die
fi
if ! use ppc; then
rm -r plugins/tfsIntegration/lib/native/linux/ppc || die
fi
if ! use x86; then
rm -r plugins/tfsIntegration/lib/native/linux/x86 || die
fi
rm -r plugins/tfsIntegration/lib/native/solaris || die
rm -r plugins/tfsIntegration/lib/native/hpux || die
}

src_install() {
local dir="/opt/${PN}-${MY_PV}"

insinto "${dir}"
doins -r *
fperms 755 "${dir}"/bin/{idea.sh,fsnotifier{,64}}

make_wrapper "${PN}" "${dir}/bin/${MY_PN}.sh"
newicon "bin/${MY_PN}.png" "${PN}.png"
make_desktop_entry "${PN}" "IntelliJ Idea Ultimate" "${PN}" "Development;IDE;"

# recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
mkdir -p "${D}/etc/sysctl.d/" || die
echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-idea-inotify-watches.conf" || die
}

0 comments on commit 68d3cb1

Please sign in to comment.