forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-plugins/kodi-game-libretro-bnes: 0.83.0.4 version bump
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Craig Andrews <[email protected]>
- Loading branch information
Showing
2 changed files
with
39 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST kodi-game-libretro-bnes-0.83.0.3.tar.gz 809447 BLAKE2B 4efcc72c60ceb433f755afe39058cffc2c39f9ad3726bd407b832b39fc4e4eb85287f6fc25cdbbebfe1b21db4b567fcd260544c1de544ddff2a94ab190c643d8 SHA512 371830f91cf3f7f47b45cd86ec7438a697e0acf886881e87c6dc9218d599e983cac0a540065b6d45b9228b20dd2c1bc264345ee454b55f68d13c62e33944bfd4 | ||
DIST kodi-game-libretro-bnes-0.83.0.4.tar.gz 810686 BLAKE2B fc64d07a3629f00d658028a1f63ef4be640d511968bbd165019431563c84989c07fe11a132757b0ab64d0127e0b39d853525f615e25fea319bef2e8cb3435ea1 SHA512 5add79554a0064dfe9287961a20b80a5c8fd63598f173e254320b78347881f23c87653b742d6b759a1faa280496155c1822ef7ed4631c94fc35a99e7ca22932d |
38 changes: 38 additions & 0 deletions
38
media-plugins/kodi-game-libretro-bnes/kodi-game-libretro-bnes-0.83.0.4.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit cmake-utils kodi-addon | ||
|
||
DESCRIPTION="bNES GameClient for Kodi" | ||
HOMEPAGE="https://github.com/kodi-game/game.libretro.bnes" | ||
SRC_URI="" | ||
|
||
if [[ ${PV} == *9999 ]]; then | ||
SRC_URI="" | ||
EGIT_REPO_URI="https://github.com/kodi-game/game.libretro.bnes.git" | ||
inherit git-r3 | ||
else | ||
KEYWORDS="~amd64 ~x86" | ||
CODENAME="Leia" | ||
SRC_URI="https://github.com/kodi-game/game.libretro.bnes/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz" | ||
S="${WORKDIR}/game.libretro.bnes-${PV}-${CODENAME}" | ||
fi | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
IUSE="" | ||
|
||
DEPEND=" | ||
=media-tv/kodi-18* | ||
games-emulation/libretro-bnes | ||
" | ||
RDEPEND=" | ||
media-plugins/kodi-game-libretro | ||
${DEPEND} | ||
" | ||
src_prepare() { | ||
echo 'find_library(BNES_LIB NAMES bnes_libretro${CMAKE_SHARED_LIBRARY_SUFFIX} PATH_SUFFIXES libretro)' > "${S}/Findlibretro-bnes.cmake" || die | ||
default | ||
} |