forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/jinja2-time: fix arrow compat, py3.7 & py3.8
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
46 additions
and
10 deletions.
There are no files selected for viewing
38 changes: 38 additions & 0 deletions
38
dev-python/jinja2-time/files/jinja2-time-0.2.0-arrow-compat.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,38 @@ | ||
From aa4af9af0a0a5111a8ad21bc1b43bbdb586ee8af Mon Sep 17 00:00:00 2001 | ||
From: Vincent Bernat <[email protected]> | ||
Date: Sun, 3 Nov 2019 07:48:08 +0100 | ||
Subject: [PATCH] Use shift() instead of replace() to modify dates | ||
|
||
Previously, the `replace()` method from arrow was shifting the date | ||
when the arguments were using the plural form. Since Arrow 0.9.0, this | ||
has been deprecated in favor of a `shift()` method. Arrow 0.14.5 | ||
completely removed the ability for `replace()` to shift dates. This | ||
leads to errors like `AttributeError: unknown attribute: "hours"` when | ||
using plural form. | ||
|
||
This commit replace the use of `replace()` by `shift()` since the | ||
intent is always to shift the current date. | ||
--- | ||
jinja2_time/jinja2_time.py | 6 +++--- | ||
setup.py | 4 ++-- | ||
2 files changed, 5 insertions(+), 5 deletions(-) | ||
|
||
diff --git a/jinja2_time/jinja2_time.py b/jinja2_time/jinja2_time.py | ||
index ce713cb..717c8a0 100755 | ||
--- a/jinja2_time/jinja2_time.py | ||
+++ b/jinja2_time/jinja2_time.py | ||
@@ -19,11 +19,11 @@ def _datetime(self, timezone, operator, offset, datetime_format): | ||
d = arrow.now(timezone) | ||
|
||
# Parse replace kwargs from offset and include operator | ||
- replace_params = {} | ||
+ shift_params = {} | ||
for param in offset.split(','): | ||
interval, value = param.split('=') | ||
- replace_params[interval.strip()] = float(operator + value.strip()) | ||
- d = d.replace(**replace_params) | ||
+ shift_params[interval.strip()] = float(operator + value.strip()) | ||
+ d = d.shift(**shift_params) | ||
|
||
if datetime_format is None: | ||
datetime_format = self.environment.datetime_format |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters