Skip to content

Commit

Permalink
dev-python/aodhclient: adding for heat
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
prometheanfire committed Oct 3, 2016
1 parent b91ea27 commit 916114b
Show file tree
Hide file tree
Showing 3 changed files with 58 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/aodhclient/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST aodhclient-0.6.0.tar.gz 40827 SHA256 eb33dd5b215a137d052cdbf12d9c7a2ab3d1fe52702ffd2323e57d2fa759363d SHA512 daa3f568cc2c59a010024beecf2917bf7e3ee64a0a18851e19c92dba159fcd2f36e64dd418ac4a36ee93b0a06c8c00b1f222aebfa915e9bddeaca074a12568bc WHIRLPOOL 2e71b890b392f6c00abe2c5fb45dfdf98215403612de2d50f19c4c9a82cde91c5cd7691fe51c3838ab6a7009824dfa01ca1430b95c86a9ac41fdea005758e915
38 changes: 38 additions & 0 deletions dev-python/aodhclient/aodhclient-0.6.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python2_7 python3_4 python3_5 )

inherit distutils-r1

DESCRIPTION="A client for the OpenStack Aodh API"
HOMEPAGE="https://github.com/openstack/python-aodhclient"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"

CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}"
RDEPEND="
${CDEPEND}
>=dev-python/cliff-1.14.0[${PYTHON_USEDEP}]
!~dev-python/cliff-1.16.0[${PYTHON_USEDEP}]
>=dev-python/osc-lib-1.0.1[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
>=dev-python/oslo-serialization-1.10.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
>=dev-python/keystoneauth-2.10.0[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
>=dev-python/debtcollector-1.3.0[${PYTHON_USEDEP}]
"

python_prepare_all() {
# built in...
sed -i '/^hacking/d' test-requirements.txt || die
distutils-r1_python_prepare_all
}
19 changes: 19 additions & 0 deletions dev-python/aodhclient/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Matthew Thode</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Openstack</name>
</maintainer>
<longdescription lang="en">
This is a client for the OpenStack Aodh API.
</longdescription>
<upstream>
<remote-id type="pypi">python-aodhclient</remote-id>
<remote-id type="github">openstack/python-aodhclient</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 916114b

Please sign in to comment.