forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-cpp/libcmis: Add upstream patches to fix bugs 556914, 569614
All tests passed. Package-Manager: portage-2.2.27
- Loading branch information
Showing
4 changed files
with
87 additions
and
15 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
From b572b60a5fdc630f7f3b31dfd5dbdd1ed48659ca Mon Sep 17 00:00:00 2001 | ||
From: =?UTF-8?q?C=C3=A9dric=20Bosdonnat?= <[email protected]> | ||
Date: Thu, 16 Jul 2015 16:22:11 +0200 | ||
Subject: [PATCH] Fix linking error when building with --with-boot | ||
|
||
--- | ||
src/libcmis/Makefile.am | 1 + | ||
1 file changed, 1 insertion(+) | ||
|
||
diff --git a/src/libcmis/Makefile.am b/src/libcmis/Makefile.am | ||
index 3915d45..1955ea6 100644 | ||
--- a/src/libcmis/Makefile.am | ||
+++ b/src/libcmis/Makefile.am | ||
@@ -144,6 +144,7 @@ libcmis_@LIBCMIS_API_VERSION@_la_LIBADD = \ | ||
$(XML2_LIBS) \ | ||
$(CURL_LIBS) \ | ||
$(BOOST_SMART_PTR_LIBS) \ | ||
+ $(BOOST_DATE_TIME_LDFLAGS) \ | ||
$(BOOST_DATE_TIME_LIBS) | ||
|
||
libcmis_@LIBCMIS_API_VERSION@_la_includedir = $(includedir)/libcmis-@LIBCMIS_API_VERSION@/libcmis |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,44 @@ | ||
From 0ad3ec084d918be503a8ce971af1b54887d7726f Mon Sep 17 00:00:00 2001 | ||
From: =?UTF-8?q?C=C3=A9dric=20Bosdonnat?= <[email protected]> | ||
Date: Thu, 16 Jul 2015 16:23:06 +0200 | ||
Subject: [PATCH] Getting cppcheck-test to pass again | ||
|
||
--- | ||
Makefile.am | 1 + | ||
cppcheck-suppress | 3 +++ | ||
cppcheck-test.sh.in | 4 +++- | ||
3 files changed, 7 insertions(+), 1 deletion(-) | ||
create mode 100644 cppcheck-suppress | ||
|
||
diff --git a/Makefile.am b/Makefile.am | ||
index ebf1f3b..9263497 100644 | ||
--- a/Makefile.am | ||
+++ b/Makefile.am | ||
@@ -35,6 +35,7 @@ EXTRA_DIST = \ | ||
COPYING.LGPL \ | ||
doc/cmis-client.xml \ | ||
cppcheck-test.sh \ | ||
+ cppcheck-suppress \ | ||
qa/libcmis/data | ||
|
||
if ENABLE_CPPCHECK | ||
diff --git a/cppcheck-suppress b/cppcheck-suppress | ||
new file mode 100644 | ||
index 0000000..9ef8482 | ||
--- /dev/null | ||
+++ b/cppcheck-suppress | ||
@@ -0,0 +1,3 @@ | ||
+publicAllocationError:qa/libcmis/test-decoder.cxx | ||
+noExplicitConstructor | ||
+noExplicitCopyMoveConstructor | ||
diff --git a/cppcheck-test.sh.in b/cppcheck-test.sh.in | ||
index 20a73f8..175e0f5 100755 | ||
--- a/cppcheck-test.sh.in | ||
+++ b/cppcheck-test.sh.in | ||
@@ -1,3 +1,5 @@ | ||
#!/bin/sh | ||
-@CPPCHECK@ -q --enable=style,performance,portability,information --error-exitcode=1 @SRCDIR@ | ||
+@CPPCHECK@ -q --enable=style,performance,portability,information \ | ||
+ --suppressions-list=./cppcheck-suppress \ | ||
+ --error-exitcode=1 @SRCDIR@ | ||
exit $? |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters