Skip to content

Commit

Permalink
dev-cpp/libcmis: Add upstream patches to fix bugs 556914, 569614
Browse files Browse the repository at this point in the history
All tests passed.

Package-Manager: portage-2.2.27
  • Loading branch information
a17r authored and akhuettel committed Feb 22, 2016
1 parent 3bbf650 commit 9527828
Show file tree
Hide file tree
Showing 4 changed files with 87 additions and 15 deletions.
21 changes: 21 additions & 0 deletions dev-cpp/libcmis/files/libcmis-0.5.0-boost-linking.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
From b572b60a5fdc630f7f3b31dfd5dbdd1ed48659ca Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?C=C3=A9dric=20Bosdonnat?= <[email protected]>
Date: Thu, 16 Jul 2015 16:22:11 +0200
Subject: [PATCH] Fix linking error when building with --with-boot

---
src/libcmis/Makefile.am | 1 +
1 file changed, 1 insertion(+)

diff --git a/src/libcmis/Makefile.am b/src/libcmis/Makefile.am
index 3915d45..1955ea6 100644
--- a/src/libcmis/Makefile.am
+++ b/src/libcmis/Makefile.am
@@ -144,6 +144,7 @@ libcmis_@LIBCMIS_API_VERSION@_la_LIBADD = \
$(XML2_LIBS) \
$(CURL_LIBS) \
$(BOOST_SMART_PTR_LIBS) \
+ $(BOOST_DATE_TIME_LDFLAGS) \
$(BOOST_DATE_TIME_LIBS)

libcmis_@LIBCMIS_API_VERSION@_la_includedir = $(includedir)/libcmis-@LIBCMIS_API_VERSION@/libcmis
44 changes: 44 additions & 0 deletions dev-cpp/libcmis/files/libcmis-0.5.0-cppcheck.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
From 0ad3ec084d918be503a8ce971af1b54887d7726f Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?C=C3=A9dric=20Bosdonnat?= <[email protected]>
Date: Thu, 16 Jul 2015 16:23:06 +0200
Subject: [PATCH] Getting cppcheck-test to pass again

---
Makefile.am | 1 +
cppcheck-suppress | 3 +++
cppcheck-test.sh.in | 4 +++-
3 files changed, 7 insertions(+), 1 deletion(-)
create mode 100644 cppcheck-suppress

diff --git a/Makefile.am b/Makefile.am
index ebf1f3b..9263497 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,6 +35,7 @@ EXTRA_DIST = \
COPYING.LGPL \
doc/cmis-client.xml \
cppcheck-test.sh \
+ cppcheck-suppress \
qa/libcmis/data

if ENABLE_CPPCHECK
diff --git a/cppcheck-suppress b/cppcheck-suppress
new file mode 100644
index 0000000..9ef8482
--- /dev/null
+++ b/cppcheck-suppress
@@ -0,0 +1,3 @@
+publicAllocationError:qa/libcmis/test-decoder.cxx
+noExplicitConstructor
+noExplicitCopyMoveConstructor
diff --git a/cppcheck-test.sh.in b/cppcheck-test.sh.in
index 20a73f8..175e0f5 100755
--- a/cppcheck-test.sh.in
+++ b/cppcheck-test.sh.in
@@ -1,3 +1,5 @@
#!/bin/sh
-@CPPCHECK@ -q --enable=style,performance,portability,information --error-exitcode=1 @SRCDIR@
+@CPPCHECK@ -q --enable=style,performance,portability,information \
+ --suppressions-list=./cppcheck-suppress \
+ --error-exitcode=1 @SRCDIR@
exit $?
18 changes: 11 additions & 7 deletions dev-cpp/libcmis/libcmis-0.5.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -22,16 +22,12 @@ KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"

IUSE="static-libs man test"

RDEPEND="
!dev-cpp/libcmis:0
!dev-cpp/libcmis:0.2
!dev-cpp/libcmis:0.3
!dev-cpp/libcmis:0.4
COMMON_DEPEND="
dev-libs/boost:=
dev-libs/libxml2
net-misc/curl
"
DEPEND="${RDEPEND}
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
man? (
app-text/docbook2X
Expand All @@ -42,9 +38,17 @@ DEPEND="${RDEPEND}
dev-util/cppunit
)
"
RDEPEND="${COMMON_DEPEND}
!dev-cpp/libcmis:0
!dev-cpp/libcmis:0.2
!dev-cpp/libcmis:0.3
!dev-cpp/libcmis:0.4
"

src_prepare() {
epatch "${WORKDIR}/${P}-gcc5.patch"
epatch "${FILESDIR}/${P}-boost-linking.patch" \
"${FILESDIR}/${P}-cppcheck.patch"
eautoreconf
}

Expand Down
19 changes: 11 additions & 8 deletions dev-cpp/libcmis/libcmis-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
EAPI=6

EGIT_REPO_URI="git://git.code.sf.net/p/libcmis/code"
[[ ${PV} == 9999 ]] && SCM_ECLASS="git-r3"
Expand All @@ -22,16 +22,12 @@ KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"

IUSE="static-libs man test"

RDEPEND="
!dev-cpp/libcmis:0
!dev-cpp/libcmis:0.2
!dev-cpp/libcmis:0.3
!dev-cpp/libcmis:0.4
COMMON_DEPEND="
dev-libs/boost:=
dev-libs/libxml2
net-misc/curl
"
DEPEND="${RDEPEND}
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
man? (
app-text/docbook2X
Expand All @@ -42,8 +38,15 @@ DEPEND="${RDEPEND}
dev-util/cppunit
)
"
RDEPEND="${COMMON_DEPEND}
!dev-cpp/libcmis:0
!dev-cpp/libcmis:0.2
!dev-cpp/libcmis:0.3
!dev-cpp/libcmis:0.4
"

src_prepare() {
eapply_user
[[ ${PV} == 9999 ]] && eautoreconf
}

Expand Down

0 comments on commit 9527828

Please sign in to comment.