forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-board/gtkatlantic: version bump
Package-Manager: portage-2.2.26
- Loading branch information
Michael Sterrett
committed
Jan 8, 2016
1 parent
5d6fa1a
commit b5e0cc7
Showing
3 changed files
with
64 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gtkatlantic-0.5.0.tar.bz2 782124 SHA256 065f649e37144a545936546c8655c5d66558415c259c4838c101ab1c733e0d86 SHA512 5aa332af2f17612caae0e396614ddfecbb1df4ad1f2c15a402efea5e96fde72cb0aefa87e690234382b82d03904e7235536434e455827b838a988c13eaa78bfe WHIRLPOOL 48e0e44ecedb02686414b1fdbfbf355b7e214c31edc1db70f90657489b19fb65d5a984c5814f31aab045e3c0837e3978e105a330510a42704c05995a1b3a1556 | ||
DIST gtkatlantic-0.6.1.tar.bz2 505701 SHA256 ab57fca9c45854752b4da77b749328884ddc975e9636ae6c73cc191f1d7eb331 SHA512 8388cbdd4c73d56eacb18a645bdd2d1f6e1fa8d21be972eaba1c4d6af6d0681a2a54909a82d6846ddd785b46b0ad99193e5afea528c5662956ff89a1e6e366df WHIRLPOOL 909331b930c540131bebcc7f1fd25ec36fa75f934ac23e21581c099aea61a78282ac5a9533b6a8622b4a76e482c023c54261bb98a5b563fa9563a3a4c5314d29 |
10 changes: 10 additions & 0 deletions
10
games-board/gtkatlantic/files/gtkatlantic-0.6.1-warnings.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,10 @@ | ||
--- src/readpng.c.orig | ||
+++ src/readpng.c | ||
@@ -23,6 +23,7 @@ | ||
|
||
#include <stdio.h> | ||
#include <stdlib.h> | ||
+#include <string.h> | ||
#include <glib.h> | ||
|
||
#include <png.h> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
inherit autotools eutils gnome2-utils games | ||
|
||
DESCRIPTION="Monopoly-like game that works with the monopd server" | ||
HOMEPAGE="http://gtkatlantic.gradator.net/" | ||
SRC_URI="http://download.tuxfamily.org/gtkatlantic/downloads/v0.6/${P}.tar.bz2" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~ppc ~x86" | ||
IUSE="" | ||
|
||
RDEPEND="x11-libs/gtk+:3 | ||
dev-libs/libxml2 | ||
media-libs/libpng:0" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
src_prepare() { | ||
sed -i -e 's:$(datadir):/usr/share:' {,data/}Makefile.am || die | ||
sed -i -e 's/configure.in/configure.ac/' configure.in || die | ||
mv configure.{in,ac} || die | ||
epatch "${FILESDIR}"/${P}-warnings.patch | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
egamesconf \ | ||
--with-icons-path=/usr/share/icons/hicolor | ||
} | ||
|
||
src_install() { | ||
default | ||
prepgamesdirs | ||
} | ||
|
||
pkg_preinst() { | ||
games_pkg_preinst | ||
gnome2_icon_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
games_pkg_postinst | ||
gnome2_icon_cache_update | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_icon_cache_update | ||
} |