Skip to content

Commit

Permalink
games-misc/gBhed: remove deprecated games eclass
Browse files Browse the repository at this point in the history
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0
  • Loading branch information
austin987 committed Oct 11, 2016
1 parent 0b609ec commit b9e5b5c
Showing 1 changed file with 44 additions and 0 deletions.
44 changes: 44 additions & 0 deletions games-misc/gBhed/gBhed-0.17-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils

DESCRIPTION="An Al Bhed translator"
HOMEPAGE="http://liquidchile.net/software/gbhed/"
SRC_URI="http://liquidchile.net/software/gbhed/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="gtk"

DEPEND="gtk? ( x11-libs/gtk+:2 )"
RDEPEND=${DEPEND}

src_prepare() {
default

sed -i 's/19/32/' src/gui/translation_fork.c || die
}

src_configure() {
econf \
--datadir=/usr/share/${PN} \
$(use_enable gtk gbhed)
}

src_install() {
emake -C src DESTDIR="${D}" install
dodoc AUTHORS ChangeLog NEWS README THANKS TODO
doman doc/abtranslate.1

if use gtk ; then
insinto /usr/share/${PN}/pixmaps
doins pixmaps/*.{jpg,png,xpm}
newicon pixmaps/gbhed48.png ${PN}.png
make_desktop_entry gbhed ${PN}
doman doc/gbhed.1
fi
}

0 comments on commit b9e5b5c

Please sign in to comment.