forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/libmpdclient: version bump to 2.13
- Loading branch information
Showing
2 changed files
with
48 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST libmpdclient-2.10.tar.xz 261792 SHA256 4f08cde82dae70895f8e4532a6e9b54b201efd5591c6b5d6834895807ed2ff82 SHA512 f54fc3501643ece4eee2f63ddbf5f3d676f3843be0859f482d70cc142b6d9dfbdebd511ccc52a9c058a644e3b80c93a680e1de19f6f3ebfc46cb197f0ddddb5b WHIRLPOOL b97f9024f1c18233019d94501e0f60055a03001e5342884a275768ac297ad11a6ab865e0849f6c274067f7952ed22c2f7bb14f6349b94df5643150a883c47840 | ||
DIST libmpdclient-2.11.tar.xz 274836 SHA256 15fe693893c0d7ea3f4c35c4016fbd0332836164178b20983eec9b470846baf6 SHA512 0503db31262acfb871578278d6526e12ee2ffbbe414425ab5ebac61f27da8ad4503d948b4d192421d301bd0a29b9b460f195e82a44608f984697a8aa47b2eb9b WHIRLPOOL b2480e9cc02f49b76abd0fd385f748ce6b9cfa901f6b338d2f10a18ccc82c9587edb1cf2bc7dd582deaf123725fba296d8716bf25b2ffd313b3f28fa2343497d | ||
DIST libmpdclient-2.13.tar.xz 56964 SHA256 5115bd52bc20a707c1ecc7587e6389c17305348e2132a66cf767c62fc55ed45d SHA512 a2aa4e1e4fcb4ab390a0a38e745e59a9764c40bfcd07d449fdc7fef7b0c5fc0c2e795ef545b6fa6d62c00861d306cab41ea43011510ad1e3a60603873a3c1b28 WHIRLPOOL c227976788e9bd8f41d0fa87d41d4072af4048eaf57360e2318765f2bb2e52d069c9b9e7f2bb27d2787bbed44d1c15ce0de01a977712de52ca8a131cf734742d | ||
DIST libmpdclient-2.9.tar.xz 253992 SHA256 7cc97ba560e91addafe5975f7e7da04b95d6710750e47b3367fa0d8c3b7699ca SHA512 7e6af51e31a3319e6681dfe5199fda1b2c1482f6aa6854af7c7f02c999fbbeae4f369c9b157abf95402c7f022d155109454b243549185ba791df5b2457baaba4 WHIRLPOOL d4d78a83bfa300be8df37e321c3b8ed535bd7342acc1ec371a2aa59a76efde79a9c4531bc8052c5d0c2c423d808f23b2e5d3b92ccf5c9dec4f2a120b615a4992 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,47 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit meson | ||
|
||
DESCRIPTION="A library for interfacing Music Player Daemon (media-sound/mpd)" | ||
HOMEPAGE="https://www.musicpd.org https://github.com/MusicPlayerDaemon/libmpdclient" | ||
SRC_URI="https://www.musicpd.org/download/${PN}/${PV%.*}/${P}.tar.xz" | ||
|
||
LICENSE="BSD" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86" | ||
IUSE="doc examples test" | ||
|
||
RDEPEND="" | ||
DEPEND=" | ||
doc? ( app-doc/doxygen ) | ||
test? ( dev-libs/check ) | ||
" | ||
|
||
src_prepare() { | ||
default | ||
|
||
sed -i "s:@top_srcdir@:.:" doc/doxygen.conf.in || die | ||
|
||
# meson doesn't support setting docdir | ||
sed -e "/^docdir =/s/meson.project_name()/'${PF}'/" \ | ||
-e "/^install_data(/s/'COPYING', //" \ | ||
-i meson.build || die | ||
} | ||
|
||
src_configure() { | ||
local emesonargs=( | ||
-Ddocumentation=$(usex doc true false) | ||
-Dtest=$(usex test true false) | ||
) | ||
meson_src_configure | ||
} | ||
|
||
src_install() { | ||
meson_src_install | ||
|
||
use examples && dodoc src/example.c | ||
use doc || rm -rf "${ED}"/usr/share/doc/${PF}/html | ||
} |