Skip to content

Commit

Permalink
x11-misc/piedock: Use pkg-config to find freetype.
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/655530
Package-Manager: Portage-2.3.36, Repoman-2.3.9
  • Loading branch information
Lars Wendler committed May 11, 2018
1 parent 7da4d10 commit c1ba529
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 8 deletions.
45 changes: 45 additions & 0 deletions x11-misc/piedock/files/piedock-1.6.9-freetype_pkgconfig.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
From 3f37592025333532e98bbe96c2b0903bb881b9c0 Mon Sep 17 00:00:00 2001
From: Lars Wendler <[email protected]>
Date: Fri, 11 May 2018 23:21:33 +0200
Subject: [PATCH] Use pkg-config to find freetype

As of freetype-2.9.1 the freetype-config file no longer gets installed
by default.
---
configure.ac | 13 ++++---------
1 file changed, 4 insertions(+), 9 deletions(-)

diff --git a/configure.ac b/configure.ac
index 0c452ad..96a51e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,6 +12,7 @@ AC_LANG_CPLUSPLUS
AC_PROG_CXX
AC_PROG_CC
AC_PROG_INSTALL
+PKG_PROG_PKG_CONFIG

# Checks for mandatory libraries
AC_CHECK_LIB([X11], [XOpenDisplay], , AC_MSG_ERROR([libX11 not found]))
@@ -47,15 +48,9 @@ AC_ARG_ENABLE(

# Checks for Freetype
if test "x$XFT" = "xtrue"; then
- AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
-
- if test x$FREETYPE_CONFIG = xno; then
- AC_MSG_ERROR([*** freetype-config not found])
- fi
-
- FREETYPE_CFLAGS="`$FREETYPE_CONFIG --cflags`"
- FREETYPE_LIBS="`$FREETYPE_CONFIG --libs`"
- CXXFLAGS="$CXXFLAGS $FREETYPE_CFLAGS"
+ PKG_CHECK_MODULES(FREETYPE, freetype2, [
+ CXXFLAGS="$CXXFLAGS $FREETYPE_CFLAGS"
+ ], AC_MSG_ERROR([Cannot find freetype]))
fi

# Checks for Xrender
--
2.17.0

30 changes: 22 additions & 8 deletions x11-misc/piedock/piedock-1.6.9.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -3,6 +3,8 @@

EAPI=6

inherit autotools

DESCRIPTION="A little bit like the famous OS X dock but in shape of a pie menu"
HOMEPAGE="
http://markusfisch.de/PieDock
Expand Down Expand Up @@ -30,19 +32,31 @@ RDEPEND="
x11-libs/gtk+:2
)
"
DEPEND="${RDEPEND}"
DEPEND="${RDEPEND}
virtual/pkgconfig"

DOCS=( res/${PN}rc.sample AUTHORS ChangeLog NEWS )

PATCHES=(
"${FILESDIR}"/${PN}-1.6.1-signals.patch
"${FILESDIR}"/${PN}-1.6.9-freetype_pkgconfig.patch
)
S=${WORKDIR}/PieDock-${PV}

S="${WORKDIR}/PieDock-${PV}"

src_prepare() {
default
eautoreconf
}

src_configure() {
econf \
$(use_enable gtk) \
--disable-kde \
--bindir="${EPREFIX}"/usr/bin \
--enable-xft \
--enable-xmu \
local myeconfargs=(
$(use_enable gtk)
--disable-kde
--bindir="${EPREFIX}"/usr/bin
--enable-xft
--enable-xmu
--enable-xrender
)
econf "${myeconfargs[@]}"
}

0 comments on commit c1ba529

Please sign in to comment.